removing patches

This commit is contained in:
Mahesh Chittur 2005-12-31 02:58:32 +00:00 committed by Thomas Klausner
parent 890f7797a5
commit d510c9f5d8
10 changed files with 0 additions and 346 deletions

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aa,v 1.2 2005/04/19 22:30:24 daprice Exp $
--- configure.orig 2005-03-02 21:42:33.000000000 -0700
+++ configure
@@ -24845,7 +24845,7 @@ echo "$as_me: error: --with-mysql argume
{ (exit 1); exit 1; }; }
fi
- MYSQL_VERSION="`$MYSQL_CONFIG --version`"
+ MYSQL_VERSION="`$MYSQL_CONFIG --version | sed -n 's/\(.*\)\..*\..*/\1/p'`"
case ${MYSQL_VERSION} in
[0-3]*)
@@ -25346,7 +25346,7 @@ fi
if test "$GEOS_CONFIG" != "no" ; then
VERSION=`$GEOS_CONFIG --version`
- if test "${VERSION:0:1}" -lt 2 ; then
+ if test `echo $VERSION | sed -n 's/\(.*\)\..*\..*/\1/p'` -lt 2 ; then
{ { echo "$as_me:$LINENO: error: geos-config reports version $VERSION, need at least 2.0 or configure --without-geos" >&5
echo "$as_me: error: geos-config reports version $VERSION, need at least 2.0 or configure --without-geos" >&2;}
{ (exit 1); exit 1; }; }

View file

@ -1,43 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2005/03/17 21:53:23 daprice Exp $
--- configure.orig 2004-11-22 12:54:17.000000000 -0700
+++ configure
@@ -24724,7 +24724,7 @@ if test "$PG_CONFIG" = "no" ; then
PG_INC=
echo "$as_me:$LINENO: result: no" >&5
-echo "${ECHO_T}no" >&6LIBZ
+echo "${ECHO_T}no" >&6
else
if test -d $PG_CONFIG ; then
@@ -24843,9 +24843,9 @@ echo "$as_me: error: --with-mysql argume
{ (exit 1); exit 1; }; }
fi
- MYSQL_VERSION="`$MYSQL_CONFIG --version`"
+ MYSQL_VERSION="`$MYSQL_CONFIG --version | sed -n 's/\(.*\)\..*\..*/\1/p`"
- if test ${MYSQL_VERSION:0:1} -ge 4 ; then
+ if test $MYSQL_VERSION -ge 4 ; then
HAVE_MYSQL=yes
MYSQL_LIB="`$MYSQL_CONFIG --libs`"
MYSQL_INC="`$MYSQL_CONFIG --include`"
@@ -25341,7 +25341,7 @@ fi
if test "$GEOS_CONFIG" != "no" ; then
VERSION=`$GEOS_CONFIG --version`
- if test "${VERSION:0:1}" -lt 2 ; then
+ if test `echo $VERSION | sed -n 's/\(.*\)\..*\..*/\1/p'` -lt 2 ; then
{ { echo "$as_me:$LINENO: error: geos-config reports version $VERSION, need at least 2.0 or configure --without-geos" >&5
echo "$as_me: error: geos-config reports version $VERSION, need at least 2.0 or configure --without-geos" >&2;}
{ (exit 1); exit 1; }; }
@@ -25950,7 +25950,7 @@ if test "${with_python+set}" = set; then
fi;
-for ac_prog in python python1.5 python1.4 python1.3
+for ac_prog in python python2.4 python2.3 python1.5 python1.4 python1.3
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2

View file

@ -1,26 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 2005/03/17 21:53:23 daprice Exp $
--- pymod/GNUmakefile.orig 2004-02-25 00:48:17.000000000 -0700
+++ pymod/GNUmakefile
@@ -9,8 +9,8 @@ CPPFLAGS := $(GDAL_INCLUDE) $(PYTHON_INC
CFLAGS := $(PYTHON_CFLAGS) $(CFLAGS)
CXXFLAGS := $(PYTHON_CFLAGS) $(CXXFLAGS)
-PY_COMMANDS = epsg_tr.py gdalchksum.py gdal2xyz.py gcps2wld.py \
- gdalimport.py gdal_merge.py pct2rgb.py rgb2pct.py
+PY_COMMANDS = epsg_tr gdalchksum gdal2xyz gcps2wld \
+ gdalimport gdal_merge pct2rgb rgb2pct
PY_MODULES = gdal.py ogr.py osr.py gdalconst.py gdalnumeric.py
# this is needed during install due to the _gdalmodule.so library
@@ -42,7 +42,9 @@ $(GDALMODULE).la: $(OBJ:.o=.lo) $(EXE_DE
install: $(GDALMODULE).$(SO_EXT)
$(INSTALL_DIR) $(INST_PYMOD)
$(INSTALL_LIB) $(GDALMODULE).$(SO_EXT) $(INST_PYMOD)
- for f in $(PY_COMMANDS) ; do $(INSTALL) $$f $(INST_BIN) ; done
+ for f in $(PY_COMMANDS) ; do \
+ sed -e "s:/usr/bin/env\ python:$(prefix)/bin/$(PYTHON):g" $$f.py > $$f ; \
+ $(INSTALL) $$f $(INST_BIN) ; done
for f in $(PY_MODULES) ; do $(INSTALL_DATA) $$f $(INST_PYMOD) ; done
# ugh! spurius relinking leaves a file owned by root into .libs/.
rm -f .libs/*.soT

View file

@ -1,78 +0,0 @@
$NetBSD: patch-ad,v 1.2 2005/04/19 22:30:24 daprice Exp $
--- GNUmakefile.orig 2005-03-01 10:55:40.000000000 -0700
+++ GNUmakefile
@@ -21,7 +21,7 @@ LIBGDAL-$(HAVE_LD_SHARED) += $(GDAL_SLIB
# override if we are using libtool
LIBGDAL-$(HAVE_LIBTOOL) := $(LIBGDAL)
-default: lib-target py-target apps-target
+default: lib-target apps-target
lib-target: check-lib;
@@ -74,11 +74,11 @@ ogr-apps: lib-target
#
# We only make python a default target if we think python is installed.
#
-ifeq ($(PYTHON),no)
-py-target: ;
-else
-py-target: py-module;
-endif
+#ifeq ($(PYTHON),no)
+#py-target: ;
+#else
+#py-target: py-module;
+#endif
clean: lclean
(cd port; $(MAKE) clean)
@@ -87,10 +87,10 @@ clean: lclean
(cd frmts; $(MAKE) clean)
(cd alg; $(MAKE) clean)
(cd apps; $(MAKE) clean)
- (cd pymod; $(MAKE) clean)
+# (cd pymod; $(MAKE) clean)
-py-module: lib-target
- (cd pymod; $(MAKE))
+#py-module: lib-target
+# (cd pymod; $(MAKE))
lclean:
rm -f *.a *.so config.log config.cache html/*.*
@@ -112,15 +112,15 @@ configure: configure.in aclocal.m4
GDALmake.opt: GDALmake.opt.in config.status
./config.status
-docs:
- (cd ogr; $(MAKE) docs)
- (cd html; rm -f *.*)
- doxygen
- doxygen Doxyfile.man
- cp data/gdalicon.png html
- cp doc/ERMapperlogo_small.gif html
- cp frmts/*.html frmts/*/frmt_*.html html
- python doc/mkindex.py
+#docs:
+# (cd ogr; $(MAKE) docs)
+# (cd html; rm -f *.*)
+# doxygen
+# doxygen Doxyfile.man
+# cp data/gdalicon.png html
+# cp doc/ERMapperlogo_small.gif html
+# cp frmts/*.html frmts/*/frmt_*.html html
+# python doc/mkindex.py
all: default ogr-all
@@ -146,7 +146,7 @@ install-actions: install-lib
(cd apps; $(MAKE) install)
(cd man; $(MAKE) install)
ifneq ($(PYTHON),no)
- (cd pymod; $(MAKE) install)
+# (cd pymod; $(MAKE) install)
endif
for f in data/*.* ; do $(INSTALL_DATA) $$f $(INST_DATA) ; done
$(LIBTOOL_FINISH) $(INST_LIB)

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ae,v 1.2 2005/04/19 22:30:24 daprice Exp $
--- frmts/dods/GNUmakefile.orig 2005-04-09 11:34:35.000000000 -0600
+++ frmts/dods/GNUmakefile
@@ -23,8 +23,8 @@ dodsdataset_test: dodsdataset_test.o dod
$(LD) $(LNK_FLAGS) -static -g3 $^ $(XTRAOBJ) $(LIBS) $(LIBGDAL) \
-lcppunit -lxml2 -o $@$(EXE)
-docs:
- doxygen
+#docs:
+# doxygen
clean:
-rm -f *.o *.lo *~ $(O_OBJ)

View file

@ -1,28 +0,0 @@
$NetBSD: patch-af,v 1.2 2005/04/19 22:30:24 daprice Exp $
--- frmts/gxf/GNUmakefile.orig 2005-04-09 11:35:07.000000000 -0600
+++ frmts/gxf/GNUmakefile
@@ -28,10 +28,10 @@ $(SHARED_LIB): $(OBJ)
install-lib: $(SHARED_LIB)
cp $(SHARED_LIB) $(GDAL_ROOT)/lib
-docs:
- rm -rf html
- mkdir html
- doxygen
+#docs:
+# rm -rf html
+# mkdir html
+# doxygen
update-web: dist
cp html/* $(WEB_DIR)
@@ -39,7 +39,7 @@ update-web: dist
cp $(DISTDIR).zip /u/ftp/pub/outgoing
-dist: docs
+dist:
rm -rf $(DISTDIR)
mkdir $(DISTDIR)
mkdir $(DISTDIR)/html

View file

@ -1,44 +0,0 @@
$NetBSD: patch-ag,v 1.2 2005/04/19 22:30:24 daprice Exp $
--- frmts/iso8211/GNUmakefile.orig 2005-04-09 11:35:50.000000000 -0600
+++ frmts/iso8211/GNUmakefile
@@ -14,7 +14,7 @@ OBJ = ddfmodule.o ddfutils.o ddffielddef
default: $(ISOLIB)
-all: $(ISOLIB) 8211dump 8211view mkcatalog docs
+all: $(ISOLIB) 8211dump 8211view mkcatalog
clean:
rm -rf *.o 8211dump 8211view $(DISTDIR) $(DISTDIR).tar.gz html/* \
@@ -47,14 +47,14 @@ mkcatalog: mkcatalog.o $(ISOLIB)
$(CXX) $(CXX_ODFLAGS) mkcatalog.o \
$(ISOLIB) $(GDAL_LIB) $(LIBS) -o mkcatalog
-docs:
- rm -rf html
- mkdir html
- doxygen
- rm html/index.html
- cp html/ISO8211Lib.html html/index.html
+#docs:
+# rm -rf html
+# mkdir html
+# doxygen
+# rm html/index.html
+# cp html/ISO8211Lib.html html/index.html
-dist: docs
+dist:
rm -rf $(DISTDIR)
mkdir $(DISTDIR)
mkdir $(DISTDIR)/html
@@ -72,7 +72,7 @@ dist: docs
tar czf $(DISTDIR).tar.gz $(DISTDIR)
zip -r $(DISTDIR).zip $(DISTDIR)
-update-web: dist docs
+update-web: dist
cp html/* $(WEB_DIR)
cp $(DISTDIR).tar.gz $(DISTDIR).zip $(WEB_DIR)
cp $(DISTDIR).tar.gz $(DISTDIR).zip /u/ftp/pub/outgoing

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ah,v 1.2 2005/04/19 22:30:24 daprice Exp $
--- frmts/pcraster/GNUmakefile.orig 2005-04-09 11:36:40.000000000 -0600
+++ frmts/pcraster/GNUmakefile
@@ -14,8 +14,8 @@ clean:
install-obj: $(O_OBJ)
-docs:
- doxygen doxygen.cfg
+#docs:
+# doxygen doxygen.cfg
ctags:
ctags *cpp *h

View file

@ -1,34 +0,0 @@
$NetBSD: patch-ai,v 1.2 2005/04/19 22:30:24 daprice Exp $
--- frmts/sdts/GNUmakefile.orig 2005-04-09 11:36:59.000000000 -0600
+++ frmts/sdts/GNUmakefile
@@ -40,14 +40,14 @@ sdts2shp: sdts2shp.cpp $(SDTSLIB)
install-obj: $(O_OBJ) ../o/sdtsdataset.o
-docs:
- rm -rf html
- mkdir html
- doxygen
- rm html/index.html
- cp html/sdts_al_main.html html/index.html
+#docs:
+# rm -rf html
+# mkdir html
+# doxygen
+# rm html/index.html
+# cp html/sdts_al_main.html html/index.html
-dist: docs
+dist:
rm -rf $(DISTDIR)
mkdir $(DISTDIR)
mkdir $(DISTDIR)/html
@@ -67,6 +67,6 @@ dist: docs
tar czf $(DISTDIR).tar.gz $(DISTDIR)
zip -r $(DISTDIR).zip $(DISTDIR)
-update-web: dist docs
+update-web: dist
cp html/* $(WEB_DIR)
cp $(DISTDIR).tar.gz $(DISTDIR).zip /u/ftp/pub/outgoing

View file

@ -1,41 +0,0 @@
$NetBSD: patch-aj,v 1.2 2005/04/19 22:30:24 daprice Exp $
--- ogr/GNUmakefile.orig 2005-04-09 11:32:39.000000000 -0600
+++ ogr/GNUmakefile
@@ -16,7 +16,7 @@ CPPFLAGS := -Iogrsf_frmts -I. $(GDAL_INC
default: lib apps
-all: sublibs apps test_ogrsf$(EXE) docs
+all: sublibs apps test_ogrsf$(EXE)
ifeq ($(OGR_ENABLED),yes)
@@ -71,12 +71,12 @@ sublibs:
endif
-docs:
- rm -rf html/*
- doxygen
- cp ogrsf_frmts/*/drv_*.html html
- cp ogrsf_frmts/ogr_formats.html html
- cp ogr_feature_style.html html
+#docs:
+# rm -rf html/*
+# doxygen
+# cp ogrsf_frmts/*/drv_*.html html
+# cp ogrsf_frmts/ogr_formats.html html
+# cp ogr_feature_style.html html
install-docs:
$(INSTALL_DIR) $(INST_DOCS)/ogr
@@ -87,7 +87,7 @@ gdalso: $(GDAL_SLIB)
$(GDAL_SLIB):
(cd ..; $(MAKE) check-lib)
-web-update: docs
+web-update:
cp html/* /u/www/projects/opengis/ogrhtml
cp ogrsf_frmts/*/drv_*.html /u/www/projects/opengis/ogrhtml
cp ogrsf_frmts/ogr_formats.html /u/www/projects/opengis/ogrhtml