Import discident-glib-0.9.9 as wip/discident-glib.

discident-glib is a convenience library for the DiscIdent Web Service
This commit is contained in:
Kamel Ibn Aziz Derouiche 2010-06-12 23:24:04 +00:00 committed by Thomas Klausner
parent 77b21e74d0
commit d57b250918
6 changed files with 79 additions and 0 deletions

1
discident-glib/DESCR Normal file
View file

@ -0,0 +1 @@
discident-glib is a convenience library for the DiscIdent Web Service

27
discident-glib/Makefile Normal file
View file

@ -0,0 +1,27 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/06/12 23:24:04 jihbed Exp $
#
DISTNAME= discident-glib-0.9.9
CATEGORIES= www
MASTER_SITES= ftp://ftp.gnome.org/pub/gnome/sources/discident-glib/0.9/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= kamelderouiche@yahoo.com
HOMEPAGE= http://git.gnome.org/browse/discident-glib/
COMMENT= Discident-glib is a convenience library for the DiscIdent Web Service
LICENSE= gnu-gpl-v2
DEPENDS+= gobject-introspection>=0.6.10:../../wip/gobject-introspection
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= pkg-config intltool
PKGCONFIG_OVERRIDE+= discident-glib.pc.in
.include "../../devel/glib2/buildlink3.mk"
.include "../../textproc/gnome-doc-utils/buildlink3.mk"
.include "../../textproc/json-glib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

16
discident-glib/PLIST Normal file
View file

@ -0,0 +1,16 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/06/12 23:24:04 jihbed Exp $
include/discident-glib/discident-glib.h
lib/libdiscident-glib.la
lib/pkgconfig/discident-glib.pc
share/gtk-doc/html/discident-glib/api-index-full.html
share/gtk-doc/html/discident-glib/ch01.html
share/gtk-doc/html/discident-glib/discident-glib-discident-glib.html
share/gtk-doc/html/discident-glib/discident-glib.devhelp
share/gtk-doc/html/discident-glib/discident-glib.devhelp2
share/gtk-doc/html/discident-glib/home.png
share/gtk-doc/html/discident-glib/index.html
share/gtk-doc/html/discident-glib/index.sgml
share/gtk-doc/html/discident-glib/left.png
share/gtk-doc/html/discident-glib/right.png
share/gtk-doc/html/discident-glib/style.css
share/gtk-doc/html/discident-glib/up.png

View file

@ -0,0 +1,16 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2010/06/12 23:24:04 jihbed Exp $
BUILDLINK_TREE+= discident-glib
.if !defined(DISCIDENT_GLIB_BUILDLINK3_MK)
DISCIDENT_GLIB_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.discident-glib+= discident-glib>=0.9.9
BUILDLINK_PKGSRCDIR.discident-glib?= ../../wip/discident-glib
.include "../../devel/glib2/buildlink3.mk"
.include "../../textproc/gnome-doc-utils/buildlink3.mk"
.include "../../textproc/json-glib/buildlink3.mk"
.endif # DISCIDENT_GLIB_BUILDLINK3_MK
BUILDLINK_TREE+= -discident-glib

6
discident-glib/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/06/12 23:24:04 jihbed Exp $
SHA1 (discident-glib-0.9.9.tar.bz2) = 8259224225007f0610f6bcfcbcea66fc8574e18b
RMD160 (discident-glib-0.9.9.tar.bz2) = d39de62be198c29bdaf3a38853c212b9c2f621a7
Size (discident-glib-0.9.9.tar.bz2) = 285980 bytes
SHA1 (patch-aa) = 08c326b53699d1af9a4c3f5664e0045290b14347

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/06/12 23:24:04 jihbed Exp $
--- ./discident-glib/test-diglib.c.orig 2010-06-08 19:44:12.000000000 +0000
+++ ./discident-glib/test-diglib.c 2010-06-08 19:44:28.000000000 +0000
@@ -6,6 +6,8 @@
#include <discident-glib.h>
#include <discident-glib-private.h>
+#include <locale.h>
+
static gboolean option_async = FALSE;
static gboolean option_file_list = FALSE;
static guint num_queries = 0;