Import fuse-zip-0.4.0 as wip/fuse-zip.
fuse-zip is a FUSE file system to navigate, extract, create and modify ZIP archives based in libzip implemented in C++. With fuse-zip you really can work with ZIP archives as real directories. Unlike KIO or Gnome VFS, it can be used in any application without modifications. Unlike other FUSE filesystems, _only_ fuse-zip provides write support to ZIP archives. Also, fuse-zip is faster that all known implementations on large archives with many files. TODO: 0.4 dumps core on mounting for me on NetBSD-7.99.1. -- wiz 20140907
This commit is contained in:
parent
4feedc238c
commit
d835f3697b
6 changed files with 64 additions and 0 deletions
10
fuse-zip/DESCR
Normal file
10
fuse-zip/DESCR
Normal file
|
@ -0,0 +1,10 @@
|
|||
fuse-zip is a FUSE file system to navigate, extract, create and
|
||||
modify ZIP archives based in libzip implemented in C++.
|
||||
|
||||
With fuse-zip you really can work with ZIP archives as real
|
||||
directories. Unlike KIO or Gnome VFS, it can be used in any
|
||||
application without modifications.
|
||||
|
||||
Unlike other FUSE filesystems, _only_ fuse-zip provides write
|
||||
support to ZIP archives. Also, fuse-zip is faster that all known
|
||||
implementations on large archives with many files.
|
25
fuse-zip/Makefile
Normal file
25
fuse-zip/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1 2014/09/06 22:35:35 thomasklausner Exp $
|
||||
|
||||
DISTNAME= fuse-zip-0.4.0
|
||||
CATEGORIES= filesystems
|
||||
MASTER_SITES= https://fuse-zip.googlecode.com/files/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://code.google.com/p/fuse-zip/
|
||||
COMMENT= FUSE file system to navigate, extract, create, and modify ZIP archives
|
||||
LICENSE= gnu-lgpl-v3
|
||||
|
||||
USE_LANGUAGES= c++
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
MAKE_FLAGS+= INSTALLPREFIX=${DESTDIR}${PREFIX}
|
||||
|
||||
SUBST_CLASSES+= man
|
||||
SUBST_SED.man+= -e "s,share/man,${PKGMANDIR},"
|
||||
SUBST_FILES.man+= Makefile
|
||||
SUBST_STAGE.man= pre-build
|
||||
SUBST_MESSAGE.man= Fixing man page installation path.
|
||||
|
||||
.include "../../archivers/libzip/buildlink3.mk"
|
||||
.include "../../mk/fuse.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
fuse-zip/PLIST
Normal file
5
fuse-zip/PLIST
Normal file
|
@ -0,0 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2014/09/06 22:35:35 thomasklausner Exp $
|
||||
bin/fuse-zip
|
||||
man/man1/fuse-zip.1
|
||||
share/doc/fuse-zip/README
|
||||
share/doc/fuse-zip/changelog
|
1
fuse-zip/TODO
Normal file
1
fuse-zip/TODO
Normal file
|
@ -0,0 +1 @@
|
|||
0.4 dumps core on mounting for me on NetBSD-7.99.1. -- wiz 20140907
|
6
fuse-zip/distinfo
Normal file
6
fuse-zip/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2014/09/06 22:35:35 thomasklausner Exp $
|
||||
|
||||
SHA1 (fuse-zip-0.4.0.tar.gz) = 09ee8c6f9d045436309e126d891510540c3d68fa
|
||||
RMD160 (fuse-zip-0.4.0.tar.gz) = 260a1b23d8a57225b561d74b714ab90f957b7a17
|
||||
Size (fuse-zip-0.4.0.tar.gz) = 671498 bytes
|
||||
SHA1 (patch-lib_fileNode.cpp) = e62d60d6161dec4a25cd396ee7fbc79bea1356a3
|
17
fuse-zip/patches/patch-lib_fileNode.cpp
Normal file
17
fuse-zip/patches/patch-lib_fileNode.cpp
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-lib_fileNode.cpp,v 1.1 2014/09/06 22:35:35 thomasklausner Exp $
|
||||
|
||||
Fix compilation issue.
|
||||
|
||||
--- lib/fileNode.cpp.orig 2014-01-14 16:55:27.000000000 +0000
|
||||
+++ lib/fileNode.cpp
|
||||
@@ -28,6 +28,10 @@
|
||||
#include <syslog.h>
|
||||
#include <cassert>
|
||||
|
||||
+#ifndef UINT16_MAX
|
||||
+#define UINT16_MAX 0xffff
|
||||
+#endif
|
||||
+
|
||||
#include "fileNode.h"
|
||||
#include "extraField.h"
|
||||
|
Loading…
Reference in a new issue