Get this a bit further to compile on 2.0/i386.

The code's a mess, I don't want to touch this further.
This commit is contained in:
Hubert Feyrer 2004-09-07 21:10:49 +00:00 committed by Thomas Klausner
parent 207bd43a7f
commit d9b2f57847
2 changed files with 16 additions and 4 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2004/09/02 04:59:37 dhowland Exp $
# $NetBSD: Makefile,v 1.3 2004/09/07 21:10:49 hubertf Exp $
#
DISTNAME= qemu-0.6.0
@ -11,16 +11,14 @@ COMMENT= CPU emulator using dynamic translation
#PKG_SKIP_REASON= unfinished / fails to build
BUILD_DEPENDS+= SDL>=1.2.7:../../devel/SDL
CONFLICTS+= qemu-bin-*
GNU_CONFIGURE= yes
USE_GNU_TOOLS+= make
ONLY_FOR_PLATFORM= NetBSD-*-i386
.include "../../mk/bsd.prefs.mk"
CONFIGURE_ARGS+= --interp-prefix=${PREFIX}/share/gnemul/qemu-%M
.include "../../devel/SDL/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

14
qemu/patches/patch-ah Normal file
View file

@ -0,0 +1,14 @@
$NetBSD: patch-ah,v 1.1 2004/09/07 21:10:50 hubertf Exp $
--- target-i386/cpu.h.orig 2004-07-10 20:20:09.000000000 +0200
+++ target-i386/cpu.h
@@ -441,7 +441,9 @@ void cpu_x86_frstor(CPUX86State *s, uint
/* you can call this signal handler from your SIGBUS and SIGSEGV
signal handlers to inform the virtual CPU of exceptions. non zero
is returned if the signal was handled by the virtual CPU. */
+#ifndef __NetBSD__
struct siginfo;
+#endif __NetBSD__
int cpu_x86_signal_handler(int host_signum, struct siginfo *info,
void *puc);
void cpu_x86_set_a20(CPUX86State *env, int a20_state);