- Install README file in place.
- Keep CPPFLAGS, CFLAGS and LDFLAGS set by pkgsrc while building. - Remove a patch (idesk handles the problem itself).
This commit is contained in:
parent
49f4e8471f
commit
dbf547450a
5 changed files with 20 additions and 44 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3 2003/09/08 13:52:34 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2003/09/08 14:24:49 jmmv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= idesk-0.3.5
|
||||
|
@ -7,12 +7,17 @@ MASTER_SITES= http://idesk.timmfin.net/releases/
|
|||
|
||||
MAINTAINER= pancake@phreaker.net
|
||||
HOMEPAGE= http://idesk.timmfin.net/
|
||||
COMMENT= Gives users of minimal WM's icons on their desktop
|
||||
COMMENT= Gives users of minimal WMs icons on their desktop
|
||||
|
||||
USE_BUILDLINK2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_X11= yes
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/idesk ${PREFIX}/bin/idesk
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/idesk
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/idesk
|
||||
|
||||
.include "../../graphics/imlib/buildlink2.mk"
|
||||
.include "../../fonts/Xft2/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,2 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/05/07 21:57:00 poppnk Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2003/09/08 14:24:49 jmmv Exp $
|
||||
bin/idesk
|
||||
share/doc/idesk/README
|
||||
@dirrm share/doc/idesk
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.2 2003/07/25 16:02:38 poppnk Exp $
|
||||
$NetBSD: distinfo,v 1.2 2003/09/08 14:24:49 jmmv Exp $
|
||||
|
||||
SHA1 (idesk-0.3.5.tar.gz) = 63c34874bdfe640908e1329955d2ec266589cc27
|
||||
Size (idesk-0.3.5.tar.gz) = 7966 bytes
|
||||
SHA1 (patch-aa) = e5dcc40a75814faea2d93676e51d5b23d4b72e6a
|
||||
SHA1 (patch-ab) = 5b33e9fe8d9d5faff5eb51a0ae9b782c2bab2683
|
||||
SHA1 (patch-ab) = 6a37e76734e24d7f301ffd1ff12f9ffe2612185e
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.2 2003/07/25 16:02:38 poppnk Exp $
|
||||
|
||||
--- Desk.cc.orig 2002-11-09 18:06:16.000000000 +0000
|
||||
+++ Desk.cc 2003-07-25 17:58:09.000000000 +0000
|
||||
@@ -1,5 +1,4 @@
|
||||
#include "Desk.h"
|
||||
-
|
||||
Desk::Desk() {
|
||||
Dpy = XOpenDisplay( NULL );
|
||||
Root = DefaultRootWindow( Dpy );
|
||||
@@ -119,7 +118,11 @@
|
||||
|
||||
DirName += "/.idesktop/";
|
||||
FileCount = scandir( DirName.c_str(), &Files, 0, alphasort );
|
||||
-
|
||||
+ if( FileCount < 0 ) {
|
||||
+ printf("No %s exist please create it and put your *.lnk files\n"
|
||||
+ , DirName.c_str() );
|
||||
+ exit(-1);
|
||||
+ }
|
||||
for(int i=0; i<FileCount; i++) {
|
||||
FileName = DirName + Files[i]->d_name;
|
||||
IconDb = new Database(FileName);
|
|
@ -1,21 +1,14 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.2 2003/07/25 16:02:38 poppnk Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2003/09/08 14:24:49 jmmv Exp $
|
||||
|
||||
--- Makefile 2003-04-27 17:52:39.000000000 +0000
|
||||
+++ Makefile.old 2003-04-27 17:45:24.000000000 +0000
|
||||
@@ -1,6 +1,6 @@
|
||||
--- Makefile.orig 2002-11-09 19:06:52.000000000 +0100
|
||||
+++ Makefile
|
||||
@@ -1,7 +1,7 @@
|
||||
cc = g++
|
||||
#cflags = -g -O2 -W -Wall
|
||||
-cflags = -g -O2
|
||||
+cflags = `imlib-config --cflags` `xft-config --cflags` -O3
|
||||
libs = `imlib-config --libs` -lXft
|
||||
-libs = `imlib-config --libs` -lXft
|
||||
+cflags = ${CPPFLAGS} ${CFLAGS} `imlib-config --cflags` `xft-config --cflags`
|
||||
+libs = ${LDFLAGS} `imlib-config --libs` -lXft
|
||||
bin = idesk
|
||||
|
||||
@@ -17,7 +17,7 @@
|
||||
$(cc) $(cflags) -c $< -o $@
|
||||
|
||||
install:
|
||||
- install $(bin) /usr/local/bin
|
||||
+ install $(bin) ${PREFIX}/bin
|
||||
|
||||
clean:
|
||||
rm -f $(objs) $(bin) *~ core
|
||||
objs = Desk.o Icon.o Database.o Main.o
|
||||
|
|
Loading…
Reference in a new issue