Remove host -- a newer version is in pkgsrc/net.

This commit is contained in:
Thomas Klausner 2005-04-16 12:45:49 +00:00
parent e6d4d51124
commit dc43ceff87
8 changed files with 2 additions and 136 deletions

View file

@ -1,5 +1,5 @@
# $Id: Makefile,v 1.1743 2005/04/16 12:35:56 thomasklausner Exp $
# $NetBSD: Makefile,v 1.1743 2005/04/16 12:35:56 thomasklausner Exp $
# $Id: Makefile,v 1.1744 2005/04/16 12:45:49 thomasklausner Exp $
# $NetBSD: Makefile,v 1.1744 2005/04/16 12:45:49 thomasklausner Exp $
COMMENT= WIP pkgsrc packages
@ -328,7 +328,6 @@ SUBDIR+= hdparm
SUBDIR+= help2man
SUBDIR+= heroes
SUBDIR+= hol-light
SUBDIR+= host
SUBDIR+= hping3
SUBDIR+= hpoj
SUBDIR+= ht2html

View file

@ -1,24 +0,0 @@
Host is a very powerful DNS query and testing command-line tool. There are
many differences with the ancient version of the program with the same name
that is included in the BIND-4 and BIND-8 distributions, including:
- Major overhaul of the entire code. Very rigid error checking, with more
verbose error messages. Code is extensively documented.
- It is now possible to do recursive listings into delegated zones.
- Maintain resource record statistics and count of hosts during zone listings.
- Check for various extraneous conditions during zone listings.
- Check for illegal domain names containing invalid characters.
- Verify that certain domain names represent canonical host names.
- Perform ttl consistency checking during zone listings.
- Exploit multiple server addresses if available.
- Option to exploit only primary server for zone transfers.
- Option to exclude info from names that do not reside in a zone.
- Implement timeout handling during connect and read.
- Write resource record output to optional log file.
- Special MB tracing by recursively expanding MR and MG records.
- Special modes to check SOA records at each name server for a zone.
- Special mode to check reverse mappings of host addresses.
- Configurable default options in HOST_DEFAULTS environment variable.
- Basic experimental NSAP support as defined in RFC 1637.
- Implement new resource record types from RFCs 1183, 1348, 1664, 1712,
1876 and 1886.

View file

@ -1,18 +0,0 @@
# $NetBSD: Makefile,v 1.5 2005/04/11 21:13:02 tvierling Exp $
#
DISTNAME= host-20031203
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.weird.com/pub/local/
MAINTAINER= cjep@NetBSD.org
HOMEPAGE= http://www.weird.com/~woods/projects/host.html
COMMENT= Enhanced version of the host DNS query tool
MAKEFILE= Makefile.BSD
#
#MAKE_FLAGS+= FILES=
#MAKE_FLAGS+= SCRIPTS="nscheck mxlookup rblookup"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/01/01 16:58:44 cjep Exp $
bin/host
bin/mxlookup
bin/nscheck
bin/rblookup
man/cat1/host.0
man/man1/host.1

View file

@ -1,18 +0,0 @@
$Id: TODO,v 1.3 2004/01/01 17:37:20 cjep Exp $
Note added: I think the following is fixed now. Just needs testing. Will
pass back to submitter for comments.
Fix command line handling. e.g. use getopt_long. The current handling
is complicated and there is at least one core dump situation:
tubbs% /usr/pkg/bin/host
Segmentation fault (core dumped)
tubbs% /usr/pkg/bin/host -v
Segmentation fault (core dumped)
tubbs% /usr/pkg/bin/host -v www.cisco.com
Query about www.cisco.com for record types A
Query for A records done, 1 answer, status: no error
The following answer is not authoritative:
Answer section contains (1 record):
www.cisco.com IN A 198.133.219.25

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.2 2004/01/01 17:37:20 cjep Exp $
SHA1 (host-20031203.tar.gz) = d092f4b090a6d529a3dbe56c5ad777dc1170d3a4
Size (host-20031203.tar.gz) = 148890 bytes
SHA1 (patch-aa) = 5247e3b8ed17208d853d9b0b89c6ecb06f81d47e
SHA1 (patch-ab) = bd5d238c6b5b3570fffe55abb715e77f20af3811

View file

@ -1,29 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/01/01 16:58:44 cjep Exp $
--- Makefile.BSD.orig 2003-11-17 05:28:42.000000000 +0000
+++ Makefile.BSD
@@ -51,14 +51,17 @@ NOSHARED = YES
BINDIR ?= ${PREFIX}/bin
BINOWN ?= root
-.if defined(__NetBSD__)
-MANDIR ?= ${PREFIX}/share/man
-.elif defined(__FreeBSD__)
-MANDIR ?= ${PREFIX}/share/man/man
-.else
+#.if defined(__NetBSD__)
+#MANDIR ?= ${PREFIX}/share/man
+#.elif defined(__FreeBSD__)
+#MANDIR ?= ${PREFIX}/share/man/man
+#.else
# 4.4BSD, including BSD/OS
-MANDIR ?= ${PREFIX}/share/man/cat
-.endif
+#MANDIR ?= ${PREFIX}/share/man/cat
+#.endif
+
+# Pkgsrc
+MANDIR?= ${PREFIX}/man
# this check is a nasty hack and will break building 'host' in the
# NetBSD source tree on any host that doesn't have this file....

View file

@ -1,31 +0,0 @@
$NetBSD: patch-ab,v 1.1 2004/01/01 17:37:20 cjep Exp $
--- main.c.orig 2003-12-04 03:51:58.000000000 +0000
+++ main.c
@@ -371,7 +371,7 @@ main(argc, argv)
* Check whether host was called with a different name.
* Interpolate default options and parameters.
*/
- if (argc < 1 || argv[0] == NULL)
+ if (argc < 2 || argv[0] == NULL)
usage_error(usage_msg);
if ((option = getenv("HOST_DEFAULTS"))) {
@@ -681,15 +681,15 @@ main(argc, argv)
usage_error(usage_msg);
}
}
-
argv++; argc--;
+
}
/*
* Check the remaining arguments.
*/
/* old syntax must have at least one argument and no more than two */
- if (!extended && (argc < 1 || argv[0] == NULL || argc > 3))
+ if (!extended && (argc < 2 || argv[0] == NULL || argc > 3))
usage_error(usage_msg);
/* old syntax has explicit server as second argument */