Use INSTALLATION_DIRS, honour PKGMANDIR, populate PLIST, add x11 buildlinks

This commit is contained in:
Tobias Nygren 2008-02-03 17:33:17 +00:00 committed by Thomas Klausner
parent 751d55852d
commit dd1cea2f2e
4 changed files with 29 additions and 11 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2006/10/29 08:32:57 shattered Exp $
# $NetBSD: Makefile,v 1.5 2008/02/03 17:33:17 tnn2 Exp $
DISTNAME= vkeybd-0.1.17
CATEGORIES= audio
@ -17,5 +17,13 @@ CFLAGS+= -DVKB_TCLFILE=\"${VKB_TCLFILE:Q}\"
CFLAGS+= -DVKB_USE_MIDI
CFLAGS+= -DMIDI_DEV=\"${RAWMIDI:Q}\"
INSTALLATION_DIRS= ${PKGMANDIR}/man1
SUBST_CLASSES+= wish
SUBST_FILES.wish= vkeybd.tcl
SUBST_STAGE.wish= pre-build
SUBST_SED.wish= -e 's,/usr/bin/wish,${PREFIX}/bin/wish,'
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/tk/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +1,9 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/02/13 18:44:33 oht Exp $
@comment This PLIST is intentionally left empty.
@comment $NetBSD: PLIST,v 1.2 2008/02/03 17:33:18 tnn2 Exp $
bin/sftovkb
bin/vkeybd
man/man1/vkeybd.1
share/vkeybd/vkeybd.list
share/vkeybd/vkeybd.tcl
share/vkeybd/vkeybdmap
share/vkeybd/vkeybdmap-german
@dirrm share/vkeybd

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.2 2005/09/28 06:41:43 rillig Exp $
$NetBSD: distinfo,v 1.3 2008/02/03 17:33:18 tnn2 Exp $
SHA1 (vkeybd-0.1.17.tar.gz) = 7b7e6a1dcbe9f9d68d928b9c078285400c13dd6a
RMD160 (vkeybd-0.1.17.tar.gz) = 3dcec5b994ed5a438218d725974ed9718f7166ff
Size (vkeybd-0.1.17.tar.gz) = 32838 bytes
SHA1 (patch-aa) = a74a3a84e66aeb4de459bb9923da6953a94eb5c5
SHA1 (patch-aa) = 94c82349a58ca85385a7d2baca0cdb8dcc16d647
SHA1 (patch-ab) = 81bb4dab345fa6266c6513b7dfdb8dc17d702444

View file

@ -1,6 +1,7 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/02/13 18:44:34 oht Exp $
$NetBSD: patch-aa,v 1.2 2008/02/03 17:33:18 tnn2 Exp $
--- Makefile.orig 2004-08-31 17:50:11.000000000 +0200
+++ Makefile 2005-02-13 16:56:45.000000000 +0100
+++ Makefile
@@ -3,12 +3,14 @@
# copyright (c) 1997-2000 by Takashi Iwai
#
@ -17,7 +18,7 @@ $NetBSD: patch-aa,v 1.1.1.1 2005/02/13 18:44:34 oht Exp $
# binary and Tcl script are put there
BIN_DIR = $(PREFIX)/bin
# man page
@@ -27,88 +29,93 @@
@@ -27,88 +29,93 @@ VKBLIB_DIR = $(DATA_DIR)/vkeybd
# device selections -- multiple avaialble
# to disable the device, set value 0 (do not comment out!)
#
@ -42,9 +43,11 @@ $NetBSD: patch-aa,v 1.1.1.1 2005/02/13 18:44:34 oht Exp $
-TKLIB = -ltk$(TCL_VERSION)
+TKLIB = -L$(PREFIX)/lib -ltk$(TCL_VERSION)
TKINC =
XLIB = -L/usr/X11R6/lib -lX11
XINC = -I/usr/X11R6/include
-XLIB = -L/usr/X11R6/lib -lX11
-XINC = -I/usr/X11R6/include
-EXTRALIB += -ldl
+XLIB = $(LDFLAGS) -lX11
+XINC = $(CPPFLAGS)
#----------------------------------------------------------------
# device definitions
@ -130,7 +133,7 @@ $NetBSD: patch-aa,v 1.1.1.1 2005/02/13 18:44:34 oht Exp $
install -c -m 444 vkeybdmap* $(DESTDIR)$(VKBLIB_DIR)
-
+ mv vkeybd.man vkeybd.1
+ install -c -m 444 vkeybd.1 $(PREFIX)/man/man1
+ install -c -m 444 vkeybd.1 $(PREFIX)/$(PKGMANDIR)/man1
+ mv vkeybd.1 vkeybd.man
install-man:
mkdir -p $(DESTDIR)$(MAN_DIR)/man$(MAN_SUFFIX)