Current-ish SVN version of the Jack Audio Connection kit. Some newer software

may require this version.  At some point, this will probably be the preferred
backend for pulseaudio.

Please, do not hesitate to test and send me feedback.

Also, audio/arts supports jack for output.  This should definitely be an option.
This commit is contained in:
Blair Sadewitz 2007-02-09 12:16:42 +00:00 committed by Thomas Klausner
parent 9d7fce78f7
commit de71c67c28
13 changed files with 248 additions and 0 deletions

7
jack-devel/DESCR Normal file
View file

@ -0,0 +1,7 @@
JACK is a low-latency audio server. Originally written for the
GNU/Linux operating system, it also supports Mac OS X and various Unix
platforms. JACK can connect a number of different client applications
to an audio device and also to each other. Most clients are external,
running in their own processes as normal applications. JACK also sup-
ports internal clients, which run within the jackd process using a
loadable "plugin" interface.

31
jack-devel/Makefile Normal file
View file

@ -0,0 +1,31 @@
# $NetBSD: Makefile,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
#
DISTNAME= jack-0.102.28.svn20061216
PKGNAME= jack-0.102.28
CATEGORIES= audio
MASTER_SITES= http://www.rncbc.org/jack/
MAINTAINER= blair.sadewitz@gmail.com
HOMEPAGE= http://www.jackaudio.org/
COMMENT= Development version of the Jack Audio Connection Kit
GNU_CONFIGURE= yes
USE_TOOLS+= perl pkg-config
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
USE_LANGUAGES= c c++
PKGCONFIG_OVERRIDE+= jack.pc.in
CONFIGURE_ENV+= ac_cv_header_readline_chardefs_h=yes
LIBS+= ${LIBOSSAUDIO}
.include "options.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

38
jack-devel/PLIST Normal file
View file

@ -0,0 +1,38 @@
@comment $NetBSD: PLIST,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
bin/jack_bufsize
bin/jack_connect
bin/jack_disconnect
bin/jack_freewheel
bin/jack_impulse_grabber
bin/jack_load
bin/jack_lsp
bin/jack_metro
bin/jack_midiseq
bin/jack_midisine
bin/jack_monitor_client
bin/jack_showtime
bin/jack_simple_client
bin/jack_transport
bin/jack_unload
bin/jackd
bin/jackrec
include/jack/intclient.h
include/jack/jack.h
include/jack/midiport.h
include/jack/ringbuffer.h
include/jack/statistics.h
include/jack/thread.h
include/jack/timestamps.h
include/jack/transport.h
include/jack/types.h
lib/jack/inprocess.la
lib/jack/intime.la
lib/jack/jack_dummy.la
lib/jack/jack_oss.la
lib/jack/jack_portaudio.la
lib/libjack.la
lib/pkgconfig/jack.pc
man/man1/jackd.1
man/man1/jackstart.1
@dirrm lib/jack
@dirrm include/jack

20
jack-devel/buildlink3.mk Normal file
View file

@ -0,0 +1,20 @@
# $NetBSD: buildlink3.mk,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
#
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
JACK_BUILDLINK3_MK:= ${JACK_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= jack
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Njack}
BUILDLINK_PACKAGES+= jack
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}jack
.if !empty(JACK_BUILDLINK3_MK:M+)
BUILDLINK_API_DEPENDS.jack= jack>=0.102.0
BUILDLINK_PKGSRCDIR.jack?= ../../wip/jack-devel
.endif # JACK_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

12
jack-devel/distinfo Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: distinfo,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
SHA1 (jack-0.102.28.svn20061216.tar.gz) = 6b795e598b85620a16f88e7f452e84c70e83e9ef
RMD160 (jack-0.102.28.svn20061216.tar.gz) = 4ddb90a1b518a0d6d9cf92befd7ed5bca7ae0cc8
Size (jack-0.102.28.svn20061216.tar.gz) = 770203 bytes
SHA1 (patch-aa) = 6f9e2108b1bee285ee7921033f11618c0702972e
SHA1 (patch-ab) = 723b44d1b8c1098a4c9ccf8ad8f2c0853551ceb4
SHA1 (patch-ac) = edb69f78d830e07130897636eba302893fb173d2
SHA1 (patch-ad) = 0e31b4ac26cd51aefc8bb3b1c144e3e69f847e3d
SHA1 (patch-ae) = 2c3dee13983ce3ba01cc68d5dada1514ec3c008c
SHA1 (patch-af) = fb4ca3996e50c97b81854cced447a62cf8990b80
SHA1 (patch-ba) = 59cd58510d14cfc127ef76e5b0a4ae15eca15f17

29
jack-devel/options.mk Normal file
View file

@ -0,0 +1,29 @@
# $NetBSD: options.mk,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
#
PKG_OPTIONS_VAR= PKG_OPTIONS.jack
PKG_SUPPORTED_OPTIONS+= portaudio sndfile flac
PKG_SUGGESTED_OPTIONS+= sndfile flac
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mportaudio)
.include "../../audio/portaudio/buildlink3.mk"
CONFIGURE_ARGS+= --with-portaudio
.else
CONFIGURE_ARGS+= --without-portaudio
.endif
.if !empty(PKG_OPTIONS:Msndfile)
.include "../../audio/libsndfile/buildlink3.mk"
CONFIGURE_ARGS+= --with-libsndfile
.else
CONFIGURE_ARGS+= --without-libsndfile
.endif
.if !empty(PKG_OPTIONS:Mflac)
.include "../../audio/flac/buildlink3.mk"
CONFIGURE_ARGS+= --with-flac
.else
CONFIGURE_ARGS+= --without-flac
.endif

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
--- config/os/generic/time.h.orig 2006-12-16 07:50:38.000000000 -0500
+++ config/os/generic/time.h
@@ -24,7 +24,9 @@
#include <jack/internal.h>
-inline jack_time_t
+jack_time_t jack_get_microseconds_from_system (void);
+
+static inline jack_time_t
jack_get_microseconds (void) {
return jack_get_microseconds_from_system ();
}

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ab,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
--- drivers/dummy/dummy_driver.c.orig 2006-12-16 07:51:42.000000000 -0500
+++ drivers/dummy/dummy_driver.c
@@ -41,10 +41,11 @@
/* this is used for calculate what counts as an xrun */
#define PRETEND_BUFFER_SIZE 4096
+#define VIDEO_SYNC_PERIOD 48000 / 30
+
void
FakeVideoSync( dummy_driver_t *driver )
{
- static const int VIDEO_SYNC_PERIOD = 48000 / 30;
static int vidCounter = VIDEO_SYNC_PERIOD;
int period = driver->period_size;

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ac,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
--- example-clients/lsp.c.orig 2006-12-16 07:50:12.000000000 -0500
+++ example-clients/lsp.c
@@ -119,10 +119,10 @@ main (int argc, char *argv[])
ports = jack_get_ports (client, NULL, NULL, 0);
for (i = 0; ports[i]; ++i) {
- printf ("%s\n", ports[i]);
-
jack_port_t *port = jack_port_by_name (client, ports[i]);
+ printf ("%s\n", ports[i]);
+
if (show_con) {
if ((connections = jack_port_get_all_connections (client, jack_port_by_name(client, ports[i]))) != 0) {
for (j = 0; connections[j]; j++) {

View file

@ -0,0 +1,21 @@
$NetBSD: patch-ad,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
--- jack/types.h.orig 2006-12-16 07:50:58.000000000 -0500
+++ jack/types.h
@@ -24,6 +24,16 @@
#include <inttypes.h>
+#ifndef PRIu32
+#define PRIi32 "i"; /* int32_t */
+#define PRIu32 "u"; /* uint32_t */
+#define PRIu64 "llu"; /* uint64_t */
+#define SCNu64 "llu"; /* uint64_t */
+#define PRId32 "d"; /* int32_t */
+#define PRIx64 "llx"; /* uint64_t */
+#endif
+
+
typedef int32_t jack_shmsize_t;
/**

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
--- jackd/engine.c.orig 2006-12-16 07:51:14.000000000 -0500
+++ jackd/engine.c
@@ -1442,7 +1442,7 @@ jack_server_thread (void *arg)
(engine, pfd[i].fd)) {
jack_error ("could not handle external"
" client request");
-#ifdef JACK_USE_MACH_THREADS
+#if 1
/* poll is implemented using
select (see the macosx/fakepoll
code). When the socket is closed

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
--- libjack/midiport.c.orig 2006-12-16 07:50:17.000000000 -0500
+++ libjack/midiport.c
@@ -77,7 +77,7 @@ jack_midi_event_get(jack_midi_event_t *e
(jack_midi_port_info_private_t *) port_buffer;
if (event_idx >= info->event_count)
- return ENODATA;
+ return ENOMSG;
port_event = (jack_midi_port_internal_event_t *) (info + 1);
port_event += event_idx;

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ba,v 1.1 2007/02/09 12:16:42 bsadewitz Exp $
--- example-clients/transport.c.orig 2006-12-16 07:50:12.000000000 -0500
+++ example-clients/transport.c
@@ -29,6 +29,10 @@
#include <jack/jack.h>
#include <jack/transport.h>
+#ifndef whitespace
+#define whitespace(c) (((c) == ' ') || ((c) == '\t'))
+#endif
+
char *package; /* program name */
int done = 0;
jack_client_t *client;