Auf Wiedersehen ec2-api-tools. You were imported in pkgsrc some weeks ago.

This commit is contained in:
Jean-Yves Migeon 2011-02-18 04:43:06 +00:00 committed by Thomas Klausner
parent 8dd14ad2dc
commit df83089123
8 changed files with 1 additions and 557 deletions

View file

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.4221 2011/02/16 17:15:47 thomasklausner Exp $
# $Id: Makefile,v 1.4222 2011/02/18 04:43:06 jym-netbsd Exp $
#
COMMENT= WIP pkgsrc packages
@ -435,7 +435,6 @@ SUBDIR+= e3
SUBDIR+= easymesh
SUBDIR+= eboard-extras
SUBDIR+= ec2-ami-tools
SUBDIR+= ec2-api-tools
SUBDIR+= ecasound
SUBDIR+= ecb
SUBDIR+= eciadsl-usermode

View file

@ -1,3 +0,0 @@
The API tools serve as the client interface to the Amazon EC2 web
service. Use these tools to register and launch AMI instances, manipulate
security groups, and more.

View file

@ -1,68 +0,0 @@
# $NetBSD: Makefile,v 1.3 2011/01/26 13:12:46 jym-netbsd Exp $
#
PKGNAME= ec2-api-tools-1.3.62308
DISTNAME= ec2-api-tools-1.3-62308
.include "Makefile.common"
CATEGORIES= misc
MASTER_SITES= http://s3.amazonaws.com/ec2-downloads/
EXTRACT_SUFX= .zip
MAINTAINER= jym@NetBSD.org
HOMEPAGE= http://aws.amazon.com/developertools/351
COMMENT= Amazon EC2 API tools (register, launch, administer instances)
LICENSE= amazon-software-license AND apache-2.0 AND gnu-gpl-v2 \
AND cddl-1.0
PKG_DESTDIR_SUPPORT= user-destdir
NO_BUILD= yes
USE_JAVA= run
USE_JAVA2= 1.5
REPLACE_INTERPRETER+= bash
REPLACE.bash.old= /usr/bin/env.*bash
REPLACE.bash.new= /bin/sh
REPLACE_FILES.bash= bin/*
SUBST_CLASSES+= java-path
SUBST_STAGE.java-path= pre-configure
SUBST_FILES.java-path= bin/ec2-cmd
SUBST_VARS.java-path+= PKG_JAVA_HOME
SUBST_MESSAGE.java-path=Fixing path to Java interpreter.
SUBST_CLASSES+= ec2-home
SUBST_STAGE.ec2-home= pre-configure
SUBST_FILES.ec2-home= bin/*
SUBST_SED.ec2-home+= -e 's|:.EC2_HOME is not set|:-${EC2_HOME}|g'
SUBST_MESSAGE.ec2-home= Setting EC2_HOME default path.
PLIST_SUBST+= EC2_DIR=${EC2_DIR:Q}
INSTALLATION_DIRS+= bin ${EC2_DIR} ${EC2_DIR}/bin ${EC2_DIR}/lib
post-extract:
# Get rid of Windows batch files
${FIND} ${WRKSRC} -name \*.cmd -type f -print | ${XARGS} ${RM} -f
do-install:
${FIND} ${WRKSRC} -name \*.orig -type f -print | ${XARGS} ${RM} -f
# Install EC2 .jar files
cd ${WRKSRC}/lib && for f in *; do \
${INSTALL_DATA} $$f ${DESTDIR}${EC2_HOME}/lib; \
done
# Install EC2 scripts
cd ${WRKSRC}/bin && for f in *; do \
${INSTALL_SCRIPT} $$f ${DESTDIR}${EC2_HOME}/bin;\
${LN} -sf ${DESTDIR}${EC2_HOME}/bin/$$f \
${DESTDIR}${PREFIX}/bin; \
done
.include "../../mk/java-vm.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +0,0 @@
# $NetBSD: Makefile.common,v 1.2 2011/01/26 12:51:32 jym-netbsd Exp $
# used by wip/ec2-ami-tools/Makefile
#
# Default path to Amazon EC2 scripts, binaries and tools
EC2_DIR= ec2-amazon
EC2_HOME= ${PREFIX}/${EC2_DIR}

View file

@ -1,444 +0,0 @@
@comment $NetBSD: PLIST,v 1.3 2011/01/26 13:12:46 jym-netbsd Exp $
bin/ec2-activate-license
bin/ec2-add-group
bin/ec2-add-keypair
bin/ec2-allocate-address
bin/ec2-associate-address
bin/ec2-associate-dhcp-options
bin/ec2-attach-volume
bin/ec2-attach-vpn-gateway
bin/ec2-authorize
bin/ec2-bundle-instance
bin/ec2-cancel-bundle-task
bin/ec2-cancel-conversion-task
bin/ec2-cancel-spot-instance-requests
bin/ec2-cmd
bin/ec2-confirm-product-instance
bin/ec2-create-customer-gateway
bin/ec2-create-dhcp-options
bin/ec2-create-image
bin/ec2-create-placement-group
bin/ec2-create-snapshot
bin/ec2-create-spot-datafeed-subscription
bin/ec2-create-subnet
bin/ec2-create-tags
bin/ec2-create-volume
bin/ec2-create-vpc
bin/ec2-create-vpn-connection
bin/ec2-create-vpn-gateway
bin/ec2-deactivate-license
bin/ec2-delete-customer-gateway
bin/ec2-delete-dhcp-options
bin/ec2-delete-disk-image
bin/ec2-delete-group
bin/ec2-delete-keypair
bin/ec2-delete-placement-group
bin/ec2-delete-snapshot
bin/ec2-delete-spot-datafeed-subscription
bin/ec2-delete-subnet
bin/ec2-delete-tags
bin/ec2-delete-volume
bin/ec2-delete-vpc
bin/ec2-delete-vpn-connection
bin/ec2-delete-vpn-gateway
bin/ec2-deregister
bin/ec2-describe-addresses
bin/ec2-describe-availability-zones
bin/ec2-describe-bundle-tasks
bin/ec2-describe-conversion-tasks
bin/ec2-describe-customer-gateways
bin/ec2-describe-dhcp-options
bin/ec2-describe-group
bin/ec2-describe-image-attribute
bin/ec2-describe-images
bin/ec2-describe-instance-attribute
bin/ec2-describe-instances
bin/ec2-describe-keypairs
bin/ec2-describe-licenses
bin/ec2-describe-placement-groups
bin/ec2-describe-regions
bin/ec2-describe-reserved-instances
bin/ec2-describe-reserved-instances-offerings
bin/ec2-describe-snapshot-attribute
bin/ec2-describe-snapshots
bin/ec2-describe-spot-datafeed-subscription
bin/ec2-describe-spot-instance-requests
bin/ec2-describe-spot-price-history
bin/ec2-describe-subnets
bin/ec2-describe-tags
bin/ec2-describe-volumes
bin/ec2-describe-vpcs
bin/ec2-describe-vpn-connections
bin/ec2-describe-vpn-gateways
bin/ec2-detach-volume
bin/ec2-detach-vpn-gateway
bin/ec2-disassociate-address
bin/ec2-fingerprint-key
bin/ec2-get-console-output
bin/ec2-get-password
bin/ec2-import-instance
bin/ec2-import-keypair
bin/ec2-import-volume
bin/ec2-migrate-image
bin/ec2-modify-image-attribute
bin/ec2-modify-instance-attribute
bin/ec2-modify-snapshot-attribute
bin/ec2-monitor-instances
bin/ec2-purchase-reserved-instances-offering
bin/ec2-reboot-instances
bin/ec2-register
bin/ec2-release-address
bin/ec2-request-spot-instances
bin/ec2-reset-image-attribute
bin/ec2-reset-instance-attribute
bin/ec2-reset-snapshot-attribute
bin/ec2-revoke
bin/ec2-run-instances
bin/ec2-start-instances
bin/ec2-stop-instances
bin/ec2-terminate-instances
bin/ec2-unmonitor-instances
bin/ec2-upload-disk-image
bin/ec2-version
bin/ec2actlic
bin/ec2addcgw
bin/ec2adddopt
bin/ec2addgrp
bin/ec2addkey
bin/ec2addpgrp
bin/ec2addsds
bin/ec2addsnap
bin/ec2addsubnet
bin/ec2addtag
bin/ec2addvgw
bin/ec2addvol
bin/ec2addvpc
bin/ec2addvpn
bin/ec2allocaddr
bin/ec2assocaddr
bin/ec2assocdopt
bin/ec2attvgw
bin/ec2attvol
bin/ec2auth
bin/ec2bundle
bin/ec2cbun
bin/ec2cct
bin/ec2cim
bin/ec2cpi
bin/ec2csir
bin/ec2daddr
bin/ec2datt
bin/ec2daz
bin/ec2dbun
bin/ec2dcgw
bin/ec2dct
bin/ec2ddi
bin/ec2ddopt
bin/ec2deactlic
bin/ec2delcgw
bin/ec2deldopt
bin/ec2delgrp
bin/ec2delkey
bin/ec2delpgrp
bin/ec2delsds
bin/ec2delsnap
bin/ec2delsubnet
bin/ec2deltag
bin/ec2delvgw
bin/ec2delvol
bin/ec2delvpc
bin/ec2delvpn
bin/ec2dereg
bin/ec2detvgw
bin/ec2detvol
bin/ec2dgrp
bin/ec2diatt
bin/ec2dim
bin/ec2dimatt
bin/ec2din
bin/ec2dinatt
bin/ec2disaddr
bin/ec2dkey
bin/ec2dlic
bin/ec2dpgrp
bin/ec2dre
bin/ec2dri
bin/ec2drio
bin/ec2dsds
bin/ec2dsir
bin/ec2dsnap
bin/ec2dsnapatt
bin/ec2dsph
bin/ec2dsubnet
bin/ec2dtag
bin/ec2dvgw
bin/ec2dvol
bin/ec2dvpc
bin/ec2dvpn
bin/ec2fp
bin/ec2gcons
bin/ec2gpass
bin/ec2ii
bin/ec2ikey
bin/ec2iv
bin/ec2kill
bin/ec2matt
bin/ec2miatt
bin/ec2mim
bin/ec2mimatt
bin/ec2min
bin/ec2minatt
bin/ec2msnapatt
bin/ec2prio
bin/ec2ratt
bin/ec2reboot
bin/ec2reg
bin/ec2reladdr
bin/ec2revoke
bin/ec2riatt
bin/ec2rimatt
bin/ec2rinatt
bin/ec2rsi
bin/ec2rsnapatt
bin/ec2run
bin/ec2start
bin/ec2stop
bin/ec2tag
bin/ec2udi
bin/ec2umin
bin/ec2ver
${EC2_DIR}/bin/ec2-activate-license
${EC2_DIR}/bin/ec2-add-group
${EC2_DIR}/bin/ec2-add-keypair
${EC2_DIR}/bin/ec2-allocate-address
${EC2_DIR}/bin/ec2-associate-address
${EC2_DIR}/bin/ec2-associate-dhcp-options
${EC2_DIR}/bin/ec2-attach-volume
${EC2_DIR}/bin/ec2-attach-vpn-gateway
${EC2_DIR}/bin/ec2-authorize
${EC2_DIR}/bin/ec2-bundle-instance
${EC2_DIR}/bin/ec2-cancel-bundle-task
${EC2_DIR}/bin/ec2-cancel-conversion-task
${EC2_DIR}/bin/ec2-cancel-spot-instance-requests
${EC2_DIR}/bin/ec2-cmd
${EC2_DIR}/bin/ec2-confirm-product-instance
${EC2_DIR}/bin/ec2-create-customer-gateway
${EC2_DIR}/bin/ec2-create-dhcp-options
${EC2_DIR}/bin/ec2-create-image
${EC2_DIR}/bin/ec2-create-placement-group
${EC2_DIR}/bin/ec2-create-snapshot
${EC2_DIR}/bin/ec2-create-spot-datafeed-subscription
${EC2_DIR}/bin/ec2-create-subnet
${EC2_DIR}/bin/ec2-create-tags
${EC2_DIR}/bin/ec2-create-volume
${EC2_DIR}/bin/ec2-create-vpc
${EC2_DIR}/bin/ec2-create-vpn-connection
${EC2_DIR}/bin/ec2-create-vpn-gateway
${EC2_DIR}/bin/ec2-deactivate-license
${EC2_DIR}/bin/ec2-delete-customer-gateway
${EC2_DIR}/bin/ec2-delete-dhcp-options
${EC2_DIR}/bin/ec2-delete-disk-image
${EC2_DIR}/bin/ec2-delete-group
${EC2_DIR}/bin/ec2-delete-keypair
${EC2_DIR}/bin/ec2-delete-placement-group
${EC2_DIR}/bin/ec2-delete-snapshot
${EC2_DIR}/bin/ec2-delete-spot-datafeed-subscription
${EC2_DIR}/bin/ec2-delete-subnet
${EC2_DIR}/bin/ec2-delete-tags
${EC2_DIR}/bin/ec2-delete-volume
${EC2_DIR}/bin/ec2-delete-vpc
${EC2_DIR}/bin/ec2-delete-vpn-connection
${EC2_DIR}/bin/ec2-delete-vpn-gateway
${EC2_DIR}/bin/ec2-deregister
${EC2_DIR}/bin/ec2-describe-addresses
${EC2_DIR}/bin/ec2-describe-availability-zones
${EC2_DIR}/bin/ec2-describe-bundle-tasks
${EC2_DIR}/bin/ec2-describe-conversion-tasks
${EC2_DIR}/bin/ec2-describe-customer-gateways
${EC2_DIR}/bin/ec2-describe-dhcp-options
${EC2_DIR}/bin/ec2-describe-group
${EC2_DIR}/bin/ec2-describe-image-attribute
${EC2_DIR}/bin/ec2-describe-images
${EC2_DIR}/bin/ec2-describe-instance-attribute
${EC2_DIR}/bin/ec2-describe-instances
${EC2_DIR}/bin/ec2-describe-keypairs
${EC2_DIR}/bin/ec2-describe-licenses
${EC2_DIR}/bin/ec2-describe-placement-groups
${EC2_DIR}/bin/ec2-describe-regions
${EC2_DIR}/bin/ec2-describe-reserved-instances
${EC2_DIR}/bin/ec2-describe-reserved-instances-offerings
${EC2_DIR}/bin/ec2-describe-snapshot-attribute
${EC2_DIR}/bin/ec2-describe-snapshots
${EC2_DIR}/bin/ec2-describe-spot-datafeed-subscription
${EC2_DIR}/bin/ec2-describe-spot-instance-requests
${EC2_DIR}/bin/ec2-describe-spot-price-history
${EC2_DIR}/bin/ec2-describe-subnets
${EC2_DIR}/bin/ec2-describe-tags
${EC2_DIR}/bin/ec2-describe-volumes
${EC2_DIR}/bin/ec2-describe-vpcs
${EC2_DIR}/bin/ec2-describe-vpn-connections
${EC2_DIR}/bin/ec2-describe-vpn-gateways
${EC2_DIR}/bin/ec2-detach-volume
${EC2_DIR}/bin/ec2-detach-vpn-gateway
${EC2_DIR}/bin/ec2-disassociate-address
${EC2_DIR}/bin/ec2-fingerprint-key
${EC2_DIR}/bin/ec2-get-console-output
${EC2_DIR}/bin/ec2-get-password
${EC2_DIR}/bin/ec2-import-instance
${EC2_DIR}/bin/ec2-import-keypair
${EC2_DIR}/bin/ec2-import-volume
${EC2_DIR}/bin/ec2-migrate-image
${EC2_DIR}/bin/ec2-modify-image-attribute
${EC2_DIR}/bin/ec2-modify-instance-attribute
${EC2_DIR}/bin/ec2-modify-snapshot-attribute
${EC2_DIR}/bin/ec2-monitor-instances
${EC2_DIR}/bin/ec2-purchase-reserved-instances-offering
${EC2_DIR}/bin/ec2-reboot-instances
${EC2_DIR}/bin/ec2-register
${EC2_DIR}/bin/ec2-release-address
${EC2_DIR}/bin/ec2-request-spot-instances
${EC2_DIR}/bin/ec2-reset-image-attribute
${EC2_DIR}/bin/ec2-reset-instance-attribute
${EC2_DIR}/bin/ec2-reset-snapshot-attribute
${EC2_DIR}/bin/ec2-revoke
${EC2_DIR}/bin/ec2-run-instances
${EC2_DIR}/bin/ec2-start-instances
${EC2_DIR}/bin/ec2-stop-instances
${EC2_DIR}/bin/ec2-terminate-instances
${EC2_DIR}/bin/ec2-unmonitor-instances
${EC2_DIR}/bin/ec2-upload-disk-image
${EC2_DIR}/bin/ec2-version
${EC2_DIR}/bin/ec2actlic
${EC2_DIR}/bin/ec2addcgw
${EC2_DIR}/bin/ec2adddopt
${EC2_DIR}/bin/ec2addgrp
${EC2_DIR}/bin/ec2addkey
${EC2_DIR}/bin/ec2addpgrp
${EC2_DIR}/bin/ec2addsds
${EC2_DIR}/bin/ec2addsnap
${EC2_DIR}/bin/ec2addsubnet
${EC2_DIR}/bin/ec2addtag
${EC2_DIR}/bin/ec2addvgw
${EC2_DIR}/bin/ec2addvol
${EC2_DIR}/bin/ec2addvpc
${EC2_DIR}/bin/ec2addvpn
${EC2_DIR}/bin/ec2allocaddr
${EC2_DIR}/bin/ec2assocaddr
${EC2_DIR}/bin/ec2assocdopt
${EC2_DIR}/bin/ec2attvgw
${EC2_DIR}/bin/ec2attvol
${EC2_DIR}/bin/ec2auth
${EC2_DIR}/bin/ec2bundle
${EC2_DIR}/bin/ec2cbun
${EC2_DIR}/bin/ec2cct
${EC2_DIR}/bin/ec2cim
${EC2_DIR}/bin/ec2cpi
${EC2_DIR}/bin/ec2csir
${EC2_DIR}/bin/ec2daddr
${EC2_DIR}/bin/ec2datt
${EC2_DIR}/bin/ec2daz
${EC2_DIR}/bin/ec2dbun
${EC2_DIR}/bin/ec2dcgw
${EC2_DIR}/bin/ec2dct
${EC2_DIR}/bin/ec2ddi
${EC2_DIR}/bin/ec2ddopt
${EC2_DIR}/bin/ec2deactlic
${EC2_DIR}/bin/ec2delcgw
${EC2_DIR}/bin/ec2deldopt
${EC2_DIR}/bin/ec2delgrp
${EC2_DIR}/bin/ec2delkey
${EC2_DIR}/bin/ec2delpgrp
${EC2_DIR}/bin/ec2delsds
${EC2_DIR}/bin/ec2delsnap
${EC2_DIR}/bin/ec2delsubnet
${EC2_DIR}/bin/ec2deltag
${EC2_DIR}/bin/ec2delvgw
${EC2_DIR}/bin/ec2delvol
${EC2_DIR}/bin/ec2delvpc
${EC2_DIR}/bin/ec2delvpn
${EC2_DIR}/bin/ec2dereg
${EC2_DIR}/bin/ec2detvgw
${EC2_DIR}/bin/ec2detvol
${EC2_DIR}/bin/ec2dgrp
${EC2_DIR}/bin/ec2diatt
${EC2_DIR}/bin/ec2dim
${EC2_DIR}/bin/ec2dimatt
${EC2_DIR}/bin/ec2din
${EC2_DIR}/bin/ec2dinatt
${EC2_DIR}/bin/ec2disaddr
${EC2_DIR}/bin/ec2dkey
${EC2_DIR}/bin/ec2dlic
${EC2_DIR}/bin/ec2dpgrp
${EC2_DIR}/bin/ec2dre
${EC2_DIR}/bin/ec2dri
${EC2_DIR}/bin/ec2drio
${EC2_DIR}/bin/ec2dsds
${EC2_DIR}/bin/ec2dsir
${EC2_DIR}/bin/ec2dsnap
${EC2_DIR}/bin/ec2dsnapatt
${EC2_DIR}/bin/ec2dsph
${EC2_DIR}/bin/ec2dsubnet
${EC2_DIR}/bin/ec2dtag
${EC2_DIR}/bin/ec2dvgw
${EC2_DIR}/bin/ec2dvol
${EC2_DIR}/bin/ec2dvpc
${EC2_DIR}/bin/ec2dvpn
${EC2_DIR}/bin/ec2fp
${EC2_DIR}/bin/ec2gcons
${EC2_DIR}/bin/ec2gpass
${EC2_DIR}/bin/ec2ii
${EC2_DIR}/bin/ec2ikey
${EC2_DIR}/bin/ec2iv
${EC2_DIR}/bin/ec2kill
${EC2_DIR}/bin/ec2matt
${EC2_DIR}/bin/ec2miatt
${EC2_DIR}/bin/ec2mim
${EC2_DIR}/bin/ec2mimatt
${EC2_DIR}/bin/ec2min
${EC2_DIR}/bin/ec2minatt
${EC2_DIR}/bin/ec2msnapatt
${EC2_DIR}/bin/ec2prio
${EC2_DIR}/bin/ec2ratt
${EC2_DIR}/bin/ec2reboot
${EC2_DIR}/bin/ec2reg
${EC2_DIR}/bin/ec2reladdr
${EC2_DIR}/bin/ec2revoke
${EC2_DIR}/bin/ec2riatt
${EC2_DIR}/bin/ec2rimatt
${EC2_DIR}/bin/ec2rinatt
${EC2_DIR}/bin/ec2rsi
${EC2_DIR}/bin/ec2rsnapatt
${EC2_DIR}/bin/ec2run
${EC2_DIR}/bin/ec2start
${EC2_DIR}/bin/ec2stop
${EC2_DIR}/bin/ec2tag
${EC2_DIR}/bin/ec2udi
${EC2_DIR}/bin/ec2umin
${EC2_DIR}/bin/ec2ver
${EC2_DIR}/lib/activation-1.1.jar
${EC2_DIR}/lib/bcprov.jar
${EC2_DIR}/lib/commons-cli-1.1.jar
${EC2_DIR}/lib/commons-codec-1.3.jar
${EC2_DIR}/lib/commons-discovery-0.2.jar
${EC2_DIR}/lib/commons-httpclient-3.0.jar
${EC2_DIR}/lib/commons-logging-1.0.4.jar
${EC2_DIR}/lib/ec2-api-tools.jar
${EC2_DIR}/lib/ec2-conversion-lib.jar
${EC2_DIR}/lib/ec2-java-client.jar
${EC2_DIR}/lib/java-xmlbuilder-0.4-SNAPSHOT.jar
${EC2_DIR}/lib/jaxb-api-2.0.jar
${EC2_DIR}/lib/jaxb-impl-2.0.1.jar
${EC2_DIR}/lib/jaxws-api-2.0.jar
${EC2_DIR}/lib/jdom-1.0.jar
${EC2_DIR}/lib/jets3t-0.8.0.jar
${EC2_DIR}/lib/log4j.jar
${EC2_DIR}/lib/mail-1.4.jar
${EC2_DIR}/lib/stax-api-1.0.1.jar
${EC2_DIR}/lib/wsdl4j-1.6.1.jar
${EC2_DIR}/lib/wss4j-1.5.1.jar
${EC2_DIR}/lib/wstx-asl-3.2.0.jar
${EC2_DIR}/lib/xalan-j2-2.7.0.jar
${EC2_DIR}/lib/xalan-j2-serializer-2.7.0.jar
${EC2_DIR}/lib/xfire-all-1.2.6.jar
${EC2_DIR}/lib/xfire-jsr181-api-1.0-M1.jar
${EC2_DIR}/lib/xmlsec-1.3.0.jar

View file

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
SHA1 (ec2-api-tools-1.3-62308.zip) = 28e3944391ad197e235a549ecf573007eb0a786d
RMD160 (ec2-api-tools-1.3-62308.zip) = e00874fd258af7912b4c1b6acfb56e6746ac7c77
Size (ec2-api-tools-1.3-62308.zip) = 8946930 bytes
SHA1 (patch-aa) = 7fcc4576ad658054f0f42ec688269839951135e8
SHA1 (patch-ab) = adf5fa6a389b275aa9d6d408c3982efdbcc61aa7

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
Prepare for substitution of the Java home path.
--- bin/ec2-cmd.orig 2010-12-15 17:41:53.000000000 +0000
+++ bin/ec2-cmd
@@ -14,7 +14,7 @@ EC2_HOME=${EC2_HOME:-EC2_HOME is not set
LIBDIR=$EC2_HOME/lib
# Check our Java env
-JAVA_HOME=${JAVA_HOME:?JAVA_HOME is not set}
+JAVA_HOME=@PKG_JAVA_HOME@
# If a classpath exists preserve it
CP=$CLASSPATH

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2011/01/20 00:31:39 jym-netbsd Exp $
Remove bashism.
--- bin/ec2-cmd.orig 2010-12-15 17:41:53.000000000 +0000
+++ bin/ec2-cmd
@@ -29,7 +29,7 @@ esac
cygprop=""
# And add our own libraries too
-if [ "$cygwin" == "true" ] ; then
+if [ "$cygwin" = "true" ] ; then
cygprop="-Dec2.cygwin=true"
# Make sure that when using Cygwin we use Unix