gem free version of graphics/ruby-rcairo, just for my fun.
while here, taken patch form upstream to honer PKG_CONFIG_LIBDIR.
This commit is contained in:
parent
a53d0943e1
commit
e034f80197
5 changed files with 79 additions and 0 deletions
2
rcairo/DESCR
Normal file
2
rcairo/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
Cairo is a 2D graphics library with support for multiple output
|
||||
devices. rcairo provides ruby bindings to cairo.
|
28
rcairo/Makefile
Normal file
28
rcairo/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2008/04/24 13:05:13 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= rcairo-1.6.0
|
||||
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://cairographics.org/releases/
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://cairographics.org/rcairo/
|
||||
COMMENT= Ruby bindings for cairo
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
BUILDLINK_API_DEPENDS.cairo+= cairo>=1.2.0
|
||||
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
RUBY_HAS_ARCHLIB= YES
|
||||
USE_RUBY_EXTCONF= YES
|
||||
|
||||
#CONFIGURE_ENV+= PKG_CONFIG_PATH=${_PKG_CONFIG_LIBDIR:Q}
|
||||
#CONFIGURE_ENV+= PKG_CONFIG_PATH=${BUILDLINK_DIR:Q}/lib/pkg-config
|
||||
#CONFIGURE_ENV+= PKG_CONFIG=${BUILDLINK_DIR:Q}/bin/pkg-config
|
||||
|
||||
.include "../../lang/ruby/modules.mk"
|
||||
.include "../../graphics/cairo/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
20
rcairo/PLIST
Normal file
20
rcairo/PLIST
Normal file
|
@ -0,0 +1,20 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2008/04/24 13:05:13 obache Exp $
|
||||
${RUBY_SITEARCHLIBDIR}/cairo.${RUBY_DLEXT}
|
||||
${RUBY_SITEARCHLIBDIR}/rb_cairo.h
|
||||
${RUBY_SITELIBDIR}/cairo.rb
|
||||
${RUBY_SITELIBDIR}/cairo/color.rb
|
||||
${RUBY_SITELIBDIR}/cairo/colors.rb
|
||||
${RUBY_SITELIBDIR}/cairo/constants.rb
|
||||
${RUBY_SITELIBDIR}/cairo/context.rb
|
||||
${RUBY_SITELIBDIR}/cairo/context/blur.rb
|
||||
${RUBY_SITELIBDIR}/cairo/context/circle.rb
|
||||
${RUBY_SITELIBDIR}/cairo/context/color.rb
|
||||
${RUBY_SITELIBDIR}/cairo/context/path.rb
|
||||
${RUBY_SITELIBDIR}/cairo/context/rectangle.rb
|
||||
${RUBY_SITELIBDIR}/cairo/context/triangle.rb
|
||||
${RUBY_SITELIBDIR}/cairo/paper.rb
|
||||
${RUBY_SITELIBDIR}/cairo/papers.rb
|
||||
${RUBY_SITELIBDIR}/cairo/path.rb
|
||||
${RUBY_SITELIBDIR}/cairo/point.rb
|
||||
@dirrm ${RUBY_SITELIBDIR}/cairo/context
|
||||
@dirrm ${RUBY_SITELIBDIR}/cairo
|
6
rcairo/distinfo
Normal file
6
rcairo/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/04/24 13:05:13 obache Exp $
|
||||
|
||||
SHA1 (rcairo-1.6.0.tar.gz) = f8f01d1871b5fcd9a167f5d27190d22753f3c663
|
||||
RMD160 (rcairo-1.6.0.tar.gz) = f1267d827f0be349b5c0591a767fef1ba4bc9104
|
||||
Size (rcairo-1.6.0.tar.gz) = 243006 bytes
|
||||
SHA1 (patch-aa) = ebdf43271c87920277c2a3a8f4b5008fd504daab
|
23
rcairo/patches/patch-aa
Normal file
23
rcairo/patches/patch-aa
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/04/24 13:05:13 obache Exp $
|
||||
|
||||
--- pkg-config.rb.orig 2008-04-04 04:13:14.000000000 +0000
|
||||
+++ pkg-config.rb
|
||||
@@ -166,6 +166,8 @@ class PackageConfig
|
||||
|
||||
def guess_default_path
|
||||
default_path = "/usr/local/lib/pkgconfig:/usr/lib/pkgconfig"
|
||||
+ libdir = ENV["PKG_CONFIG_LIBDIR"]
|
||||
+ default_path = "#{libdir}:#{default_path}" if libdir
|
||||
pkg_config = with_config("pkg-config", ENV["PKG_CONFIG"] || "pkg-config")
|
||||
pkg_config = Pathname.new(pkg_config)
|
||||
unless pkg_config.absolute?
|
||||
@@ -191,7 +193,8 @@ class PackageConfig
|
||||
return default_path if pkg_config.nil?
|
||||
pkg_config = Pathname.new(pkg_config)
|
||||
end
|
||||
- (pkg_config.parent.parent + "lib" + "pkgconfig").to_s
|
||||
+ [(pkg_config.parent.parent + "lib" + "pkgconfig").to_s,
|
||||
+ default_path].join(":")
|
||||
end
|
||||
end
|
||||
|
Loading…
Reference in a new issue