POSIX bindings for lua. This one is for the 5.0 legacy release.
This commit is contained in:
parent
286b9ac93c
commit
e0fd626dba
6 changed files with 95 additions and 0 deletions
1
lua50-posix/DESCR
Normal file
1
lua50-posix/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
These are POSIX bindings for lua 5.0.x.
|
18
lua50-posix/Makefile
Normal file
18
lua50-posix/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2007/05/31 19:34:24 hoka_adam Exp $
|
||||
|
||||
DISTNAME= lposix
|
||||
PKGNAME= lua50-posix-1.0
|
||||
CATEGORIES= devel
|
||||
WRKSRC= ${WRKDIR}/posix
|
||||
MASTER_SITES= http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/5.0/
|
||||
|
||||
MAINTAINER= adam.hoka@gmail.com
|
||||
COMMENT= POSIX bindings for Lua 5.0.x
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/lposix.so ${PREFIX}/lib/lua/5.0/
|
||||
${INSTALL_DATA} ${WRKSRC}/posix.lua ${PREFIX}/share/lua/5.0/
|
||||
|
||||
.include "../../wip/lua50/buildlink3.mk"
|
||||
.include "../../wip/lua50-compat51/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
lua50-posix/PLIST
Normal file
5
lua50-posix/PLIST
Normal file
|
@ -0,0 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2007/05/31 19:34:24 hoka_adam Exp $
|
||||
lib/lua/5.0/lposix.so
|
||||
share/lua/5.0/posix.lua
|
||||
@dirrm share/lua/5.0
|
||||
@dirrm lib/lua/5.0
|
22
lua50-posix/buildlink3.mk
Normal file
22
lua50-posix/buildlink3.mk
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2007/05/31 19:34:24 hoka_adam Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
LUA50_POSIX_BUILDLINK3_MK:= ${LUA50_POSIX_BUILDLINK3_MK}+
|
||||
|
||||
.if ${BUILDLINK_DEPTH} == "+"
|
||||
BUILDLINK_DEPENDS+= lua50-posix
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nlua50-posix}
|
||||
BUILDLINK_PACKAGES+= lua50-posix
|
||||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}lua50-posix
|
||||
|
||||
.if ${LUA50_POSIX_BUILDLINK3_MK} == "+"
|
||||
BUILDLINK_API_DEPENDS.lua50-posix+= lua50-posix>=1.0
|
||||
BUILDLINK_PKGSRCDIR.lua50-posix?= ../../wip/lua50-posix
|
||||
.endif # LUA50_POSIX_BUILDLINK3_MK
|
||||
|
||||
.include "../../wip/lua50/buildlink3.mk"
|
||||
.include "../../wip/lua50-compat51/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
6
lua50-posix/distinfo
Normal file
6
lua50-posix/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/05/31 19:34:24 hoka_adam Exp $
|
||||
|
||||
SHA1 (lposix.tar.gz) = 85b58f90e225c15f512bd2f341086580f8c7e09c
|
||||
RMD160 (lposix.tar.gz) = c5c2366b9864773b350c02e032a1c6a433dcdbe5
|
||||
Size (lposix.tar.gz) = 9651 bytes
|
||||
SHA1 (patch-aa) = 7f3e374810c82974b547b6395aaea193ca27f6c9
|
43
lua50-posix/patches/patch-aa
Normal file
43
lua50-posix/patches/patch-aa
Normal file
|
@ -0,0 +1,43 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2007/05/31 19:34:24 hoka_adam Exp $
|
||||
|
||||
--- Makefile.orig 2003-11-06 01:26:49.000000000 +0100
|
||||
+++ Makefile
|
||||
@@ -1,30 +1,33 @@
|
||||
# makefile for POSIX library for Lua
|
||||
|
||||
# change these to reflect your Lua installation
|
||||
-LUA= /tmp/lhf/lua-5.0
|
||||
+LUA= ${PREFIX}
|
||||
LUAINC= $(LUA)/include
|
||||
LUALIB= $(LUA)/lib
|
||||
LUABIN= $(LUA)/bin
|
||||
|
||||
# no need to change anything below here
|
||||
CFLAGS= -fPIC $(INCS) $(WARN) -O2 $G
|
||||
-WARN= -pedantic -Wall
|
||||
+WARN= -Wall
|
||||
INCS= -I$(LUAINC)
|
||||
|
||||
MYNAME= posix
|
||||
MYLIB= l$(MYNAME)
|
||||
|
||||
-OBJS= $(MYLIB).o
|
||||
+OBJS= $(MYLIB).o compat-5.1.o
|
||||
|
||||
T= $(MYLIB).so
|
||||
|
||||
-all: test
|
||||
+all: $T
|
||||
|
||||
test: $T
|
||||
$(LUABIN)/lua -l$(MYNAME) test.lua
|
||||
|
||||
$T: $(OBJS)
|
||||
- $(CC) -o $@ -shared $(OBJS)
|
||||
+ $(CC) -o $@ -shared $(OBJS) -L$(LUALIB) -llua -llualib
|
||||
+
|
||||
+compat-5.1.c: $(LUALIB)/lua/compat-5.1r5/compat-5.1.c
|
||||
+ cp $(LUALIB)/lua/compat-5.1r5/compat-5.1.? .
|
||||
|
||||
$(OBJS): modemuncher.c
|
||||
|
Loading…
Reference in a new issue