Update to 1.1 and add a debug option. Also, the old distfile was not
available anymore. Changes: 20051120: - Added "nextstacked" key binding. - Released v1.1. 20051119: - Added ClockStyle, TrayButtonStyle, and TrayStyle options. - Now icon aspect ratios are preserved when resized. 20051116: - Added button border to TrayButtons. - Added Clock. 20051114: - Fixed task list overflow. - Fixed minimization on restart. 20051113: - Released v1.0. 20051112: - Make maximization work in a more sane manner. 20051111: - Focus next client in the stacking order when the active client is closed. - Added "Desktops" root menu item. - Fixed key actions with click-to-focus. - Improved window placement. 20051110: - Now desktops can be named, changes to the configuration for this. 20051109: - Send ClientMessage instead of PropertyNotify for _JWM commands. - More EWMH support. - Fix label attribute for RootMenu. - Added menu includes (rarsa). - Fix a minor menu bug. 20051106: - Restore maximization status on restart. 20051027: - Fix byte-order issue with PNG images. 20051026: - Fix lockup issue when restoring transient windows. - Added a separator to the window menu before kill/close. 20051024: - Fix 64-bit X server issues. 20051016: - Tray button can now execute external programs (or show the root menu). 20051013: - Support for vertical trays, pagers, and task lists. 20051012: - Added the ability to swallow applications in the tray. 20051010: - Overhaul of the tray. Multiple trays now supported. [The configuration file changed] 20051007: - Large windows are now handled in a more sane manner. 20051003: - Flush the X connection before closing it. - Make status windows show on the screen with the mouse. - Fixed an off-by-one error drawing the load. 20051001: - Can now use XRender for rendering icons. - Added support for PNG icons (optional). - Icons are now scaled independently for title bars and the task bar. - Added "height" attribute to RootMenu and Menu. 20050925: - Now uses Xft for antialiasing, which can be disabled at compile time. - Made drawing of border double-buffered. 20050924: - Added "enabled" option to Pager. - Fixed a bug with loading icons. - Attempted to fix color issues on 64-bit X-Servers.
This commit is contained in:
parent
bc6a053473
commit
e23b65e7ef
5 changed files with 61 additions and 12 deletions
20
jwm/Makefile
20
jwm/Makefile
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.5 2005/11/06 10:18:47 leonardschmidt Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2005/11/27 10:08:43 leonardschmidt Exp $
|
||||
#
|
||||
|
||||
DISTNAME= jwm-0.24
|
||||
PKGREVISION= 1
|
||||
DISTNAME= jwm-1.1
|
||||
CATEGORIES= wm x11
|
||||
MASTER_SITES= http://www.joewing.net/programs/jwm/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -11,10 +10,16 @@ MAINTAINER= pip88nl@gmail.com
|
|||
HOMEPAGE= http://joewing.net/programs/jwm
|
||||
COMMENT= Lightweight window manager with virtual desktops
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PKGINSTALL= yes
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if exists(${X11BASE}/include/X11/extensions/Xinerama.h)
|
||||
CONFIGURE_ARGS+= --enable-xinerama
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
|
||||
SUBST_CLASSES+= egdir
|
||||
SUBST_STAGE.egdir= pre-configure
|
||||
|
@ -25,5 +30,10 @@ PKG_SYSCONFSUBDIR= jwm
|
|||
EGDIR= ${PREFIX}/share/examples/jwm
|
||||
CONF_FILES= ${EGDIR}/system.jwmrc ${PKG_SYSCONFDIR}/system.jwmrc
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../fonts/Xft2/buildlink3.mk"
|
||||
.include "../../graphics/xpm/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../mk/x11.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
11
jwm/distinfo
11
jwm/distinfo
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/10/13 15:46:25 ghen Exp $
|
||||
$NetBSD: distinfo,v 1.3 2005/11/27 10:08:43 leonardschmidt Exp $
|
||||
|
||||
SHA1 (jwm-0.24.tar.bz2) = 3059e3a3c03b7c4b619818a19997280ee0f56b6c
|
||||
RMD160 (jwm-0.24.tar.bz2) = 12e7aa89dcd867d622d220c28f2cd108bd1814e7
|
||||
Size (jwm-0.24.tar.bz2) = 101478 bytes
|
||||
SHA1 (patch-aa) = 982532b3f62e2de04a21a9683629602af105dc25
|
||||
SHA1 (jwm-1.1.tar.bz2) = b5e6443fe82d218e5476150bc9699120e902c902
|
||||
RMD160 (jwm-1.1.tar.bz2) = 69ec91632ba361ac00121a75128c7ea4d2b314cf
|
||||
Size (jwm-1.1.tar.bz2) = 111464 bytes
|
||||
SHA1 (patch-aa) = ac33481d7e4d081960977a05f87c698865d19c63
|
||||
SHA1 (patch-ab) = 37dde771f21eb0ae63af01ecd53f2f201dd1c6fc
|
||||
SHA1 (patch-ac) = 7969b853bfd64243526174d021f6e0bbd7f1ba57
|
||||
|
|
10
jwm/options.mk
Normal file
10
jwm/options.mk
Normal file
|
@ -0,0 +1,10 @@
|
|||
# $NetBSD: options.mk,v 1.1 2005/11/27 10:08:44 leonardschmidt Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.jwm
|
||||
PKG_SUPPORTED_OPTIONS= debug
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mdebug)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.1 2005/10/13 15:46:25 ghen Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2005/11/27 10:08:44 leonardschmidt Exp $
|
||||
|
||||
--- Makefile.in.orig 2005-09-23 03:48:27.000000000 +0200
|
||||
--- Makefile.in.orig 2005-11-21 04:02:12.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -1,5 +1,5 @@
|
||||
|
||||
|
@ -9,3 +9,18 @@ $NetBSD: patch-aa,v 1.1 2005/10/13 15:46:25 ghen Exp $
|
|||
MANDIR = @MANDIR@
|
||||
VERSION = @VERSION@
|
||||
|
||||
@@ -8,10 +8,10 @@ all:
|
||||
|
||||
install: all
|
||||
cd src ; $(MAKE) install ; cd ..
|
||||
- install -d $(SYSCONF)
|
||||
- install -m 644 example.jwmrc $(SYSCONF)/system.jwmrc
|
||||
- install -d $(MANDIR)/man1
|
||||
- install -m 644 jwm.1 $(MANDIR)/man1/jwm.1
|
||||
+ ${BSD_INSTALL_DATA_DIR} $(SYSCONF)
|
||||
+ ${BSD_INSTALL_DATA} example.jwmrc $(SYSCONF)/system.jwmrc
|
||||
+ ${BSD_INSTALL_MAN_DIR} $(MANDIR)/man1
|
||||
+ ${BSD_INSTALL_MAN} jwm.1 $(MANDIR)/man1/jwm.1
|
||||
|
||||
depend:
|
||||
cd src ; $(MAKE) depend
|
||||
|
|
13
jwm/patches/patch-ac
Normal file
13
jwm/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1 2005/11/27 10:08:44 leonardschmidt Exp $
|
||||
|
||||
--- configure.orig 2005-11-21 04:02:12.000000000 +0000
|
||||
+++ configure
|
||||
@@ -2728,7 +2728,7 @@ echo "${ECHO_T}libraries $x_libraries, h
|
||||
fi
|
||||
|
||||
|
||||
-CFLAGS="-O2 $CFLAGS -ansi -D_XOPEN_SOURCE=600"
|
||||
+CFLAGS="$CFLAGS -D_XOPEN_SOURCE=600"
|
||||
|
||||
if test ! "$no_x" = "yes" ; then
|
||||
if test ! x"$x_libraries" = x ; then
|
Loading…
Reference in a new issue