Update allegro to 4.1.13 (latest development version) and bl3ify, remove
TODO because it works fine now. Changes: ==================================================================== ============ Changes from 4.1.12 to 4.1.13 (March 2004) ============ ==================================================================== Minor changes and clarifications in the docs by Sven Sandberg, Andy Goth, Jon Rafkind, Nathan Smith and Daniel Schlyder. Elias Pschernig extensively modified the ALSA 0.9/1.0 sound driver to make it work more nicely. Julien Cugniere and Eric Botcazou fixed the crash on exit with the aRts sound driver. Nathan Smith implemented the recursive handling of directories for the dat utility. Eric Botcazou renamed the new '-r' option of the dat utility into '-f'. Omar Cornut improved the handling of KEY_COLON2 on Japanese keyboards. Omar Cornut fixed the Windows joystick driver to handle a weird peculiarity of the DirectInput API. Elias Pschernig corrected the value of the alpha-channel depth field in the header when saving TGA image files. Eric Botcazou fixed again the formula giving the stride value in the Linux framebuffer console. Eric Botcazou restored the pixel-correct version of line() and added fastline() after Doug Eleveld had reported the problem. Andy Goth and Eric Botcazou fixed the constructor support in dat2s on Unix. Angelo Mottola revamped the MacOS X package creation process to make it work under 10.3 and create an enduser package that holds just the shared framework. Angelo Mottola changed the MacOS X shared library building process to have a prebound shared library separated from a small static libray holding just the magic main stuff. Angelo Mottola removed window shadow flickering when moving the program window around on MacOS X.
This commit is contained in:
parent
266761562e
commit
e240c33c0b
12 changed files with 130 additions and 277 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.7 2004/01/25 02:11:30 grantbeattie Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2004/04/05 04:25:05 xtraeme Exp $
|
||||
#
|
||||
|
||||
DISTNAME= allegro-4.1.12
|
||||
DISTNAME= allegro-4.1.13
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=alleg/}
|
||||
|
||||
|
@ -9,30 +9,32 @@ MAINTAINER= wiz@NetBSD.org
|
|||
HOMEPAGE= http://alleg.sourceforge.net/
|
||||
COMMENT= Allegro game programming library
|
||||
|
||||
USE_BUILDLINK2= YES
|
||||
USE_BUILDLINK3= yes
|
||||
USE_GNU_TOOLS+= make
|
||||
USE_X11= YES
|
||||
GNU_CONFIGURE= YES
|
||||
USE_X11= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAKEFILE= makefile
|
||||
ALL_TARGET= # there is no 'all' target for some reason
|
||||
USE_NEW_TEXINFO= YES
|
||||
USE_MAKEINFO= YES
|
||||
USE_MAKEINFO= yes
|
||||
INFO_FILES= allegro.info
|
||||
INSTALL_TARGET= install install-info
|
||||
|
||||
# build debugging lib
|
||||
CONFIGURE_ARGS+= --enable-dbglib
|
||||
|
||||
# NetBSD's OSS midi emulation is non-existant.
|
||||
CONFIGURE_ARGS+= --disable-ossmidi
|
||||
# Following three only exist as static libraries, but will be linked
|
||||
# into shared library by allegro if enabled.
|
||||
CONFIGURE_ARGS+= --disable-xwin-vidmode
|
||||
CONFIGURE_ARGS+= --disable-xwin-dga
|
||||
CONFIGURE_ARGS+= --disable-xwin-dga2
|
||||
|
||||
LIBS+= ${LIBOSSAUDIO}
|
||||
CFLAGS+= -DDEVOSSAUDIO=\"\\\"${DEVOSSAUDIO}\\\"\"
|
||||
|
||||
.include "../../mk/ossaudio.buildlink2.mk"
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
BUILD_DEFS+= USE_ESOUND
|
||||
|
||||
.if !empty(USE_ESOUND:M[Yy][Ee][Ss])
|
||||
CONFIGURE_ARGS+= --enable-esddigi
|
||||
.include "../../audio/esound/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.include "../../mk/ossaudio.buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2003/07/02 09:43:24 blef Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2004/04/05 04:25:05 xtraeme Exp $
|
||||
bin/allegro-config
|
||||
bin/colormap
|
||||
bin/dat
|
||||
|
@ -93,10 +93,8 @@ include/allegro/timer.h
|
|||
include/allegro/unicode.h
|
||||
include/linalleg.h
|
||||
include/xalleg.h
|
||||
info/allegro.info
|
||||
lib/liballd-${PKGVERSION}.so
|
||||
lib/liballd.so.4.1
|
||||
lib/liballd_unsharable.a
|
||||
lib/allegro/4.1/alleg-dga2.so
|
||||
lib/allegro/4.1/modules.lst
|
||||
lib/liballeg-${PKGVERSION}.so
|
||||
lib/liballeg.so.4.1
|
||||
lib/liballeg_unsharable.a
|
||||
|
@ -104,3 +102,5 @@ lib/liballeg_unsharable.a
|
|||
@dirrm include/allegro/internal
|
||||
@dirrm include/allegro/inline
|
||||
@dirrm include/allegro
|
||||
@dirrm lib/allegro/4.1
|
||||
@dirrm lib/allegro
|
||||
|
|
11
allegro/TODO
11
allegro/TODO
|
@ -1,11 +0,0 @@
|
|||
Reason it's not committed:
|
||||
liquidwar isn't working, probably a threading issue. (LW's menu loads in 1.6.1
|
||||
if I wait a while, and works flawlessly in current -Soren)
|
||||
|
||||
patch-aa, patch-ab, and patch-ad are only there to add debug flags --
|
||||
they should be removed once the problem with liquid war is found and fixed.
|
||||
The same holds for --enable-dbglib in Makefile.
|
||||
|
||||
patch-ae is an unsuccessful try to fix the problem.
|
||||
|
||||
Help in debugging this welcome.
|
|
@ -1,104 +0,0 @@
|
|||
# $NetBSD: buildlink2.mk,v 1.1.1.1 2003/04/06 11:17:20 thomasklausner Exp $
|
||||
#
|
||||
|
||||
.if !defined(ALLEGRO_BUILDLINK2_MK)
|
||||
ALLEGRO_BUILDLINK2_MK= # defined
|
||||
|
||||
BUILDLINK_PACKAGES+= allegro
|
||||
BUILDLINK_DEPENDS.allegro?= allegro>=4.1.8
|
||||
BUILDLINK_PKGSRCDIR.allegro?= ../../wip/allegro
|
||||
|
||||
EVAL_PREFIX+= BUILDLINK_PREFIX.allegro=allegro
|
||||
BUILDLINK_PREFIX.allegro_DEFAULT= ${LOCALBASE}
|
||||
BUILDLINK_FILES.allegro+= include/allegro.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/3d.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/3dmaths.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/alcompat.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/alinline.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/alunixac.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/base.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/color.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/compiled.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/config.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/datafile.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/debug.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/digi.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/draw.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/file.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/fix.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/fixed.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/fli.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/fmaths.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/gfx.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/graphics.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/gui.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/3dmaths.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/asm.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/color.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/draw.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/file.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/fix.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/fmaths.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/gfx.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/matrix.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/rle.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/inline/system.inl
|
||||
BUILDLINK_FILES.allegro+= include/allegro/internal/aintern.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/internal/aintvga.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/internal/alconfig.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/joystick.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/keyboard.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/matrix.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/midi.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/mouse.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/palette.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aintbeos.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aintdos.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aintlnx.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aintmac.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aintqnx.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aintunix.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aintwin.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/al386gcc.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/al386vc.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/al386wat.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/albcc32.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/albecfg.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/albeos.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aldjgpp.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/aldos.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/almac.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/almaccfg.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/almngw32.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/almsvc.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/alplatf.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/alqnx.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/alqnxcfg.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/alucfg.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/alunix.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/alunixac.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/alwatcom.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/alwin.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/platform/macdef.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/quat.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/rle.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/sound.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/stream.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/system.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/text.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/timer.h
|
||||
BUILDLINK_FILES.allegro+= include/allegro/unicode.h
|
||||
BUILDLINK_FILES.allegro+= include/linalleg.h
|
||||
BUILDLINK_FILES.allegro+= include/xalleg.h
|
||||
BUILDLINK_FILES.allegro+= lib/liballd-*.*
|
||||
BUILDLINK_FILES.allegro+= lib/liballd.*
|
||||
BUILDLINK_FILES.allegro+= lib/liballd_unsharable.*
|
||||
BUILDLINK_FILES.allegro+= lib/liballeg-*.*
|
||||
BUILDLINK_FILES.allegro+= lib/liballeg.*
|
||||
BUILDLINK_FILES.allegro+= lib/liballeg_unsharable.*
|
||||
|
||||
BUILDLINK_TARGETS+= allegro-buildlink
|
||||
|
||||
allegro-buildlink: _BUILDLINK_USE
|
||||
|
||||
.endif # ALLEGRO_BUILDLINK2_MK
|
20
allegro/buildlink3.mk
Normal file
20
allegro/buildlink3.mk
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2004/04/05 04:25:05 xtraeme Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
ALLEGRO_BUILDLINK3_MK:= ${ALLEGRO_BUILDLINK3_MK}+
|
||||
|
||||
.if !empty(BUILDLINK_DEPTH:M+)
|
||||
BUILDLINK_DEPENDS+= allegro
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nallegro}
|
||||
BUILDLINK_PACKAGES+= allegro
|
||||
|
||||
.if !empty(ALLEGRO_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.allegro+= allegro>=4.1.13
|
||||
BUILDLINK_PKGSRCDIR.allegro?= ../../wip/allegro
|
||||
.endif # ALLEGRO_BUILDLINK3_MK
|
||||
|
||||
.include "../../audio/esound/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
|
@ -1,10 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.5 2003/11/27 22:20:08 blef Exp $
|
||||
$NetBSD: distinfo,v 1.6 2004/04/05 04:25:05 xtraeme Exp $
|
||||
|
||||
SHA1 (allegro-4.1.12.tar.gz) = 848ab42a5378cbe3da30db45fae8912653b13b7c
|
||||
Size (allegro-4.1.12.tar.gz) = 2760323 bytes
|
||||
SHA1 (patch-aa) = 8e9694c647170b1222d17a6b2a662dae3afb861d
|
||||
SHA1 (patch-ab) = 615a3e054ddf1f12ca3c7e6ddce6847b38a1bb6e
|
||||
SHA1 (patch-ac) = 9cd0b652ac08d121575fc9209203b213657f5682
|
||||
SHA1 (patch-ad) = 798e1af2e62a92bf2e25f07551dd946c3abc406d
|
||||
SHA1 (patch-ae) = cd316b805e6f4f33cc156b1242696651f5765d9b
|
||||
SHA1 (patch-af) = 510655ab2fdaf0583e0044d974a5a1007e57d822
|
||||
SHA1 (allegro-4.1.13.tar.gz) = 0238c39abdfe9f9de093576b7c66c37665bb8ce8
|
||||
Size (allegro-4.1.13.tar.gz) = 2773434 bytes
|
||||
SHA1 (patch-aa) = 9cd0b652ac08d121575fc9209203b213657f5682
|
||||
SHA1 (patch-ab) = cd316b805e6f4f33cc156b1242696651f5765d9b
|
||||
SHA1 (patch-ac) = 510655ab2fdaf0583e0044d974a5a1007e57d822
|
||||
|
|
|
@ -1,22 +1,41 @@
|
|||
$NetBSD: patch-aa,v 1.3 2003/11/27 22:20:09 blef Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2004/04/05 04:25:05 xtraeme Exp $
|
||||
|
||||
--- configure.orig 2003-11-27 05:59:16.000000000 -0800
|
||||
+++ configure 2003-11-27 06:01:17.000000000 -0800
|
||||
@@ -4043,7 +4043,7 @@
|
||||
COMPILE_CXX_PROGRAM=COMPILE_CXX_NORMAL
|
||||
COMPILE_S_PROGRAM=COMPILE_S_NORMAL
|
||||
if test "X$allegro_cv_prog_ld_s" = "Xyes"; then
|
||||
- PROG_LDFLAGS="-s \$(LDFLAGS)"
|
||||
+ PROG_LDFLAGS="\$(LDFLAGS)"
|
||||
else
|
||||
PROG_LDFLAGS="\$(LDFLAGS)"
|
||||
--- makefile.in.orig Sun Jun 29 16:27:00 2003
|
||||
+++ makefile.in Wed Jul 2 13:50:49 2003
|
||||
@@ -59,7 +59,7 @@
|
||||
|
||||
INCLUDES =
|
||||
DEFS = @DEFS@ -Iinclude -Iinclude/allegro -I$(srcdir)/include -I$(srcdir)/include/allegro -I.
|
||||
-CPPFLAGS = @CPPFLAGS@
|
||||
+CPPFLAGS = @CPPFLAGS@ -DDEVOSSAUDIO=\"${DEVOSSAUDIO}\"
|
||||
LDFLAGS = @LDFLAGS@
|
||||
PROG_LDFLAGS = @PROG_LDFLAGS@
|
||||
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS)
|
||||
@@ -82,7 +82,7 @@
|
||||
COMPILE_S_PROGRAM = $(@COMPILE_S_PROGRAM@)
|
||||
|
||||
LIBALLEG = @LIBALLEG@
|
||||
-LINK_LIBALLEG = @LINK_LIBALLEG@
|
||||
+LINK_LIBALLEG = @LINK_LIBALLEG@ ${LIBOSSAUDIO}
|
||||
ALLEGRO_LIB_TARGETS = @ALLEGRO_LIB_TARGETS@
|
||||
ALLEGRO_MODULE_TARGETS = @ALLEGRO_MODULE_TARGETS@
|
||||
|
||||
@@ -417,17 +417,7 @@
|
||||
fi
|
||||
@@ -9861,7 +9861,7 @@
|
||||
s,@ECHO_T@,$ECHO_T,;t t
|
||||
s,@LIBS@,$LIBS,;t t
|
||||
s,@CC@,$CC,;t t
|
||||
-s,@CFLAGS@,$CFLAGS,;t t
|
||||
+s,@CFLAGS@,$CFLAGS -g,;t t
|
||||
s,@LDFLAGS@,$LDFLAGS,;t t
|
||||
s,@CPPFLAGS@,$CPPFLAGS,;t t
|
||||
s,@ac_ct_CC@,$ac_ct_CC,;t t
|
||||
$(mkinstalldirs) $(DESTDIR)$(bindir)
|
||||
@echo Installing allegro-config to $(DESTDIR)$(bindir)
|
||||
- @$(INSTALL_PROGRAM) allegro-config $(DESTDIR)$(bindir)
|
||||
- @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
|
||||
- (cat /etc/ld.so.conf | grep $(libdir) >/dev/null || \
|
||||
- test $(libdir) = /lib || test $(libdir) = /usr/lib) \
|
||||
- && ($(LDCONFIG) $(libdir) || true) || (\
|
||||
- echo "" ; \
|
||||
- echo "Warning: shared library destination $(libdir) is not in ldd search path." ; \
|
||||
- echo "Unless you add it to /etc/ld.so.conf, you must set LD_LIBRARY_PATH to include"; \
|
||||
- echo "$(libdir) each time you want to run an Allegro program." ; \
|
||||
- ) ; \
|
||||
- fi
|
||||
+ @$(BSD_INSTALL_SCRIPT) allegro-config $(DESTDIR)$(bindir)
|
||||
@for l in alleg alld allp; do \
|
||||
if test -f $(DESTDIR)$(libdir)/lib$${l}-$(shared_version).so -a \! -h $(DESTDIR)$(libdir)/lib$${l}.so.${shared_major_minor}; then \
|
||||
(cd $(DESTDIR)$(libdir); ln -s lib$${l}-$(shared_version).so lib$${l}.so.${shared_major_minor}); \
|
||||
|
|
|
@ -1,13 +1,30 @@
|
|||
$NetBSD: patch-ab,v 1.2 2003/07/02 05:36:25 blef Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2004/04/05 04:25:05 xtraeme Exp $
|
||||
|
||||
--- src/unix/uoss.c.orig Sun Jun 29 16:27:04 2003
|
||||
+++ src/unix/uoss.c Wed Jul 2 13:25:43 2003
|
||||
@@ -176,6 +176,8 @@
|
||||
_mix_some_samples((unsigned long) oss_bufdata, 0, oss_signed);
|
||||
}
|
||||
}
|
||||
+
|
||||
+ yield_timeslice();
|
||||
}
|
||||
|
||||
|
||||
@@ -191,7 +193,7 @@
|
||||
|
||||
ustrzcpy(_oss_driver, sizeof(_oss_driver), get_config_string(uconvert_ascii("sound", tmp1),
|
||||
uconvert_ascii("oss_driver", tmp2),
|
||||
- uconvert_ascii("/dev/dsp", tmp3)));
|
||||
+ uconvert_ascii(DEVOSSAUDIO, tmp3)));
|
||||
|
||||
ustrzcpy(_oss_mixer_driver, sizeof(_oss_mixer_driver), get_config_string(uconvert_ascii("sound", tmp1),
|
||||
uconvert_ascii("oss_mixer_driver", tmp2),
|
||||
@@ -583,6 +585,7 @@
|
||||
p[i] ^= 0x80;
|
||||
}
|
||||
|
||||
+ yield_timeslice();
|
||||
return 1;
|
||||
}
|
||||
|
||||
--- misc/deplib.sh.orig Tue Jul 1 21:38:28 2003
|
||||
+++ misc/deplib.sh Tue Jul 1 21:39:13 2003
|
||||
@@ -24,7 +24,7 @@
|
||||
echo " rm -f \$@"
|
||||
# gf: This bit is obviously gcc-specific
|
||||
# eb: Yes, but the GNU C Compiler doesn't always spell 'gcc'
|
||||
- echo " \$(CC) -shared -o \$@ ${shareobj} ${3} \$(LDFLAGS) -Wl,-h,lib${1}.so.\$(shared_major_minor) \$(LIBS)"
|
||||
+ echo " \$(CC) -g -shared -o \$@ ${shareobj} ${3} \$(LDFLAGS) -Wl,-h,lib${1}.so.\$(shared_major_minor) \$(LIBS)"
|
||||
echo ""
|
||||
echo "\$(LIBDIR)/${unsharelib}: ${unshareobj}"
|
||||
echo " rm -f \$@"
|
||||
|
|
|
@ -1,41 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.2 2003/07/02 21:00:27 blef Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2004/04/05 04:25:05 xtraeme Exp $
|
||||
|
||||
--- makefile.in.orig Sun Jun 29 16:27:00 2003
|
||||
+++ makefile.in Wed Jul 2 13:50:49 2003
|
||||
@@ -59,7 +59,7 @@
|
||||
--- setup/setup.c.orig Sun Jun 29 16:27:02 2003
|
||||
+++ setup/setup.c Wed Jul 2 13:02:28 2003
|
||||
@@ -211,7 +211,7 @@
|
||||
#endif
|
||||
|
||||
INCLUDES =
|
||||
DEFS = @DEFS@ -Iinclude -Iinclude/allegro -I$(srcdir)/include -I$(srcdir)/include/allegro -I.
|
||||
-CPPFLAGS = @CPPFLAGS@
|
||||
+CPPFLAGS = @CPPFLAGS@ -DDEVOSSAUDIO=\"${DEVOSSAUDIO}\"
|
||||
LDFLAGS = @LDFLAGS@
|
||||
PROG_LDFLAGS = @PROG_LDFLAGS@
|
||||
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS)
|
||||
@@ -82,7 +82,7 @@
|
||||
COMPILE_S_PROGRAM = $(@COMPILE_S_PROGRAM@)
|
||||
|
||||
LIBALLEG = @LIBALLEG@
|
||||
-LINK_LIBALLEG = @LINK_LIBALLEG@
|
||||
+LINK_LIBALLEG = @LINK_LIBALLEG@ ${LIBOSSAUDIO}
|
||||
ALLEGRO_LIB_TARGETS = @ALLEGRO_LIB_TARGETS@
|
||||
ALLEGRO_MODULE_TARGETS = @ALLEGRO_MODULE_TARGETS@
|
||||
|
||||
@@ -417,17 +417,7 @@
|
||||
fi
|
||||
$(mkinstalldirs) $(DESTDIR)$(bindir)
|
||||
@echo Installing allegro-config to $(DESTDIR)$(bindir)
|
||||
- @$(INSTALL_PROGRAM) allegro-config $(DESTDIR)$(bindir)
|
||||
- @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
|
||||
- (cat /etc/ld.so.conf | grep $(libdir) >/dev/null || \
|
||||
- test $(libdir) = /lib || test $(libdir) = /usr/lib) \
|
||||
- && ($(LDCONFIG) $(libdir) || true) || (\
|
||||
- echo "" ; \
|
||||
- echo "Warning: shared library destination $(libdir) is not in ldd search path." ; \
|
||||
- echo "Unless you add it to /etc/ld.so.conf, you must set LD_LIBRARY_PATH to include"; \
|
||||
- echo "$(libdir) each time you want to run an Allegro program." ; \
|
||||
- ) ; \
|
||||
- fi
|
||||
+ @$(BSD_INSTALL_SCRIPT) allegro-config $(DESTDIR)$(bindir)
|
||||
@for l in alleg alld allp; do \
|
||||
if test -f $(DESTDIR)$(libdir)/lib$${l}-$(shared_version).so -a \! -h $(DESTDIR)$(libdir)/lib$${l}.so.${shared_major_minor}; then \
|
||||
(cd $(DESTDIR)$(libdir); ln -s lib$${l}-$(shared_version).so lib$${l}.so.${shared_major_minor}); \
|
||||
#ifdef DIGI_OSS
|
||||
- { "oss_driver", param_str, "", "/dev/dsp", NULL, "Drv:", "", NULL, "Name of the driver (e.g. /dev/dsp)" },
|
||||
+ { "oss_driver", param_str, "", DEVOSSAUDIO, NULL, "Drv:", "", NULL, "Name of the driver (e.g. /dev/dsp)" },
|
||||
{ "oss_numfrags", param_int, "", "-1", &_oss_numfrags, "NumFr:", NULL, NULL, "Number of fragments (use 2, other values make little difference)" },
|
||||
{ "oss_fragsize", param_num, "", "-1", &_oss_fragsize, "Siz:", NULL, NULL, "Size of fragment (small values -- choppy sound, large values -- delayed sound)" },
|
||||
#endif
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2003/04/06 11:17:20 thomasklausner Exp $
|
||||
|
||||
--- misc/depmod.sh.orig Sat Dec 21 09:34:30 2002
|
||||
+++ misc/depmod.sh
|
||||
@@ -33,9 +33,9 @@ echo ""
|
||||
# module rule
|
||||
echo "\$(LIBDIR)/$module: \$(${objlist})"
|
||||
if test "$modlibs" = "--"; then
|
||||
- echo " \$(CC) -shared \$(ALLEGRO_SHAREDLIB_CFLAGS) -o \$@ \$(${objlist}) \$(LDFLAGS)"
|
||||
+ echo " \$(CC) -g -shared \$(ALLEGRO_SHAREDLIB_CFLAGS) -o \$@ \$(${objlist}) \$(LDFLAGS)"
|
||||
else
|
||||
- echo " \$(CC) -shared \$(ALLEGRO_SHAREDLIB_CFLAGS) -o \$@ \$(${objlist}) \$(LDFLAGS) $modlibs"
|
||||
+ echo " \$(CC) -g -shared \$(ALLEGRO_SHAREDLIB_CFLAGS) -o \$@ \$(${objlist}) \$(LDFLAGS) $modlibs"
|
||||
fi
|
||||
echo ""
|
||||
|
|
@ -1,30 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.2 2003/07/02 21:00:28 blef Exp $
|
||||
|
||||
--- src/unix/uoss.c.orig Sun Jun 29 16:27:04 2003
|
||||
+++ src/unix/uoss.c Wed Jul 2 13:25:43 2003
|
||||
@@ -176,6 +176,8 @@
|
||||
_mix_some_samples((unsigned long) oss_bufdata, 0, oss_signed);
|
||||
}
|
||||
}
|
||||
+
|
||||
+ yield_timeslice();
|
||||
}
|
||||
|
||||
|
||||
@@ -191,7 +193,7 @@
|
||||
|
||||
ustrzcpy(_oss_driver, sizeof(_oss_driver), get_config_string(uconvert_ascii("sound", tmp1),
|
||||
uconvert_ascii("oss_driver", tmp2),
|
||||
- uconvert_ascii("/dev/dsp", tmp3)));
|
||||
+ uconvert_ascii(DEVOSSAUDIO, tmp3)));
|
||||
|
||||
ustrzcpy(_oss_mixer_driver, sizeof(_oss_mixer_driver), get_config_string(uconvert_ascii("sound", tmp1),
|
||||
uconvert_ascii("oss_mixer_driver", tmp2),
|
||||
@@ -583,6 +585,7 @@
|
||||
p[i] ^= 0x80;
|
||||
}
|
||||
|
||||
+ yield_timeslice();
|
||||
return 1;
|
||||
}
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.2 2003/07/02 21:00:28 blef Exp $
|
||||
|
||||
--- setup/setup.c.orig Sun Jun 29 16:27:02 2003
|
||||
+++ setup/setup.c Wed Jul 2 13:02:28 2003
|
||||
@@ -211,7 +211,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef DIGI_OSS
|
||||
- { "oss_driver", param_str, "", "/dev/dsp", NULL, "Drv:", "", NULL, "Name of the driver (e.g. /dev/dsp)" },
|
||||
+ { "oss_driver", param_str, "", DEVOSSAUDIO, NULL, "Drv:", "", NULL, "Name of the driver (e.g. /dev/dsp)" },
|
||||
{ "oss_numfrags", param_int, "", "-1", &_oss_numfrags, "NumFr:", NULL, NULL, "Number of fragments (use 2, other values make little difference)" },
|
||||
{ "oss_fragsize", param_num, "", "-1", &_oss_fragsize, "Siz:", NULL, NULL, "Size of fragment (small values -- choppy sound, large values -- delayed sound)" },
|
||||
#endif
|
Loading…
Reference in a new issue