Newt is a windowing toolkit for text mode built from the slang

library. It allows color text mode applications to easily use
stackable windows, push buttons, check boxes, radio buttons, lists,   
entry fields, labels, and displayable text. Scrollbars are supported,
and forms may be nested to provide extra functionality.

Besides the newt library, this package provides whiptail, which may
be used from shell scripts similarly to Savio Lam's "dialog". Newt
provides the textual interface for the Red Hat and Debian boot
disks.

TODO:

- Add Python and TCL support options
- deal a bit better with libtool - shouldn't have to install whiptail from
  ${WRKSRC}/.libs
This commit is contained in:
Jeff Rizzo 2005-02-05 21:42:52 +00:00 committed by Thomas Klausner
parent ead563777a
commit e2433600e4
7 changed files with 235 additions and 0 deletions

10
newt/DESCR Normal file
View file

@ -0,0 +1,10 @@
Newt is a windowing toolkit for text mode built from the slang
library. It allows color text mode applications to easily use
stackable windows, push buttons, check boxes, radio buttons, lists,
entry fields, labels, and displayable text. Scrollbars are supported,
and forms may be nested to provide extra functionality.
Besides the newt library, this package provides whiptail, which may
be used from shell scripts similarly to Savio Lam's "dialog". Newt
provides the textual interface for the Red Hat and Debian boot
disks.

34
newt/Makefile Normal file
View file

@ -0,0 +1,34 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/02/05 21:42:53 riz Exp $
DISTNAME= ${PKGNAME}-6.src.rpm
PKGNAME= newt-0.51.6
CATEGORIES= devel
MASTER_SITES= http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/
EXTRACT_SUFX= # empty
MAINTAINER= riz@tastylime.net
HOMEPAGE= # empty
COMMENT= Windowing toolkit based on libslang
BUILD_DEPENDS+= rpm2pkg>=2.0:../../pkgtools/rpm2pkg
USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
USE_LIBTOOL= yes
NO_EXPORT_CPP= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PKGNAME}
do-extract:
rpm2pkg -d ${WRKDIR} ${DISTDIR}/${DISTNAME}
cd ${WRKDIR} ; ${GZCAT} ${WRKDIR}/${PKGNAME}.tar.gz | ${TAR} -xf -
do-install:
cd ${WRKSRC}; \
${LIBTOOL} --mode=install ${INSTALL_PROGRAM} libnewt.la ${PREFIX}/lib;\
${INSTALL_DATA} newt.h ${PREFIX}/include; \
${INSTALL_PROGRAM} .libs/whiptail ${PREFIX}/bin
.include "../../devel/libslang/buildlink3.mk"
.include "../../devel/popt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

4
newt/PLIST Normal file
View file

@ -0,0 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/02/05 21:42:53 riz Exp $
include/newt.h
lib/libnewt.la
bin/whiptail

3
newt/TODO Normal file
View file

@ -0,0 +1,3 @@
- Add Python and TCL support options
- deal a bit better with libtool - shouldn't have to install whiptail from
${WRKSRC}/.libs

20
newt/buildlink3.mk Normal file
View file

@ -0,0 +1,20 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2005/02/05 21:42:52 riz Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
NEWT_BUILDLINK3_MK:= ${NEWT_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= newt
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nnewt}
BUILDLINK_PACKAGES+= newt
.if !empty(NEWT_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.newt+= newt>=0.51.6
BUILDLINK_PKGSRCDIR.newt?= ../../wip/newt
.endif # NEWT_BUILDLINK3_MK
.include "../../devel/libslang/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

5
newt/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2005/02/05 21:42:52 riz Exp $
SHA1 (newt-0.51.6-6.src.rpm) = 0f7a8a1ed58bd11dda95ba1cfb5b485508a80b91
Size (newt-0.51.6-6.src.rpm) = 174803 bytes
SHA1 (patch-aa) = 9a35c2e114d3f3d726f86b3432cae21d9668ba6b

159
newt/patches/patch-aa Normal file
View file

@ -0,0 +1,159 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/02/05 21:42:53 riz Exp $
--- Makefile.in.orig 2003-11-05 22:56:47.000000000 -0800
+++ Makefile.in 2005-02-05 11:06:33.000000000 -0800
@@ -1,18 +1,16 @@
-LIBS = -lslang -lm #-lefence
-SHLIBS = -lslang -lm -lc
+LIBS = libnewt.la -lslang -lm -lpopt #-lefence
+SHLIBS = -lslang -lm -lc -lpopt
GPM_SUPPORT=@gpm_support@
-CFLAGS = $(RPM_OPT_FLAGS) -Wall -I/usr/include/slang -D_GNU_SOURCE
-ifeq ($(RPM_OPT_FLAGS),)
-CFLAGS += -g
-endif
+CFLAGS += -I${PREFIX}/include
+#LDFLAGS += -L${PREFIX}/lib -R${PREFIX}/lib
VERSION = @VERSION@
CVSTAG = r$(subst .,-,$(VERSION))
SONAME = @SONAME@
-PYTHONVERS = $(shell ls /usr/include/python*/Python.h | sed "s|/usr/include/||g"| sed "s|/Python.h||g")
+#PYTHONVERS = $(shell ls /usr/include/python*/Python.h | sed "s|/usr/include/||g"| sed "s|/Python.h||g")
WHIPTCLSO=
#WHIPTCLSO=whiptcl.so
@@ -21,16 +19,16 @@
TESTOBJS = test.o
NDIALOGOBJS = whiptail.o dialogboxes.o
WHIPTCLOBJS = whiptcl.o dialogboxes.o
-LIBNEWT = libnewt.a
+LIBNEWT = libnewt.la
LIBNEWTSH = libnewt.so.$(VERSION)
LIBNEWTSONAME = libnewt.so.$(SONAME)
-LIBOBJS = newt.o button.o form.o checkbox.o entry.o label.o listbox.o \
+LIBOBJS = button.o form.o checkbox.o entry.o label.o listbox.o \
scrollbar.o textbox.o scale.o grid.o windows.o buttonbar.o \
checkboxtree.o
-SHCFLAGS = -fPIC
+#SHCFLAGS = ${CFLAGS} -fPIC
-prefix = /usr
+prefix = ${PREFIX}
includedir = $(prefix)/include
libdir = $(prefix)/lib
bindir = $(prefix)/bin
@@ -38,6 +36,7 @@
#--------------------------------------
+LIBSOURCES = $(subst .o,.c,$(LIBOBJS))
SOURCES = $(subst .o,.c,$(TESTOBJS) $(NDIALOGOBJS) $(LIBOBJS))
SHAREDDIR = shared
@@ -49,43 +48,49 @@
TARGET=depend $(PROGS)
endif
-all: $(TARGET) _snackmodule.so
+all: $(TARGET)
+#all: $(TARGET) _snackmodule.so
test: $(TESTOBJS) $(LIBNEWT)
- gcc -g -o test $(TESTOBJS) $(LIBNEWT) $(LIBS) -static
+ ${LIBTOOL} --mode=link ${CC} -g -o test $(TESTOBJS) $(LIBS) -static
testgrid: testgrid.o $(LIBNEWT)
- gcc -g -o testgrid testgrid.o $(LIBNEWT) $(LIBS)
+ ${LIBTOOL} --mode=link ${CC} -g -o testgrid testgrid.o $(LIBS)
testtree: testtree.o $(LIBNEWT)
- gcc -g -o testtree testtree.o $(LIBNEWT) $(LIBS)
+ ${LIBTOOL} --mode=link ${CC} -g -o testtree testtree.o $(LIBS)
showchars: showchars.o $(LIBNEWT)
- gcc -g -o showchars showchars.o $(LIBNEWT) $(LIBS)
+ ${LIBTOOL} --mode=link ${CC} -g -o showchars showchars.o $(LIBS)
showkey: showkey.o $(LIBNEWT)
- gcc -g -o showkey showkey.o $(LIBNEWT) $(LIBS)
+ ${LIBTOOL} --mode=link ${CC} -g -o showkey showkey.o $(LIBS)
_snackmodule.so: snackmodule.c $(LIBNEWTSH)
for ver in $(PYTHONVERS) ; do \
if [ ! -f "$$ver/_snackmodule.so" -o $(LIBNEWTSH) -nt "$$ver/_snackmodule.so" ]; then \
mkdir -p $$ver ;\
- gcc $(CFLAGS) -I/usr/include/$$ver -fPIC -c -o $$ver/snackmodule.o snackmodule.c ;\
- gcc --shared $(SHCFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L . $(LIBNEWTSH) ;\
+ ${CC} $(CFLAGS) -I/usr/include/$$ver -fPIC -c -o $$ver/snackmodule.o snackmodule.c ;\
+ ${CC} --shared $(SHCFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L . $(LIBNEWTSH) ;\
fi ; \
done
-whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
- gcc -g -o whiptail $(NDIALOGOBJS) -L . $(LIBNEWTSH) $(LIBS) -lpopt
-
-whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
- gcc -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . $(LIBNEWTSH) -ltcl -lslang -lpopt -lm
+whiptail: $(NDIALOGOBJS) $(LIBNEWT)
+ ${LIBTOOL} --mode=link ${CC} -g -o whiptail $(NDIALOGOBJS) $(LIBS)
-$(LIBNEWT): $(LIBOBJS)
- ar rv $@ $^
+whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWT)
+ ${LIBTOOL} --mode=link ${CC} -shared $(SHCFLAGS) -o whiptcl.so \
+ $(WHIPTCLOBJS) -ltcl ${LIBS}
+
+$(LIBNEWT): $(LIBOBJS) newt.o
+ ${LIBTOOL} --mode=link ${CC} -o ${LIBNEWT} ${LIBOBJS:.o=.lo} \
+ newt.lo -rpath ${PREFIX}/lib -version-number 0:51:6
newt.o: newt.c Makefile
- $(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<
+ ${LIBTOOL} --mode=compile $(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<
+
+%.o: %.c
+ ${LIBTOOL} --mode=compile ${CC} ${CFLAGS} -c -o $@ $<
veryclean: clean
rm -f .depend
@@ -97,19 +102,19 @@
depend:
$(CPP) $(CFLAGS) -M $(SOURCES) > .depend
-$(SHAREDDIR):
- mkdir -p $(SHAREDDIR)
+#$(SHAREDDIR):
+# mkdir -p $(SHAREDDIR)
-sharedlib: $(LIBNEWTSH)
+#sharedlib: $(LIBNEWTSH)
-$(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
- gcc -shared -o $(LIBNEWTSH) -Wl,-soname,$(LIBNEWTSONAME) $(SHAREDOBJS) $(SHLIBS)
+#$(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
+# ${CC} -shared -o $(LIBNEWTSH) -Wl,-soname,$(LIBNEWTSONAME) $(SHAREDOBJS) $(SHLIBS)
-$(SHAREDDIR)/%.o : %.c
- $(CC) $(SHCFLAGS) -c $(CFLAGS) -o $@ $<
+#$(SHAREDDIR)/%.o : %.c
+# $(CC) $(SHCFLAGS) -c $(CFLAGS) -o $@ $<
-$(SHAREDDIR)/newt.o: newt.c Makefile
- $(CC) $(SHCFLAGS) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<
+#$(SHAREDDIR)/newt.o: newt.c Makefile
+# $(CC) $(SHCFLAGS) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<
install: $(LIBNEWT) install-sh whiptail
@@ -147,7 +152,3 @@
@rm -f /tmp/newt-$(VERSION).tar.gz
@echo " "
@echo "The final archive is ./newt-$(VERSION).tar.gz."
-
-ifeq (.depend,$(wildcard .depend))
-include .depend
-endif