initial import of DSPAM.

DSPAM (as in De-Spam) is an extremely scalable, open-source
statistical-algorithmic hybrid anti-spam filter.
A majority of users running v2.10+ achieve filtering rates ranging
from 99.92% - 99.98+%, DSPAM is currently effective as both a
server-side agent for UNIX email servers and a developer's library
for mail clients, other anti-spam tools, and similar projects requiring
drop-in spam filtering. DSPAM has been implemented on many large and
small scale systems with the largest systems being reported at about
125,000 mailboxes.

WWW: http://www.nuclearelephant.com/projects/dspam/
This commit is contained in:
tom hensel 2004-03-13 16:11:15 +00:00 committed by Thomas Klausner
parent da96b339e1
commit e3201f8c16
7 changed files with 205 additions and 0 deletions

11
dspam/DESCR Normal file
View file

@ -0,0 +1,11 @@
DSPAM (as in De-Spam) is an extremely scalable, open-source
statistical-algorithmic hybrid anti-spam filter.
A majority of users running v2.10+ achieve filtering rates ranging
from 99.92% - 99.98+%, DSPAM is currently effective as both a
server-side agent for UNIX email servers and a developer's library
for mail clients, other anti-spam tools, and similar projects requiring
drop-in spam filtering. DSPAM has been implemented on many large and
small scale systems with the largest systems being reported at about
125,000 mailboxes.
WWW: http://www.nuclearelephant.com/projects/dspam/

30
dspam/MESSAGE Normal file
View file

@ -0,0 +1,30 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2004/03/13 16:11:15 tomhensel Exp $
See the file ${DOCSDIR}/README
on how to setup DSPAM and configure your MTA.
Examples are provided for sendmail, exim and other popular MTAs.
Integrating DSPAM with Postfix is described at
http://www.phpinsider.com/dspam/
${EXAMPLESDIR}/mysql.data
contains an example configuration for use with MySQL.
Edit and install as
${LOCALBASE}/etc/dspam/mysql.data
${EXAMPLESDIR}/mysql_objects.sql
contains a dump of MySQL table structures used by DSPAM,
import it into your database.
Please note the lack of manpages in the current release of DSPAM.
A FAQ is available at
http://www.nuclearelephant.com/projects/dspam/faq.html
For more information on the optional Chi Square algorithm see
http://radio.weblogs.com/0101454/stories/2002/09/16/spamDetection.html
===========================================================================

111
dspam/Makefile Normal file
View file

@ -0,0 +1,111 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/03/13 16:11:15 tomhensel Exp $
# FreeBSD Id: ports/mail/dspam/Makefile,v 1.9 2004/01/31 22:51:09 sergei Exp
DISTNAME= dspam-${_DSPAM_VER}
CATEGORIES= mail
MASTER_SITES= http://www.nuclearelephant.com/projects/dspam/sources/
MAINTAINER= tom@replic8.net
HOMEPAGE= http://www.nuclearelephant.com/projects/dspam/
COMMENT= Scalable statistical-algorithmic hybrid anti-spam filter
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_BUILDLINK3= yes
USE_PKGINSTALL= yes
CONFIGURE_ARGS= --with-userdir=${PREFIX}/etc/dspam
DOCS= CHANGE README RELEASE.NOTES LICENSE
DOCSDIR= ${PREFIX}/share/doc/dspam
EXAMPLESDIR= ${PREFIX}/share/examples/dspam
PLIST_SUBST+= DOCSDIR=${DOCSDIR:S/${PREFIX}\///} \
EXAMPLESDIR=${EXAMPLESDIR:S/${PREFIX}\///}
MESSAGE_SUBST+= DOCSDIR=${DOCSDIR} \
EXAMPLESDIR=${EXAMPLESDIR}
_DSPAM_VER= 2.8.3
BUILD_DEFS+= USE_MYSQL \
DSPAM_USE_MAILDROP DSPAM_USE_PROCMAIL DSPAM_USE_MAILLOCAL \
DSPAM_CHI_SQUARE \
DSPAM_USE_SGID \
DSPAM_SPAM_DELIVERY \
DSPAM_SOURCE_ADDRESS_TRACKING \
DSPAM_SIGNATURE_ATTACHMENTS \
DSPAM_HOMEDIR_DOTFILES
DSPAM_USE_PROCMAIL?= YES
.if defined(USE_MYSQL)
.include "../../databases/mysql-client/buildlink3.mk"
CONFIGURE_ARGS+= --with-storage-driver=mysql_drv \
--with-mysql-includes=${PREFIX}/include/mysql \
--with-mysql-libraries=${PREFIX}/lib/mysql
MESSAGE_SUBST+= MYSQL=""
PLIST_SUBST+= DB4="@comment "
PLIST_SUBST+= MYSQL=""
.else
.include "../../databases/db4/buildlink3.mk"
DEPENDS= db4>=4.2:../../databases/db4
CONFIGURE_ARGS+= --with-db4-includes=${PREFIX}/include/db4
PLIST_SUBST+= DB4=""
PLIST_SUBST+= MYSQL="@comment "
MESSAGE_SUBST+= MYSQL="@comment "
.endif
.if defined(DSPAM_USE_PROCMAIL)
RUN_DEPENDS= procmail>=3.22:../../mail/procmail
CONFIGURE_ARGS+= --with-local-delivery-agent='${PREFIX}/bin/procmail $u'
DSPAM_USE_SGID?= YES
.elif defined(DSPAM_USE_MAILDROP)
RUN_DEPENDS= maildrop>=1.3.9:../../mail/maildrop
CONFIGURE_ARGS+= --with-local-delivery-agent='${PREFIX}/bin/maildrop $u'
DSPAM_USE_SGID?= YES
.elif defined(DSPAM_USE_MAILLOCAL)
CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/libexec/mail.local $u'
.else
CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/libexec/mail.local $u'
CONFIGURE_ARGS+= --enable-delivery-to-stdout
DSPAM_SPAM_DELIVERY?= YES
.endif
.if defined(DSPAM_USE_SGID)
CONFIGURE_ARGS+= --with-dspam-mode=2511
.endif
.if defined(DSPAM_SPAM_DELIVERY)
CONFIGURE_ARGS+= --enable-spam-delivery
.endif
.if defined(DSPAM_CHI_SQUARE)
CONFIGURE_ARGS+= --enable-chi-square
.endif
.if defined(DSPAM_SIGNATURE_ATTACHMENTS)
CONFIGURE_ARGS+= --enable-signature-attachments
.endif
.if defined(DSPAM_HOMEDIR_DOTFILES)
CONFIGURE_ARGS+= --enable-homedir-dotfiles
CONFIGURE_ARGS+= --enable-opt-in
.endif
.if defined(DSPAM_SOURCE_ADDRESS_TRACKING)
CONFIGURE_ARGS+= --enable-source-address-tracking
.endif
post-install:
.if defined(USE_MYSQL)
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/tools.mysql_drv && \
${INSTALL_DATA} README *.sql ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/mysql.data ${EXAMPLESDIR}
.endif
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.include "../../mk/bsd.pkg.mk"

29
dspam/PLIST Normal file
View file

@ -0,0 +1,29 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/03/13 16:11:15 tomhensel Exp $
bin/dspam
bin/dspam_2mysql
bin/dspam_dump
bin/dspam_clean
bin/dspam_corpus
bin/dspam_crc
bin/dspam_genaliases
bin/dspam_merge
bin/dspam_ngstats
${DB4}bin/dspam_purge
${DB4}bin/dspam_purge.libdb4
bin/dspam_stats
${DB4}bin/libdb4_purge
lib/libdspam.so
lib/libdspam.so.4
lib/libdspam.a
${DOCSDIR}/README
${DOCSDIR}/CHANGE
${DOCSDIR}/RELEASE.NOTES
${DOCSDIR}/LICENSE
@dirrm ${DOCSDIR}
${MYSQL}${EXAMPLESDIR}/README
${MYSQL}${EXAMPLESDIR}/mysql.data
${MYSQL}${EXAMPLESDIR}/mysql_objects.sql
${MYSQL}${EXAMPLESDIR}/purge.sql
${MYSQL}${EXAMPLESDIR}/virtual_users.sql
${MYSQL}@dirrm ${EXAMPLESDIR}
@dirrm etc/dspam

5
dspam/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/03/13 16:11:15 tomhensel Exp $
SHA1 (dspam-2.8.3.tar.gz) = 4613fdf717f62dc21e561a5505568f3ebafd0f1c
Size (dspam-2.8.3.tar.gz) = 462004 bytes
SHA1 (patch-aa) = a63c3ee56ece496a05a10c88cd695887b2f5529e

5
dspam/files/mysql.data Normal file
View file

@ -0,0 +1,5 @@
/tmp/mysql.sock
user
password
database

14
dspam/patches/patch-aa Normal file
View file

@ -0,0 +1,14 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/03/13 16:11:15 tomhensel Exp $
--- configure.orig Wed Nov 26 14:35:34 2003
+++ configure Thu Dec 11 14:00:18 2003
@@ -7548,7 +7548,8 @@
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+LIBTOOL_DEPS="%%LIBTOOLFLAGS%% $ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'