bird 1.3.11 modeled after the 1.3.6 in pkgsrc/net
This commit is contained in:
parent
693b2e312a
commit
e8ce057a08
10 changed files with 177 additions and 0 deletions
14
bird/DESCR
Normal file
14
bird/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
The BIRD project aims to develop a fully functional dynamic IP routing daemon
|
||||||
|
primarily targetted on (but not limited to) UNIX-like systems and distributed
|
||||||
|
under the GNU General Public License.
|
||||||
|
|
||||||
|
+ The bird package is for IPv4, bird6 for IPv6
|
||||||
|
+ Multiple routing tables
|
||||||
|
+ BGP
|
||||||
|
+ RIP
|
||||||
|
+ OSPF
|
||||||
|
+ Static routes
|
||||||
|
+ Inter-table protocol
|
||||||
|
+ Command-line interface
|
||||||
|
+ Soft reconfiguration
|
||||||
|
+ Powerful language for route filtering
|
3
bird/Makefile
Normal file
3
bird/Makefile
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
# $NetBSD: Makefile,v 1.12 2013/11/14 14:01:10 kralian Exp $
|
||||||
|
|
||||||
|
.include "../../wip/bird/Makefile.common"
|
38
bird/Makefile.common
Normal file
38
bird/Makefile.common
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
# $NetBSD: Makefile.common,v 1.8 2013/11/14 14:01:10 kralian Exp $
|
||||||
|
# used by wip/bird/Makefile
|
||||||
|
# used by wip/bird6/Makefile
|
||||||
|
|
||||||
|
DISTNAME= bird-1.3.11
|
||||||
|
PKGNAME= ${DISTNAME:S/bird/bird${BIRD6}/}
|
||||||
|
CATEGORIES= net
|
||||||
|
MASTER_SITES= ftp://bird.network.cz/pub/bird/
|
||||||
|
|
||||||
|
MAINTAINER= amd@pd-house.dk
|
||||||
|
HOMEPAGE= http://bird.network.cz/
|
||||||
|
COMMENT= The BIRD Internet Routing Daemon
|
||||||
|
LICENSE= gnu-gpl-v2
|
||||||
|
|
||||||
|
USE_LIBTOOL= yes
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
USE_TOOLS+= gmake flex bison
|
||||||
|
|
||||||
|
CONFIGURE_ARGS+= --localstatedir=/var
|
||||||
|
BIRD6?= # empty
|
||||||
|
PLIST_SUBST+= BIRD6=${BIRD6}
|
||||||
|
|
||||||
|
FILESDIR= ${.CURDIR}/../bird/files
|
||||||
|
PATCHDIR= ${.CURDIR}/../bird/patches
|
||||||
|
DISTINFO_FILE= ${.CURDIR}/../bird/distinfo
|
||||||
|
PLIST_SRC= ${.CURDIR}/../bird/PLIST
|
||||||
|
DESCR_SRC= ${.CURDIR}/../bird/DESCR
|
||||||
|
|
||||||
|
RCD_SCRIPTS+= bird${BIRD6}
|
||||||
|
|
||||||
|
EGDIR= ${PREFIX}/share/examples/bird${BIRD6}
|
||||||
|
ALL_ENV+= EGDIR=${EGDIR}
|
||||||
|
CONF_FILES= ${EGDIR}/bird${BIRD6}.conf ${PKG_SYSCONFDIR}/bird${BIRD6}.conf
|
||||||
|
|
||||||
|
.include "../../devel/readline/buildlink3.mk"
|
||||||
|
.include "../../devel/ncurses/buildlink3.mk"
|
||||||
|
|
||||||
|
.include "../../mk/bsd.pkg.mk"
|
6
bird/PLIST
Normal file
6
bird/PLIST
Normal file
|
@ -0,0 +1,6 @@
|
||||||
|
@comment $NetBSD: PLIST,v 1.4 2013/11/14 14:01:10 kralian Exp $
|
||||||
|
sbin/bird${BIRD6}
|
||||||
|
sbin/birdc${BIRD6}
|
||||||
|
sbin/birdcl${BIRD6}
|
||||||
|
share/examples/bird${BIRD6}/bird${BIRD6}.conf
|
||||||
|
share/examples/rc.d/bird${BIRD6}
|
8
bird/distinfo
Normal file
8
bird/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
$NetBSD: distinfo,v 1.12 2013/11/14 14:01:10 kralian Exp $
|
||||||
|
|
||||||
|
SHA1 (bird-1.3.11.tar.gz) = c0a425ff2ef85bbeb17dbdf82c97c4565ebfb903
|
||||||
|
RMD160 (bird-1.3.11.tar.gz) = f62213b07941cac4e441e8211a37b0a32fd4601b
|
||||||
|
Size (bird-1.3.11.tar.gz) = 1108400 bytes
|
||||||
|
SHA1 (patch-configure) = ea93a7e90caa274632159172deb53eff9739cb4b
|
||||||
|
SHA1 (patch-lib_lists.h) = c5af1e31b3cbeb39c30f5732ff7eef5ed2f77869
|
||||||
|
SHA1 (patch-tools_Makefile.in) = 4ce6eab482f60aa4ac3a803c871e5ac20be37710
|
18
bird/files/bird.sh
Normal file
18
bird/files/bird.sh
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
#!@RCD_SCRIPTS_SHELL@
|
||||||
|
#
|
||||||
|
# $NetBSD: bird.sh,v 1.3 2013/11/14 14:01:10 kralian Exp $
|
||||||
|
#
|
||||||
|
# PROVIDE: bird
|
||||||
|
# REQUIRE: DAEMON NETWORKING
|
||||||
|
|
||||||
|
if [ -f /etc/rc.subr ]
|
||||||
|
then
|
||||||
|
. /etc/rc.subr
|
||||||
|
fi
|
||||||
|
|
||||||
|
name="bird"
|
||||||
|
rcvar="${name}"
|
||||||
|
command="@PREFIX@/sbin/${name}"
|
||||||
|
|
||||||
|
load_rc_config $name
|
||||||
|
run_rc_command "$1"
|
18
bird/files/bird6.sh
Normal file
18
bird/files/bird6.sh
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
#!@RCD_SCRIPTS_SHELL@
|
||||||
|
#
|
||||||
|
# $NetBSD: bird6.sh,v 1.3 2013/11/14 14:01:10 kralian Exp $
|
||||||
|
#
|
||||||
|
# PROVIDE: bird6
|
||||||
|
# REQUIRE: DAEMON NETWORKING
|
||||||
|
|
||||||
|
if [ -f /etc/rc.subr ]
|
||||||
|
then
|
||||||
|
. /etc/rc.subr
|
||||||
|
fi
|
||||||
|
|
||||||
|
name="bird6"
|
||||||
|
rcvar="${name}"
|
||||||
|
command="@PREFIX@/sbin/${name}"
|
||||||
|
|
||||||
|
load_rc_config $name
|
||||||
|
run_rc_command "$1"
|
17
bird/patches/patch-configure
Normal file
17
bird/patches/patch-configure
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
$NetBSD: patch-configure,v 1.1 2013/11/14 14:01:10 kralian Exp $
|
||||||
|
|
||||||
|
--- configure.orig 2013-07-28 18:57:59.000000000 +0000
|
||||||
|
+++ configure
|
||||||
|
@@ -4442,12 +4442,8 @@ else
|
||||||
|
default_iproutedir="/etc/iproute2"
|
||||||
|
;;
|
||||||
|
ipv6:netbsd*) sysdesc=bsd-v6
|
||||||
|
- CPPFLAGS="$CPPFLAGS -I/usr/pkg/include"
|
||||||
|
- LDFLAGS="$LDFLAGS -L/usr/pkg/lib -R/usr/pkg/lib"
|
||||||
|
;;
|
||||||
|
ipv4:netbsd*) sysdesc=bsd
|
||||||
|
- CPPFLAGS="$CPPFLAGS -I/usr/pkg/include"
|
||||||
|
- LDFLAGS="$LDFLAGS -L/usr/pkg/lib -R/usr/pkg/lib"
|
||||||
|
;;
|
||||||
|
ipv6:freebsd*) sysdesc=bsd-v6
|
||||||
|
;;
|
31
bird/patches/patch-lib_lists.h
Normal file
31
bird/patches/patch-lib_lists.h
Normal file
|
@ -0,0 +1,31 @@
|
||||||
|
$NetBSD: patch-lib_lists.h,v 1.1 2013/11/14 14:01:11 kralian Exp $
|
||||||
|
|
||||||
|
--- lib/lists.h.orig 2012-08-07 09:15:40.000000000 +0000
|
||||||
|
+++ lib/lists.h
|
||||||
|
@@ -48,19 +48,19 @@ typedef struct list { /* In fact two o
|
||||||
|
|
||||||
|
#define EMPTY_LIST(list) (!(list).head->next)
|
||||||
|
|
||||||
|
+#ifndef _BIRD_LISTS_C_
|
||||||
|
+#define LIST_INLINE static inline
|
||||||
|
+#include "lib/lists.c"
|
||||||
|
+#undef LIST_INLINE
|
||||||
|
+#else
|
||||||
|
+#define LIST_INLINE
|
||||||
|
+
|
||||||
|
void add_tail(list *, node *);
|
||||||
|
void add_head(list *, node *);
|
||||||
|
void rem_node(node *);
|
||||||
|
void add_tail_list(list *, list *);
|
||||||
|
void init_list(list *);
|
||||||
|
void insert_node(node *, node *);
|
||||||
|
-
|
||||||
|
-#ifndef _BIRD_LISTS_C_
|
||||||
|
-#define LIST_INLINE extern inline
|
||||||
|
-#include "lib/lists.c"
|
||||||
|
-#undef LIST_INLINE
|
||||||
|
-#else
|
||||||
|
-#define LIST_INLINE
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#endif
|
24
bird/patches/patch-tools_Makefile.in
Normal file
24
bird/patches/patch-tools_Makefile.in
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
$NetBSD: patch-tools_Makefile.in,v 1.3 2013/11/14 14:01:11 kralian Exp $
|
||||||
|
|
||||||
|
--- tools/Makefile.in.orig 2013-04-29 21:41:58.000000000 +0000
|
||||||
|
+++ tools/Makefile.in
|
||||||
|
@@ -68,17 +68,13 @@ tags:
|
||||||
|
cd $(srcdir) ; etags -lc `find $(static-dirs) $(addprefix $(objdir)/,$(dynamic-dirs)) $(client-dirs) -name *.[chY]`
|
||||||
|
|
||||||
|
install: all
|
||||||
|
- $(INSTALL) -d $(DESTDIR)/$(sbindir) $(DESTDIR)/$(sysconfdir) $(DESTDIR)/@runtimedir@
|
||||||
|
+ $(INSTALL) -d $(DESTDIR)/$(sbindir) $(DESTDIR)/$(EGDIR) $(DESTDIR)/@runtimedir@
|
||||||
|
$(INSTALL_PROGRAM) -s $(exedir)/bird $(DESTDIR)/$(sbindir)/bird@SUFFIX@
|
||||||
|
$(INSTALL_PROGRAM) -s $(exedir)/birdcl $(DESTDIR)/$(sbindir)/birdcl@SUFFIX@
|
||||||
|
if test -n "@CLIENT@" ; then \
|
||||||
|
$(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX@ ; \
|
||||||
|
fi
|
||||||
|
- if ! test -f $(DESTDIR)/@CONFIG_FILE@ ; then \
|
||||||
|
- $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/@CONFIG_FILE@ ; \
|
||||||
|
- else \
|
||||||
|
- echo "Not overwriting old bird@SUFFIX@.conf" ; \
|
||||||
|
- fi
|
||||||
|
+ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(EGDIR)/bird@SUFFIX@.conf
|
||||||
|
|
||||||
|
install-docs:
|
||||||
|
$(INSTALL) -d $(DESTDIR)/$(docdir)
|
Loading…
Reference in a new issue