Changes 2.0.3: Bug-fix release

This commit is contained in:
Adam Ciarciński 2004-06-14 14:04:03 +00:00 committed by Thomas Klausner
parent 3b6df4f2d9
commit eb192f2630
5 changed files with 37 additions and 11 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.9 2004/05/09 02:39:01 minskim Exp $
#
# $NetBSD: Makefile,v 1.10 2004/06/14 14:04:03 moubctez Exp $
DISTNAME= gg2-2.0.2
DISTNAME= gg2-2.0.3
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ggadu/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.6 2004/05/04 09:36:10 moubctez Exp $
@comment $NetBSD: PLIST,v 1.7 2004/06/14 14:04:03 moubctez Exp $
bin/gg2
include/gg2_core.h
lib/gg2/libGUI_plugin.a
@ -293,6 +293,7 @@ share/gg2/themes/vblue2.theme
share/gg2/themes/vgreen2.theme
share/gg2/themes/vred2.theme
share/gg2/themes/white2.theme
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/gg2.mo
${PKGLOCALEDIR}/locale/pl/LC_MESSAGES/gg2.mo
share/pixmaps/gg2.png
@dirrm share/gg2/themes

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.7 2004/05/04 09:36:10 moubctez Exp $
$NetBSD: distinfo,v 1.8 2004/06/14 14:04:03 moubctez Exp $
SHA1 (gg2-2.0.2.tar.bz2) = 7073da1a2c84460ecdae71f362db4fa812f014e6
Size (gg2-2.0.2.tar.bz2) = 1158392 bytes
SHA1 (patch-aa) = 2f9bec564e11563fd2331795ec22174a2349f814
SHA1 (gg2-2.0.3.tar.bz2) = 4804f97cbfb62111d29dd9f8dfda2579fcfab70c
Size (gg2-2.0.3.tar.bz2) = 1182315 bytes
SHA1 (patch-aa) = 8c053760b3e178548bb36dbaf472e8618fc02307
SHA1 (patch-ab) = 5d3cb86625da7cc1da7a3daa3df384308f54965c

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.4 2004/05/04 09:36:11 moubctez Exp $
$NetBSD: patch-aa,v 1.5 2004/06/14 14:04:03 moubctez Exp $
--- lib/Makefile.in.orig 2004-05-03 21:42:08.000000000 +0000
--- lib/Makefile.in.orig 2004-06-12 07:19:21.000000000 +0000
+++ lib/Makefile.in
@@ -306,7 +306,7 @@ libgg2_core_la_SOURCES = unified-types.c
@@ -310,7 +310,7 @@ libgg2_core_la_SOURCES = \
perl_embed.h
libgg2_core_la_HEADERS = gg2_core.h

26
gg2/patches/patch-ab Normal file
View file

@ -0,0 +1,26 @@
$NetBSD: patch-ab,v 1.3 2004/06/14 14:04:04 moubctez Exp $
--- src/main.c.orig 2004-03-29 07:03:22.000000000 +0000
+++ src/main.c
@@ -43,6 +43,12 @@
#include "ggadu_repo.h"
#include "perl_embed.h"
+#ifdef __Darwin__
+#define DYLIB_SUFX ".dylib"
+#else
+#define DYLIB_SUFX ".so"
+#endif
+
GGaduConfig *config;
gboolean gnu_gadu_init(gpointer data);
@@ -80,7 +86,7 @@ void load_available_modules()
{
gchar *fullfilename = g_build_filename(dirpath, namepl, NULL);
- if ((!g_file_test(fullfilename, G_FILE_TEST_IS_DIR)) && (str_has_suffix(namepl, ".so")))
+ if ((!g_file_test(fullfilename, G_FILE_TEST_IS_DIR)) && (str_has_suffix(namepl, DYLIB_SUFX)))
{
print_debug("core : load_avilable_modules : %s\n", namepl);