Snapshot 2015018. Adjust gcc_config_netbsd.c to upstream changes.

This commit is contained in:
Kai-Uwe Eckhardt 2015-01-21 14:58:48 +00:00 committed by Thomas Klausner
parent 2f95caa245
commit eb68f888fd
4 changed files with 65 additions and 57 deletions

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.12 2015/01/15 06:09:09 keckhardt Exp $
$NetBSD: distinfo,v 1.13 2015/01/21 14:58:48 keckhardt Exp $
SHA1 (ecj-4.5.jar) = 58c1d79c64c8cd718550f32a932ccfde8d1e6449
RMD160 (ecj-4.5.jar) = d3f4da657f086b6423f74e93f001132f4855368a
Size (ecj-4.5.jar) = 1470676 bytes
SHA1 (gcc-5-20150104.tar.bz2) = 3b524e6f54c98d90f041f32fa269b8b925fee0c6
RMD160 (gcc-5-20150104.tar.bz2) = 6ff7bad2960aa449e5f346ca1d37a6e57de446c1
Size (gcc-5-20150104.tar.bz2) = 88981849 bytes
SHA1 (gcc-5-20150118.tar.bz2) = fc55f0296f7977d7a86a539c2584b7c316583a15
RMD160 (gcc-5-20150118.tar.bz2) = cfa2bd7ec9711f2b2e0044ae1dcff1537a55ae10
Size (gcc-5-20150118.tar.bz2) = 89820990 bytes
SHA1 (isl-0.14.tar.bz2) = b09e25df265c97ed54002cd811d227a9a26c5f9c
RMD160 (isl-0.14.tar.bz2) = 4c69d026b51561bc1948cb7db79331b78a9d2c39
Size (isl-0.14.tar.bz2) = 1399896 bytes
@ -13,7 +13,7 @@ SHA1 (patch-gcc_Makefile.in) = ce366a091960d335ecb022918e2f7bfc4e3fcccf
SHA1 (patch-gcc_config.gcc) = bfa3897de6afa573ee44a60973611c4e9024f497
SHA1 (patch-gcc_config_netbsd-protos.h) = 6d28864b4ccc8c1a63fe28e43601b84b63a00633
SHA1 (patch-gcc_config_netbsd-stdint.h) = 025fc883101a187e84ed4c0772406720d645d550
SHA1 (patch-gcc_config_netbsd.c) = 07ccccd1fdaf9f3ab1f248ff72b671a7f7492404
SHA1 (patch-gcc_config_netbsd.c) = 9d1327f926dece6e753093e759b5c8b707747ae1
SHA1 (patch-gcc_config_netbsd.h) = b722614a3822e9800a2a8f65a87e56927d05a1b1
SHA1 (patch-gcc_config_t-netbsd) = 802ad5706aa7ca9629f8e237f08fbb1569d28846
SHA1 (patch-gcc_config_x-netbsd) = 6dc3d78e26df62054ea29f98ca51592858e671e3

View file

@ -1,8 +1,8 @@
$NetBSD: patch-gcc_config_netbsd.c,v 1.1 2014/12/17 21:51:02 keckhardt Exp $
$NetBSD: patch-gcc_config_netbsd.c,v 1.2 2015/01/21 14:58:48 keckhardt Exp $
--- /dev/null 2014-12-17 06:10:54.000000000 +0000
--- /dev/null 2015-01-20 20:33:39.000000000 +0000
+++ gcc/config/netbsd.c
@@ -0,0 +1,106 @@
@@ -0,0 +1,122 @@
+/* Functions for generic NetBSD as target machine for GNU C compiler.
+ Copyright (C) 1989-2014 Free Software Foundation, Inc.
+ Contributed by Apple Computer Inc.
@ -23,6 +23,7 @@ $NetBSD: patch-gcc_config_netbsd.c,v 1.1 2014/12/17 21:51:02 keckhardt Exp $
+along with GCC; see the file COPYING3. If not see
+<http://www.gnu.org/licenses/>. */
+
+
+#include "config.h"
+#include "system.h"
+#include "coretypes.h"
@ -36,18 +37,33 @@ $NetBSD: patch-gcc_config_netbsd.c,v 1.1 2014/12/17 21:51:02 keckhardt Exp $
+#include "output.h"
+#include "insn-attr.h"
+#include "flags.h"
+#include "hash-set.h"
+#include "machmode.h"
+#include "vec.h"
+#include "double-int.h"
+#include "input.h"
+#include "alias.h"
+#include "symtab.h"
+#include "wide-int.h"
+#include "inchash.h"
+#include "tree.h"
+#include "fold-const.h"
+#include "stringpool.h"
+#include "varasm.h"
+#include "stor-layout.h"
+#include "hashtab.h"
+#include "function.h"
+#include "statistics.h"
+#include "real.h"
+#include "fixed-value.h"
+#include "expmed.h"
+#include "dojump.h"
+#include "explow.h"
+#include "calls.h"
+#include "emit-rtl.h"
+#include "stmt.h"
+#include "expr.h"
+#include "reload.h"
+#include "hashtab.h"
+#include "hash-set.h"
+#include "vec.h"
+#include "machmode.h"
+#include "input.h"
+#include "function.h"
+#include "ggc.h"
+#include "langhooks.h"
+#include "target.h"

View file

@ -1,7 +1,7 @@
cat <<'EOF' |
LAST_UPDATED: Obtained from SVN: trunk revision 219175
LAST_UPDATED: Obtained from SVN: trunk revision 219827
Native configuration is x86_64--netbsd # 7.99.4
Native configuration is x86_64--netbsd
=== g++ tests ===
@ -19,18 +19,15 @@ FAIL: g++.dg/guality/pr55665.C -O3 -g line 23 p == 40
FAIL: g++.old-deja/g++.eh/badalloc1.C -std=c++98 execution test
FAIL: g++.old-deja/g++.eh/badalloc1.C -std=c++11 execution test
FAIL: g++.old-deja/g++.eh/badalloc1.C -std=c++14 execution test
FAIL: g++.old-deja/g++.law/profile1.C -std=gnu++98 (test for excess errors)
FAIL: g++.old-deja/g++.law/profile1.C -std=gnu++11 (test for excess errors)
FAIL: g++.old-deja/g++.law/profile1.C -std=gnu++14 (test for excess errors)
=== g++ Summary ===
# of expected passes 84166
# of unexpected failures 12
# of expected failures 246
# of expected passes 84842
# of unexpected failures 9
# of expected failures 267
# of unresolved testcases 3
# of unsupported tests 3386
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/testsuite/g++/../../xg++ version 5.0.0 20150104 (experimental) (GCC)
# of unsupported tests 3490
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/testsuite/g++/../../xg++ version 5.0.0 20150118 (experimental) (GCC)
=== gcc tests ===
@ -43,7 +40,6 @@ FAIL: gcc.c-torture/execute/20030125-1.c -O3 -g execution test
FAIL: gcc.c-torture/execute/20030125-1.c -Os execution test
FAIL: gcc.c-torture/execute/20030125-1.c -O2 -flto -fno-use-linker-plugin -flto-partition=none execution test
FAIL: gcc.c-torture/execute/20030125-1.c -O2 -flto -fuse-linker-plugin -fno-fat-lto-objects execution test
FAIL: gcc.dg/20021014-1.c (test for excess errors)
FAIL: gcc.dg/binop-xor1.c scan-tree-dump-times optimized "\\\\^" 1
FAIL: gcc.dg/binop-xor3.c scan-tree-dump-times optimized "\\\\^" 1
FAIL: gcc.dg/builtins-20.c (test for excess errors)
@ -58,12 +54,6 @@ FAIL: gcc.dg/builtins-61.c scan-tree-dump optimized "cos"
FAIL: gcc.dg/builtins-61.c scan-tree-dump optimized "return 0.0"
FAIL: gcc.dg/builtins-62.c scan-tree-dump-times optimized "cexpi" 3
FAIL: gcc.dg/builtins-65.c (test for excess errors)
FAIL: gcc.dg/nest.c (test for excess errors)
FAIL: gcc.dg/nested-func-4.c (test for excess errors)
FAIL: gcc.dg/pr32450.c (test for excess errors)
FAIL: gcc.dg/pr43643.c (test for excess errors)
FAIL: gcc.dg/pr44194-1.c scan-rtl-dump dse1 "global deletions = (2|3)"
FAIL: gcc.dg/pr44194-1.c scan-rtl-dump-not final "insn[: ][^\\n]*set \\\\(mem(?![^\\n]*scratch)"
UNRESOLVED: gcc.dg/superblock.c scan-rtl-dump-times sched2 "ADVANCING TO" 2
FAIL: gcc.dg/utf-array-short-wchar.c (test for errors, line 39)
FAIL: gcc.dg/utf-array-short-wchar.c (test for errors, line 41)
@ -489,17 +479,16 @@ FAIL: gcc.target/i386/long-double-128-9.c (test for excess errors)
UNRESOLVED: gcc.target/i386/long-double-128-9.c compilation failed to produce executable
FAIL: gcc.target/i386/pr63618.c (test for excess errors)
UNRESOLVED: gcc.target/i386/pr63618.c compilation failed to produce executable
FAIL: gcc.target/i386/pr64291-1.c execution test
=== gcc Summary ===
# of expected passes 107998
# of unexpected failures 329
# of expected passes 108219
# of unexpected failures 321
# of unexpected successes 33
# of expected failures 272
# of expected failures 277
# of unresolved testcases 92
# of unsupported tests 2687
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/xgcc version 5.0.0 20150104 (experimental) (GCC)
# of unsupported tests 2717
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/xgcc version 5.0.0 20150118 (experimental) (GCC)
=== gfortran tests ===
@ -533,11 +522,11 @@ FAIL: gfortran.dg/nint_2.f90 -O0 execution test
=== gfortran Summary ===
# of expected passes 46986
# of expected passes 47816
# of unexpected failures 25
# of expected failures 61
# of unsupported tests 108
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/testsuite/gfortran/../../gfortran version 5.0.0 20150104 (experimental) (GCC)
# of expected failures 76
# of unsupported tests 111
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/testsuite/gfortran/../../gfortran version 5.0.0 20150118 (experimental) (GCC)
=== obj-c++ tests ===
@ -549,7 +538,7 @@ Running target unix
# of expected passes 1445
# of expected failures 10
# of unsupported tests 86
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/testsuite/obj-c++/../../xg++ version 5.0.0 20150104 (experimental) (GCC)
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/testsuite/obj-c++/../../xg++ version 5.0.0 20150118 (experimental) (GCC)
=== objc tests ===
@ -565,7 +554,7 @@ FAIL: objc.dg/proto-lossage-4.m -fgnu-runtime (test for excess errors)
# of unexpected failures 3
# of expected failures 6
# of unsupported tests 74
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/xgcc version 5.0.0 20150104 (experimental) (GCC)
/usr/pkgsrc/wip/gcc50snapshot/work/build/gcc/xgcc version 5.0.0 20150118 (experimental) (GCC)
=== libatomic tests ===
@ -580,15 +569,19 @@ Running target unix
Running target unix
WARNING: program timed out.
FAIL: libgomp.fortran/cancel-parallel-1.f90 -O3 -fomit-frame-pointer execution test
FAIL: libgomp.c/affinity-1.c execution test
WARNING: program timed out.
FAIL: libgomp.fortran/target4.f90 -O0 execution test
FAIL: libgomp.fortran/examples-4/e.51.3.f90 -O3 -fomit-frame-pointer execution test
FAIL: libgomp.fortran/pr25162.f -O3 -fomit-frame-pointer execution test
FAIL: libgomp.fortran/pr25162.f -O3 -fomit-frame-pointer -funroll-loops execution test
FAIL: libgomp.fortran/pr25162.f -O3 -fomit-frame-pointer -funroll-all-loops -finline-functions execution test
FAIL: libgomp.fortran/pr25162.f -O3 -g execution test
=== libgomp Summary ===
# of expected passes 3739
# of unexpected failures 2
# of unsupported tests 86
# of expected passes 4665
# of unexpected failures 6
# of unsupported tests 206
=== libitm tests ===
@ -607,6 +600,7 @@ FAIL: libitm.c/clone-1.c execution test
Running target unix
WARNING: program timed out.
FAIL: 20_util/hash/chi2_q_uniform_random.cc execution test
FAIL: 22_locale/conversions/string/2.cc execution test
FAIL: 22_locale/ctype_base/11844.cc execution test
FAIL: 22_locale/locale/cons/6.cc execution test
FAIL: 22_locale/num_get/get/char/11.cc execution test
@ -701,24 +695,22 @@ FAIL: tr1/5_numerical_facilities/special_functions/08_cyl_bessel_i/check_nan.cc
UNRESOLVED: tr1/5_numerical_facilities/special_functions/08_cyl_bessel_i/check_nan.cc compilation failed to produce executable
FAIL: tr1/5_numerical_facilities/special_functions/09_cyl_bessel_j/check_nan.cc (test for excess errors)
UNRESOLVED: tr1/5_numerical_facilities/special_functions/09_cyl_bessel_j/check_nan.cc compilation failed to produce executable
FAIL: tr1/5_numerical_facilities/special_functions/11_cyl_neumann/check_nan.cc (test for excess errors)
UNRESOLVED: tr1/5_numerical_facilities/special_functions/11_cyl_neumann/check_nan.cc compilation failed to produce executable
FAIL: tr1/5_numerical_facilities/special_functions/22_sph_legendre/check_nan.cc (test for excess errors)
UNRESOLVED: tr1/5_numerical_facilities/special_functions/22_sph_legendre/check_nan.cc compilation failed to produce executable
=== libstdc++ Summary ===
# of expected passes 9134
# of expected passes 9162
# of unexpected failures 95
# of expected failures 67
# of unresolved testcases 4
# of expected failures 64
# of unresolved testcases 3
# of unsupported tests 646
Compiler version: 5.0.0 20150104 (experimental) (GCC)
Compiler version: 5.0.0 20150118 (experimental) (GCC)
Platform: x86_64--netbsd
configure flags: --enable-nls --with-libiconv-prefix=/usr --enable-__cxa_atexit --with-gxx-include-dir=/usr/pkg/gcc50snapshot/include/c++/ --enable-languages='c obj-c++ objc fortran c++' --enable-shared --enable-long-long --with-local-prefix=/usr/pkg/gcc50snapshot --enable-libssp --enable-threads=posix --with-boot-ldflags='-static-libstdc++ -static-libgcc -Wl,-R/usr/pkg/lib ' --with-gnu-ld --with-ld=/usr/bin/ld --with-gnu-as --with-as=/usr/bin/as --with-arch=nocona --with-tune=nocona --with-fpmath=sse --prefix=/usr/pkg/gcc50snapshot --build=x86_64--netbsd --host=x86_64--netbsd --infodir=/usr/pkg/gcc50snapshot/info --mandir=/usr/pkg/gcc50snapshot/man
EOF
Mail -s "Results for 5.0.0 20150104 (experimental) (GCC) testsuite on x86_64--netbsd" gcc-testresults@gcc.gnu.org &&
Mail -s "Results for 5.0.0 20150118 (experimental) (GCC) testsuite on x86_64--netbsd" gcc-testresults@gcc.gnu.org &&
mv /usr/pkgsrc/wip/gcc50snapshot/work/build/./gcc/testsuite/g++/g++.sum /usr/pkgsrc/wip/gcc50snapshot/work/build/./gcc/testsuite/g++/g++.sum.sent &&
mv /usr/pkgsrc/wip/gcc50snapshot/work/build/./gcc/testsuite/gcc/gcc.sum /usr/pkgsrc/wip/gcc50snapshot/work/build/./gcc/testsuite/gcc/gcc.sum.sent &&
mv /usr/pkgsrc/wip/gcc50snapshot/work/build/./gcc/testsuite/gfortran/gfortran.sum /usr/pkgsrc/wip/gcc50snapshot/work/build/./gcc/testsuite/gfortran/gfortran.sum.sent &&

View file

@ -1,2 +1,2 @@
# $NetBSD: version.mk,v 1.10 2015/01/15 06:09:09 keckhardt Exp $
GCC50S_DIST_VERSION:=5-20150104
# $NetBSD: version.mk,v 1.11 2015/01/21 14:58:48 keckhardt Exp $
GCC50S_DIST_VERSION:=5-20150118