Digital clocks are nice for telling exactly what time it is, but, unlike an
analogue clock, they don't give a spatial representation of time. They don't show where time is coming from or going to. On the other hand, a bitmap representation of a mechanical clock doesn't tell time very accurately if the bitmap is very small. And curves and oblique lines don't look very nice in a small, low-resolution bitmap. So, this is something different: an analogue clock that isn't tied to the design of the mechanical clock, but instead uses the natural properties of bitmaps: straight lines and rectangles.
This commit is contained in:
parent
d941fb6f21
commit
eb6cbba9f2
6 changed files with 85 additions and 0 deletions
11
abclock/DESCR
Normal file
11
abclock/DESCR
Normal file
|
@ -0,0 +1,11 @@
|
|||
Digital clocks are nice for telling exactly what time it is, but, unlike an
|
||||
analogue clock, they don't give a spatial representation of time. They don't
|
||||
show where time is coming from or going to.
|
||||
|
||||
On the other hand, a bitmap representation of a mechanical clock doesn't tell
|
||||
time very accurately if the bitmap is very small. And curves and oblique lines
|
||||
don't look very nice in a small, low-resolution bitmap.
|
||||
|
||||
So, this is something different: an analogue clock that isn't tied to the
|
||||
design of the mechanical clock, but instead uses the natural properties of
|
||||
bitmaps: straight lines and rectangles.
|
16
abclock/Makefile
Normal file
16
abclock/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2005/11/18 10:43:04 ghen Exp $
|
||||
|
||||
DISTNAME= abclock-1.0c
|
||||
CATEGORIES= time
|
||||
MASTER_SITES= ${HOMEPAGE}
|
||||
|
||||
MAINTAINER= geert.hendrickx@ua.ac.be
|
||||
COMMENT= Analogue Bitmap Clock
|
||||
HOMEPAGE= http://odur.let.rug.nl/~kleiweg/abclock/
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/abclock ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/abc_img ${PREFIX}/bin
|
||||
|
||||
.include "../../mk/x11.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
abclock/PLIST
Normal file
3
abclock/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2005/11/18 10:43:04 ghen Exp $
|
||||
bin/abc_img
|
||||
bin/abclock
|
7
abclock/distinfo
Normal file
7
abclock/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2005/11/18 10:43:04 ghen Exp $
|
||||
|
||||
SHA1 (abclock-1.0c.tar.gz) = 1513b53ff98f49400b713e704061a7a5967e5760
|
||||
RMD160 (abclock-1.0c.tar.gz) = c37f1ceef6b2badf39849c1ca56dda64976c2562
|
||||
Size (abclock-1.0c.tar.gz) = 17927 bytes
|
||||
SHA1 (patch-aa) = 038887a124c5110ea97902a6158e77e2b62647f4
|
||||
SHA1 (patch-ab) = c15f9ea30c6662baa357d0864159b3825a2d7e97
|
35
abclock/patches/patch-aa
Normal file
35
abclock/patches/patch-aa
Normal file
|
@ -0,0 +1,35 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/11/18 10:43:04 ghen Exp $
|
||||
|
||||
--- Makefile.orig 2003-08-27 15:57:57.000000000 +0200
|
||||
+++ Makefile
|
||||
@@ -1,26 +1,17 @@
|
||||
|
||||
.SUFFIXES:
|
||||
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
|
||||
-OPT = -s -Wall
|
||||
-
|
||||
-XLIBDIR = -L/usr/X11/lib -L/usr/X11R6/lib -L/usr/X11R5/lib -L/usr/X11R4/lib \
|
||||
- -L/usr/lib/X11 -L/usr/lib/X11R6 -L/usr/lib/X11R5 -L/usr/lib/X11R4
|
||||
-
|
||||
-XINCLUDEDIR = -I/usr/X11/include -I/usr/X11R6/include -I/usr/X11R5/include -I/usr/X11R4/include \
|
||||
- -I/usr/include/X11 -I/usr/include/X11R6 -I/usr/include/X11R5 -I/usr/include/X11R4 \
|
||||
- -I/usr/local/X11/include -I/usr/local/X11R6/include -I/usr/local/X11R5/include -I/usr/local/X11R4/include \
|
||||
- -I/usr/local/include/X11 -I/usr/local/include/X11R6 -I/usr/local/include/X11R5 -I/usr/local/include/X11R4 \
|
||||
- -I/usr/X386/include -I/usr/x386/include -I/usr/XFree86/include/X11 -I/usr/local/x11r5/include
|
||||
+OPT = $(CFLAGS) -Wall
|
||||
|
||||
all: abclock abc_img
|
||||
|
||||
abclock: abclock.o abclib.o
|
||||
- $(CC) $(XLIBDIR) $(OPT) -o abclock abclock.o abclib.o -lX11
|
||||
+ $(CC) $(LDFLAGS) $(OPT) -o abclock abclock.o abclib.o -lX11
|
||||
|
||||
abc_img: abc_img.o abclib.o
|
||||
- $(CC) $(OPT) -o abc_img abc_img.o abclib.o
|
||||
+ $(CC) $(LDFLAGS) $(OPT) -o abc_img abc_img.o abclib.o
|
||||
|
||||
abclib.o: abclib.c abclib.h
|
||||
$(CC) -c $(OPT) -o abclib.o abclib.c
|
13
abclock/patches/patch-ab
Normal file
13
abclock/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2005/11/18 10:43:04 ghen Exp $
|
||||
|
||||
--- abclock.c.orig 2005-11-18 11:03:51.000000000 +0100
|
||||
+++ abclock.c
|
||||
@@ -29,7 +29,7 @@
|
||||
#include <time.h>
|
||||
#include <sys/time.h>
|
||||
#include <unistd.h>
|
||||
-#include <values.h>
|
||||
+#include <float.h>
|
||||
#include <X11/Xlib.h>
|
||||
#include <X11/Xutil.h>
|
||||
|
Loading…
Reference in a new issue