import the email client mutt - but with the current source and extra
patches for: nntp support date_conditional formatting
This commit is contained in:
parent
675f7244ea
commit
eb9855c91a
10 changed files with 376 additions and 0 deletions
13
mutt-devel/DESCR
Normal file
13
mutt-devel/DESCR
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: DESCR,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
|
||||
The Mutt E-Mail Client by Michael Elkins <me@cs.hmc.edu>
|
||||
|
||||
``All mail clients suck. This one just sucks less.'' -me, circa 1995
|
||||
|
||||
Mutt is a small but very powerful text-based MIME mail client.Mutt
|
||||
is highly configurable, and is well suited to the mail power user with
|
||||
advanced features like key bindings, keyboard macros, mail threading,
|
||||
regular expression searches and a powerful pattern matching language
|
||||
for selecting groups of messages.
|
||||
|
||||
This is the latest current version of mutt with extra patches.
|
4
mutt-devel/MESSAGE.date_conditional
Normal file
4
mutt-devel/MESSAGE.date_conditional
Normal file
|
@ -0,0 +1,4 @@
|
|||
===========================================================================
|
||||
You will want to change your "index_format" to see these changes. Try this:
|
||||
'%3C %Z %?[1y?%\?[1d\?%[%H:%M]\&%[%d/%m]\?&%[%y.%m]? %-12.12F (%4c) %s'
|
||||
===========================================================================
|
104
mutt-devel/Makefile
Normal file
104
mutt-devel/Makefile
Normal file
|
@ -0,0 +1,104 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
|
||||
DISTNAME= mutt-1.5.4i
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:C/i$$//}
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.mutt.org/mutt/ \
|
||||
ftp://ftp.stealth.net/pub/mirrors/ftp.mutt.org/pub/mutt/ \
|
||||
ftp://gd.tuwien.ac.at/infosys/mail/mutt/ \
|
||||
ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/
|
||||
|
||||
MAINTAINER= charlie@rubberduck.com
|
||||
HOMEPAGE= http://www.mutt.org/
|
||||
COMMENT= text-based MIME mail client with PGP support
|
||||
|
||||
# for nntp patch
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
CONFLICTS+= mutt-[0-9]*
|
||||
|
||||
BUILD_USES_MSGFMT= yes
|
||||
|
||||
USE_BUILDLINK2= yes
|
||||
USE_PKGINSTALL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR} \
|
||||
--with-docdir=${PREFIX}/share/doc/mutt \
|
||||
--without-included-gettext \
|
||||
--enable-pop --enable-imap
|
||||
|
||||
LDFLAGS+= ${_STRIPFLAG_CC}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${MUTT_USE_SLANG} == YES
|
||||
. include "../../devel/libslang/buildlink2.mk"
|
||||
CONFIGURE_ARGS+= --with-slang=${BUILDLINK_PREFIX.libslang}
|
||||
.else
|
||||
. if ${MUTT_USE_NCURSES} == YES
|
||||
USE_NCURSES= yes
|
||||
. endif
|
||||
. include "../../devel/ncurses/buildlink2.mk"
|
||||
CONFIGURE_ARGS+= --with-curses=${BUILDLINK_PREFIX.ncurses}
|
||||
.endif
|
||||
|
||||
.if defined(MUTT_USE_NNTP) && ${MUTT_USE_NNTP} == YES
|
||||
PATCHFILES+=${NNTP_PATCH}
|
||||
PATCH_DIST_STRIP= -p1
|
||||
NNTP_PATCH=patch-1.5.4.vvv.nntp.gz
|
||||
SITES_${NNTP_PATCH}=http://mutt.org.ua/download/mutt-1.5.4/
|
||||
|
||||
CONFIGURE_ARGS+=--enable-nntp
|
||||
|
||||
pre-install:
|
||||
${PATCH} -d ${WRKSRC} < ${FILESDIR}/no_smime
|
||||
|
||||
.endif
|
||||
|
||||
.if defined(MUTT_USE_DATE_CONDITIONAL) && ${MUTT_USE_DATE_CONDITIONAL} == YES
|
||||
PATCHFILES+= patch-1.5.1.ats.date_conditional.1 patch-1.5.1.dgc.deepif.1
|
||||
DATE_CONDITIONAL=patch-1.5.1.ats.date_conditional.1
|
||||
DEEPIF=patch-1.5.1.dgc.deepif.1
|
||||
SITES_${DATE_CONDITIONAL}=http://www.schrab.com/aaron/mutt/
|
||||
SITES_${DEEPIF}=http://home.uchicago.edu/~dgc/sw/mutt/
|
||||
|
||||
MESSAGE_SRC+= ${.CURDIR}/MESSAGE.date_conditional
|
||||
.endif
|
||||
|
||||
# There seems to be a problem using NetBSD's /bin/sh, so use /bin/ksh instead.
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
CONFIGURE_ARGS+= --with-exec-shell=/bin/ksh
|
||||
.endif
|
||||
|
||||
.if ${MUTT_USE_SSL} == YES
|
||||
.include "../../security/openssl/buildlink2.mk"
|
||||
CONFIGURE_ARGS+= --with-ssl=${SSLBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-ssl
|
||||
.endif
|
||||
|
||||
.if defined(USE_SASL) && ${USE_SASL} == "YES"
|
||||
.include "../../security/cyrus-sasl/buildlink2.mk"
|
||||
CONFIGURE_ARGS+= --with-sasl=${BUILDLINK_PREFIX.cyrus-sasl}
|
||||
.endif
|
||||
|
||||
BUILD_DEFS+= MUTT_USE_NCURSES MUTT_USE_SLANG MUTT_USE_SSL USE_SASL
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/mutt
|
||||
CONF_FILES= ${EGDIR}/Muttrc ${PKG_SYSCONFDIR}/Muttrc
|
||||
SUPPORT_FILES= ${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types
|
||||
|
||||
post-extract:
|
||||
${MV} ${WRKSRC}/doc/mutt.man ${WRKSRC}/doc/mutt.man.in
|
||||
${SED} -e "s|@PREFIX@|${PREFIX}|g" \
|
||||
-e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g" \
|
||||
< ${WRKSRC}/doc/mutt.man.in > ${WRKSRC}/doc/mutt.man
|
||||
|
||||
post-install:
|
||||
${CP} ${WRKSRC}/smime_keys ${PREFIX}/bin
|
||||
${LN} -s ${EGDIR} ${PREFIX}/share/doc/mutt/samples
|
||||
|
||||
.include "../../converters/libiconv/buildlink2.mk"
|
||||
.include "../../devel/gettext-lib/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
100
mutt-devel/PLIST
Normal file
100
mutt-devel/PLIST
Normal file
|
@ -0,0 +1,100 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
bin/flea
|
||||
bin/mutt
|
||||
bin/muttbug
|
||||
bin/pgpewrap
|
||||
bin/pgpring
|
||||
bin/smime_keys
|
||||
man/man1/flea.1
|
||||
man/man1/mutt.1
|
||||
man/man1/muttbug.1
|
||||
man/man5/mbox.5
|
||||
man/man5/muttrc.5
|
||||
share/doc/mutt/COPYRIGHT
|
||||
share/doc/mutt/ChangeLog
|
||||
share/doc/mutt/ChangeLog.old
|
||||
share/doc/mutt/GPL
|
||||
share/doc/mutt/INSTALL
|
||||
share/doc/mutt/NEWS
|
||||
share/doc/mutt/PGP-Notes.txt
|
||||
share/doc/mutt/README
|
||||
share/doc/mutt/README.SECURITY
|
||||
share/doc/mutt/README.SSL
|
||||
share/doc/mutt/TODO
|
||||
share/doc/mutt/applying-patches.txt
|
||||
share/doc/mutt/devel-notes.txt
|
||||
share/doc/mutt/html/manual-1.html
|
||||
share/doc/mutt/html/manual-2.html
|
||||
share/doc/mutt/html/manual-3.html
|
||||
share/doc/mutt/html/manual-4.html
|
||||
share/doc/mutt/html/manual-5.html
|
||||
share/doc/mutt/html/manual-6.html
|
||||
share/doc/mutt/html/manual-7.html
|
||||
share/doc/mutt/html/manual.html
|
||||
share/doc/mutt/manual.txt
|
||||
share/doc/mutt/patch-notes.txt
|
||||
share/doc/mutt/samples
|
||||
share/doc/mutt/smime-notes.txt
|
||||
share/examples/mutt/Mush.rc
|
||||
share/examples/mutt/Muttrc
|
||||
share/examples/mutt/Pine.rc
|
||||
share/examples/mutt/Tin.rc
|
||||
share/examples/mutt/ca-bundle.crt
|
||||
share/examples/mutt/gpg.rc
|
||||
share/examples/mutt/iconv/iconv.aix-3.2.5.rc
|
||||
share/examples/mutt/iconv/iconv.aix-4.1.5.rc
|
||||
share/examples/mutt/iconv/iconv.aix-4.2.0.rc
|
||||
share/examples/mutt/iconv/iconv.aix-4.3.2.rc
|
||||
share/examples/mutt/iconv/iconv.freebsd-3.3.rc
|
||||
share/examples/mutt/iconv/iconv.glibc-2.1.3.rc
|
||||
share/examples/mutt/iconv/iconv.glibc-2.1.90.rc
|
||||
share/examples/mutt/iconv/iconv.hpux-10.01.rc
|
||||
share/examples/mutt/iconv/iconv.hpux-10.20.rc
|
||||
share/examples/mutt/iconv/iconv.hpux-11.00.rc
|
||||
share/examples/mutt/iconv/iconv.irix-6.5.rc
|
||||
share/examples/mutt/iconv/iconv.osf1-4.0a.rc
|
||||
share/examples/mutt/iconv/iconv.osf1-4.0d.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.4.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.5.1.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.6-cjk.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.6.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.7.rc
|
||||
share/examples/mutt/mime.types
|
||||
share/examples/mutt/pgp2.rc
|
||||
share/examples/mutt/pgp5.rc
|
||||
share/examples/mutt/pgp6.rc
|
||||
share/examples/mutt/sample.mailcap
|
||||
share/examples/mutt/sample.muttrc
|
||||
share/examples/mutt/sample.muttrc-tlr
|
||||
share/examples/mutt/smime.rc
|
||||
share/examples/mutt/smime_keys_test.pl
|
||||
${PKGLOCALEDIR}/locale/ca/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/da/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/el/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/eo/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/et/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/gl/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/hu/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/id/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/ko/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/lt/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/pl/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/sk/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/tr/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/uk/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/zh_CN/LC_MESSAGES/mutt.mo
|
||||
${PKGLOCALEDIR}/locale/zh_TW/LC_MESSAGES/mutt.mo
|
||||
@dirrm share/examples/mutt/iconv
|
||||
@dirrm share/examples/mutt
|
||||
@dirrm share/doc/mutt/html
|
||||
@dirrm share/doc/mutt
|
14
mutt-devel/distinfo
Normal file
14
mutt-devel/distinfo
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
|
||||
SHA1 (mutt-1.5.4i.tar.gz) = 94a31c6044570c8899ff189a28bec23957507a46
|
||||
Size (mutt-1.5.4i.tar.gz) = 2788104 bytes
|
||||
SHA1 (patch-1.5.4.vvv.nntp.gz) = 85fe1d4883a5b593ebec00c0d6da8f8d41ef5575
|
||||
Size (patch-1.5.4.vvv.nntp.gz) = 182485 bytes
|
||||
SHA1 (patch-1.5.1.ats.date_conditional.1) = a5bf64e56335b626aeae12a7e43bbab7f6eeff89
|
||||
Size (patch-1.5.1.ats.date_conditional.1) = 1993 bytes
|
||||
SHA1 (patch-1.5.1.dgc.deepif.1) = 6f5afbc7af8a6b619535c8006a155b189eadac8a
|
||||
Size (patch-1.5.1.dgc.deepif.1) = 767 bytes
|
||||
SHA1 (patch-ab) = e0d3c5b90c94a501436aa037f5538c4ab12b04bc
|
||||
SHA1 (patch-ad) = 63abea4130832d7612a904f7954ab9c97b3b80ac
|
||||
SHA1 (patch-ae) = e65a91d80b07c3bd505b2e987abcdff6d7bbefc9
|
||||
SHA1 (patch-ag) = a1574bfe28b2a0ee5295a3f3529b6865f72075fa
|
13
mutt-devel/files/no_smime
Normal file
13
mutt-devel/files/no_smime
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: no_smime,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
|
||||
--- Makefile.old 2003-06-11 19:42:15.000000000 +1000
|
||||
+++ Makefile 2003-06-11 19:42:45.000000000 +1000
|
||||
@@ -119,7 +119,7 @@
|
||||
|
||||
BUILT_SOURCES = keymap_defs.h patchlist.c
|
||||
|
||||
-bin_PROGRAMS = mutt pgpring pgpewrap smime_keys
|
||||
+bin_PROGRAMS = mutt pgpring pgpewrap
|
||||
mutt_SOURCES = $(BUILT_SOURCES) addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c crypt.c cryptglue.c commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c edit.c enter.c flags.c init.c filter.c from.c getdomain.c handler.c hash.c hdrline.c headers.c help.c hook.c keymap.c main.c mbox.c menu.c mh.c mx.c pager.c parse.c pattern.c postpone.c query.c recvattach.c recvcmd.c rfc822.c rfc1524.c rfc2047.c rfc2231.c score.c send.c sendlib.c signal.c sort.c status.c system.c thread.c charset.c history.c lib.c muttlib.c editmsg.c utf8.c mbyte.c wcwidth.c url.c ascii.c mutt_idna.c
|
||||
|
||||
|
26
mutt-devel/patches/patch-ab
Normal file
26
mutt-devel/patches/patch-ab
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
|
||||
--- Makefile.in.orig Wed May 29 11:31:04 2002
|
||||
+++ Makefile.in Sun Dec 1 16:25:32 2002
|
||||
@@ -23,9 +23,11 @@
|
||||
sbindir = @sbindir@
|
||||
libexecdir = @libexecdir@
|
||||
datadir = @datadir@
|
||||
-sysconfdir = @sysconfdir@
|
||||
+sysconfdir = @datadir@/examples/@PACKAGE@
|
||||
+realsysconfdir = @sysconfdir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
localstatedir = @localstatedir@
|
||||
+localedir = $(prefix)/share/locale
|
||||
libdir = @libdir@
|
||||
infodir = @infodir@
|
||||
mandir = @mandir@
|
||||
@@ -139,7 +141,7 @@
|
||||
|
||||
CPP = @CPP@
|
||||
|
||||
-DEFS = -DPKGDATADIR=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(sysconfdir)\" -DBINDIR=\"$(bindir)\" -DMUTTLOCALEDIR=\"$(datadir)/locale\" -DHAVE_CONFIG_H=1
|
||||
+DEFS = -DPKGDATADIR=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(realsysconfdir)\" -DBINDIR=\"$(bindir)\" -DMUTTLOCALEDIR=\"$(localedir)\" -DHAVE_CONFIG_H=1
|
||||
|
||||
|
||||
INCLUDES = -I. -I$(top_srcdir) $(IMAP_INCLUDES) -Iintl
|
28
mutt-devel/patches/patch-ad
Normal file
28
mutt-devel/patches/patch-ad
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
|
||||
--- contrib/Makefile.in.orig Mon Jun 4 19:14:31 2001
|
||||
+++ contrib/Makefile.in
|
||||
@@ -12,6 +12,7 @@ libdir = @libdir@
|
||||
mandir = @mandir@
|
||||
srcdir = @srcdir@
|
||||
docdir = @docdir@
|
||||
+egdir = @datadir@/examples/@PACKAGE@
|
||||
top_srcdir = @top_srcdir@
|
||||
top_builddir = ..
|
||||
INSTALL = @INSTALL@
|
||||
@@ -37,12 +38,12 @@ distclean:
|
||||
check:
|
||||
|
||||
install:
|
||||
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)/samples $(DESTDIR)$(docdir)/samples/iconv
|
||||
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(egdir) $(DESTDIR)$(egdir)/iconv
|
||||
for f in $(SAMPLES) ; do \
|
||||
- $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(docdir)/samples ; \
|
||||
+ $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(egdir) ; \
|
||||
done
|
||||
for f in $(srcdir)/iconv/*.rc ; do \
|
||||
- $(INSTALL) -m 644 $$f $(DESTDIR)$(docdir)/samples/iconv ; \
|
||||
+ $(INSTALL) -m 644 $$f $(DESTDIR)$(egdir)/iconv ; \
|
||||
done
|
||||
|
||||
# Nothing needs to be done - uninstall in doc removes samples as well.
|
61
mutt-devel/patches/patch-ae
Normal file
61
mutt-devel/patches/patch-ae
Normal file
|
@ -0,0 +1,61 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
|
||||
--- contrib/gpg.rc.orig 2002-03-27 09:23:58.000000000 +1100
|
||||
+++ contrib/gpg.rc 2003-06-11 15:19:42.000000000 +1000
|
||||
@@ -31,44 +31,44 @@
|
||||
# breaking PGP/MIME.
|
||||
|
||||
# decode application/pgp
|
||||
-set pgp_decode_command="/usr/bin/gpg --charset utf-8 %?p?--passphrase-fd 0? --no-verbose --quiet --batch --output - %f"
|
||||
+set pgp_decode_command="gpg --charset utf-8 %?p?--passphrase-fd 0? --no-verbose --quiet --batch --output - %f"
|
||||
|
||||
# verify a pgp/mime signature
|
||||
-set pgp_verify_command="/usr/bin/gpg --no-verbose --quiet --batch --output - --verify %s %f"
|
||||
+set pgp_verify_command="gpg --no-verbose --quiet --batch --output - --verify %s %f"
|
||||
|
||||
# decrypt a pgp/mime attachment
|
||||
-set pgp_decrypt_command="/usr/bin/gpg --passphrase-fd 0 --no-verbose --quiet --batch --output - %f"
|
||||
+set pgp_decrypt_command="gpg --passphrase-fd 0 --no-verbose --quiet --batch --output - %f"
|
||||
|
||||
# create a pgp/mime signed attachment
|
||||
# set pgp_sign_command="/usr/bin/gpg-2comp --comment '' --no-verbose --batch --output - --passphrase-fd 0 --armor --detach-sign --textmode %?a?-u %a? %f"
|
||||
-set pgp_sign_command="/usr/bin/gpg --no-verbose --batch --quiet --output - --passphrase-fd 0 --armor --detach-sign --textmode %?a?-u %a? %f"
|
||||
+set pgp_sign_command="gpg --no-verbose --batch --quiet --output - --passphrase-fd 0 --armor --detach-sign --textmode %?a?-u %a? %f"
|
||||
|
||||
# create a application/pgp signed (old-style) message
|
||||
# set pgp_clearsign_command="/usr/bin/gpg-2comp --comment '' --no-verbose --batch --output - --passphrase-fd 0 --armor --textmode --clearsign %?a?-u %a? %f"
|
||||
-set pgp_clearsign_command="/usr/bin/gpg --charset utf-8 --no-verbose --batch --quiet --output - --passphrase-fd 0 --armor --textmode --clearsign %?a?-u %a? %f"
|
||||
+set pgp_clearsign_command="gpg --charset utf-8 --no-verbose --batch --quiet --output - --passphrase-fd 0 --armor --textmode --clearsign %?a?-u %a? %f"
|
||||
|
||||
# create a pgp/mime encrypted attachment
|
||||
# set pgp_encrypt_only_command="pgpewrap gpg-2comp -v --batch --output - --encrypt --textmode --armor --always-trust -- -r %r -- %f"
|
||||
-set pgp_encrypt_only_command="pgpewrap /usr/bin/gpg --charset utf-8 --batch --quiet --no-verbose --output - --encrypt --textmode --armor --always-trust -- -r %r -- %f"
|
||||
+set pgp_encrypt_only_command="pgpewrap gpg --charset utf-8 --batch --quiet --no-verbose --output - --encrypt --textmode --armor --always-trust -- -r %r -- %f"
|
||||
|
||||
# create a pgp/mime encrypted and signed attachment
|
||||
# set pgp_encrypt_sign_command="pgpewrap gpg-2comp --passphrase-fd 0 -v --batch --output - --encrypt --sign %?a?-u %a? --armor --always-trust -- -r %r -- %f"
|
||||
-set pgp_encrypt_sign_command="pgpewrap /usr/bin/gpg --charset utf-8 --passphrase-fd 0 --batch --quiet --no-verbose --textmode --output - --encrypt --sign %?a?-u %a? --armor --always-trust -- -r %r -- %f"
|
||||
+set pgp_encrypt_sign_command="pgpewrap gpg --charset utf-8 --passphrase-fd 0 --batch --quiet --no-verbose --textmode --output - --encrypt --sign %?a?-u %a? --armor --always-trust -- -r %r -- %f"
|
||||
|
||||
# import a key into the public key ring
|
||||
-set pgp_import_command="/usr/bin/gpg --no-verbose --import -v %f"
|
||||
+set pgp_import_command="gpg --no-verbose --import -v %f"
|
||||
|
||||
# export a key from the public key ring
|
||||
-set pgp_export_command="/usr/bin/gpg --no-verbose --export --armor %r"
|
||||
+set pgp_export_command="gpg --no-verbose --export --armor %r"
|
||||
|
||||
# verify a key
|
||||
-set pgp_verify_key_command="/usr/bin/gpg --verbose --batch --fingerprint --check-sigs %r"
|
||||
+set pgp_verify_key_command="gpg --verbose --batch --fingerprint --check-sigs %r"
|
||||
|
||||
# read in the public key ring
|
||||
-set pgp_list_pubring_command="/usr/bin/gpg --no-verbose --batch --quiet --with-colons --list-keys %r"
|
||||
+set pgp_list_pubring_command="gpg --no-verbose --batch --quiet --with-colons --list-keys %r"
|
||||
|
||||
# read in the secret key ring
|
||||
-set pgp_list_secring_command="/usr/bin/gpg --no-verbose --batch --quiet --with-colons --list-secret-keys %r"
|
||||
+set pgp_list_secring_command="gpg --no-verbose --batch --quiet --with-colons --list-secret-keys %r"
|
||||
|
||||
# fetch keys
|
||||
# set pgp_getkeys_command="pkspxycwrap %r"
|
13
mutt-devel/patches/patch-ag
Normal file
13
mutt-devel/patches/patch-ag
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 2003/06/11 11:46:56 yeled Exp $
|
||||
|
||||
--- doc/Makefile.in.orig Tue Nov 6 20:12:31 2001
|
||||
+++ doc/Makefile.in
|
||||
@@ -74,8 +74,6 @@ install: all instdoc
|
||||
./instdoc $(srcdir)/mutt.man $(DESTDIR)$(mandir)/man1/mutt.1
|
||||
./instdoc $(srcdir)/muttbug.man $(DESTDIR)$(mandir)/man1/flea.1
|
||||
echo ".so $(mandir)/man1/flea.1" > $(DESTDIR)$(mandir)/man1/muttbug.1
|
||||
- ./instdoc $(srcdir)/dotlock.man \
|
||||
- $(DESTDIR)$(mandir)/man1/mutt_dotlock.1
|
||||
./instdoc muttrc.man $(DESTDIR)$(mandir)/man5/muttrc.5
|
||||
./instdoc $(srcdir)/mbox.man $(DESTDIR)$(mandir)/man5/mbox.5
|
||||
$(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)
|
Loading…
Reference in a new issue