- change maintainer - as agreed with by adam@
- clean up patches
- bump to version 3.1

Changelog for hydra
-------------------

v3.1 (MARCH 2004)               PUBLIC RELEASE
-rc1:
* added patch by m0j0.j0j0 which fixes the parallel host scanning and
  killing all childrens. Also new options for his smbnt module and frees
  memory which I forgot.
* more memory freeing. Whis will save considerable amount of memory now :-)
* fixed a small glitch in the mysql module (thanks to plasmoid@thc.org)
* reviewed all fishy conversions (gcc -pedantic)
* restore functionality is still experimental - a message states this now.
* added CYGWIN support
-rc2:
* fixed two small glitches (thanks to Eric)
* uh, fixed big search'n replace error in smbnt in rc1 ... :-)

v3.0 (FEBRUARY 2004)            PUBLIC RELEASE
* added a restore function to enable you to continue aborted/crashed
  sessions. Just type "hydra -R" to continue a session.
  NOTE: this does not work with the -M option! This feature is then disabled!
* added a module for http proxy authentication cracking ("http-proxy") :-)
* added HTTP and SSL/CONNECT proxy support. SSL/CONNECT proxy support works
  for *all* TCP protocols, you just need to find a proxy which allows you to
  CONNECT on port 23 ...
  The environment variable HYDRA_PROXY_HTTP defines the web proxy. The
  following syntax is valid: HYDRA_PROXY_HTTP="http://123.45.67.89:8080/"
  Same for HYDRA_PROXY_CONNECT.
  If you require authentication for the proxy, use the HYDRA_PROXY_AUTH
  environment variable:
    HYDRA_PROXY_AUTH="login:password"
* fixed parallel host scanning engine (thanks to m0j0.j0j0 for reporting)
* A status, speed and time to completion report is now printed every minute.
* finally updated the README

v2.9 (FEBRUARY 2004)            PRIVATE RELEASE
...

v2.8 (JANUARY 2004)             PRIVATE RELEASE
...

v2.7 (JANUARY 2004)             PUBLIC RELEASE
* small fix for the parallel host code (thanks to m0j0@foofus.net)
This commit is contained in:
Adrian Portelli 2004-04-22 21:00:40 +00:00 committed by Thomas Klausner
parent dd0666d196
commit ec6d444db9
5 changed files with 39 additions and 34 deletions

View file

@ -1,21 +1,18 @@
# $NetBSD: Makefile,v 1.4 2003/12/16 22:51:25 adrian_p Exp $
# $NetBSD: Makefile,v 1.5 2004/04/22 21:00:40 adrian_p Exp $
#
DISTNAME= hydra-2.6
DISTNAME= hydra-3.1
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/
MAINTAINER= adam@monkeybyte.org
MAINTAINER= adrianp@stindustries.net
HOMEPAGE= http://www.thc.org/
COMMENT= Login password cracker
GNU_CONFIGURE= YES
USE_BUILDLINK2= YES
USE_BUILDLINK3= YES
CONFIGURE_ARGS+= --prefix=${PREFIX}
post-extract:
@${CHMOD} 0755 ${WRKSRC}
.include "../../security/openssl/buildlink2.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: TODO,v 1.1 2003/12/16 22:51:25 adrian_p Exp $
$NetBSD: TODO,v 1.2 2004/04/22 21:00:41 adrian_p Exp $
Not tested on -current
patch-ab needs work as it should follow ${SSLBASE}
patch-aa needs work as it should follow ${SSLBASE}

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.4 2003/12/16 22:51:25 adrian_p Exp $
$NetBSD: distinfo,v 1.5 2004/04/22 21:00:42 adrian_p Exp $
SHA1 (hydra-2.6.tar.gz) = e2ff1dd68284c55f7fc6fe63a66dbd9f3480a82d
Size (hydra-2.6.tar.gz) = 48954 bytes
SHA1 (patch-aa) = 7d38687f39def66c12410605531a7facca529ad0
SHA1 (patch-ab) = 4ed6a379282313695d354c4a0424f1145610ffbd
SHA1 (hydra-3.1.tar.gz) = 4b63b66b02eb28b355fd526cc7b30ff62cb6a88b
Size (hydra-3.1.tar.gz) = 53937 bytes
SHA1 (patch-aa) = 329255db454c04bbe0749982534482693ed0c264
SHA1 (patch-ab) = 8aca85df83d7625c97799f54168e8e89266c00b8

View file

@ -1,13 +1,13 @@
$NetBSD: patch-aa,v 1.3 2003/11/14 17:15:16 adrian_p Exp $
$NetBSD: patch-aa,v 1.4 2004/04/22 21:00:42 adrian_p Exp $
--- Makefile.am.orig 2003-11-14 17:10:29.000000000 +0000
+++ Makefile.am 2003-11-14 17:10:43.000000000 +0000
@@ -4,7 +4,7 @@
--- Makefile.am.orig Thu Apr 22 20:49:08 2004
+++ Makefile.am Thu Apr 22 20:49:27 2004
@@ -3,7 +3,7 @@
#
CC = gcc
OPTS = -O2 -I. -Wall
-LIBS =
+LIBS = -lm
-OPTS = -O2 -I. -Wall
+OPTS = ${CFLAGS} -I/usr/pkg/include/openssl
LIBS =
DIR = /bin
SRC = hydra-vnc.c hydra-pcnfs.c hydra-rexec.c hydra-nntp.c hydra-socks5.c \

View file

@ -1,13 +1,21 @@
$NetBSD: patch-ab,v 1.1 2003/12/16 22:51:25 adrian_p Exp $
$NetBSD: patch-ab,v 1.2 2004/04/22 21:00:44 adrian_p Exp $
--- configure.orig Tue Dec 16 22:44:05 2003
+++ configure Tue Dec 16 22:44:40 2003
@@ -141,7 +141,7 @@
fi
--- hydra-smbnt.c.orig Thu Apr 22 21:51:59 2004
+++ hydra-smbnt.c Thu Apr 22 21:52:26 2004
@@ -243,6 +243,7 @@
int
SMBNegProt(int s)
{
+ int i;
char buf[168] = { 0x00, 0x00, 0x00, 0xa4, 0xff, 0x53, 0x4d, 0x42,
0x72, 0x00, 0x00, 0x00, 0x00, 0x08, 0x01, 0x40,
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
@@ -278,7 +279,7 @@
echo
-XDEFINES=""
+XDEFINES="-I/usr/include/openssl"
XLIBS=""
XLIBPATHS=""
XIPATHS=""
/* find the primary domain/workgroup name */
memset(workgroup, 0, 16);
- int i = 0;
+ i = 0;
while ((rbuf[81+i*2] != 0) && (i<16)) {
workgroup[i] = rbuf[81+i*2];
i++;