Rebase to ATLAS 3.9.25.

This commit is contained in:
Aleksej Saushev 2010-08-01 11:17:03 +00:00 committed by Thomas Klausner
parent 783046445a
commit ed069116f6
3 changed files with 15 additions and 15 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.8 2010/05/06 10:23:01 asau Exp $
# $NetBSD: Makefile,v 1.9 2010/08/01 11:17:03 asau Exp $
ATLAS_VERSION= 3.9.15
ATLAS_VERSION= 3.9.25
DISTNAME= atlas${ATLAS_VERSION}
PKGNAME= atlas-${ATLAS_VERSION}
@ -9,7 +9,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=math-atlas/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= asau@inbox.ru
HOMEPAGE= http://math-atlas.sourceforge.net/
HOMEPAGE= http://math-atlas.sourceforge.net/
COMMENT= Automatically Tuned Linear Algebra Software
CONFLICTS= lapack-[0-9]*

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2009/10/14 20:17:34 asau Exp $
$NetBSD: distinfo,v 1.6 2010/08/01 11:17:03 asau Exp $
SHA1 (atlas3.9.15.tar.bz2) = e7da6581887fc66577b9c42775a539a730ad1a09
RMD160 (atlas3.9.15.tar.bz2) = ecdd56e92fe53af70061647c83160060b58a873e
Size (atlas3.9.15.tar.bz2) = 4772571 bytes
SHA1 (atlas3.9.25.tar.bz2) = ab1b8b44a0f7f44ce0e7635af9d1200d087b08db
RMD160 (atlas3.9.25.tar.bz2) = a8a884c9db69946f5a839716e75fe73b76eb34b5
Size (atlas3.9.25.tar.bz2) = 4988010 bytes
SHA1 (patch-aa) = b804aff967228551bafd3f5d232c2f79c79e989b
SHA1 (patch-ab) = 40e89aee71f7164776df72a182216c110a246b7d
SHA1 (patch-ab) = 1f363575769a70689a7466483c2caa132d840820

View file

@ -1,13 +1,13 @@
$NetBSD: patch-ab,v 1.1 2008/04/27 19:08:31 asau Exp $
$NetBSD: patch-ab,v 1.2 2010/08/01 11:17:03 asau Exp $
Teach it about NetBSD.
--- CONFIG/src/probe_OS.c.orig 2008-02-22 19:38:51.000000000 +0300
+++ CONFIG/src/probe_OS.c 2008-04-27 18:58:23.000000000 +0400
@@ -15,6 +15,7 @@
if (ierr == 0)
{
if(strstr(ln, "Linux")) OS = OSLinux;
--- CONFIG/src/probe_OS.c.orig 2010-06-04 20:42:47.000000000 +0400
+++ CONFIG/src/probe_OS.c 2010-08-01 15:15:22.000000000 +0400
@@ -19,6 +19,7 @@
* This is patch from Sylvestre Ledru; I have no direct experience wt HURD
*/
if(strstr(ln, "Linux") || strstr(ln, "GNU")) OS = OSLinux;
+ else if (strstr(ln, "NetBSD")) OS = OSNetBSD;
else if(strstr(ln, "FreeBSD")) OS = OSFreeBSD;
else if (strstr(ln, "Darwin")) OS = OSOSX;