Upstream update to HUnit-1.2.4.2
This commit is contained in:
parent
05f27df2f1
commit
eec88e3db2
4 changed files with 73 additions and 25 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.5 2011/07/28 09:54:12 phonohawk Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2011/12/04 13:27:16 phonohawk Exp $
|
||||
#
|
||||
|
||||
DISTNAME= HUnit-1.2.2.3
|
||||
DISTNAME= HUnit-1.2.4.2
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= pho@cielonegro.org
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.2 2009/09/23 06:35:34 phonohawk Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.3 2011/12/04 13:27:16 phonohawk Exp $
|
||||
|
||||
BUILDLINK_TREE+= hs-HUnit
|
||||
|
||||
.if !defined(HS_HUNIT_BUILDLINK3_MK)
|
||||
HS_HUNIT_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.hs-HUnit+= hs-HUnit>=1.2.2.0
|
||||
BUILDLINK_API_DEPENDS.hs-HUnit+= hs-HUnit>=1.2.4
|
||||
BUILDLINK_PKGSRCDIR.hs-HUnit?= ../../wip/hs-HUnit
|
||||
.endif # HS_HUNIT_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.4 2011/07/28 09:54:12 phonohawk Exp $
|
||||
$NetBSD: distinfo,v 1.5 2011/12/04 13:27:16 phonohawk Exp $
|
||||
|
||||
SHA1 (HUnit-1.2.2.3.tar.gz) = 669c1a658c667f1ecd7cad1ee35a2e2aff788f41
|
||||
RMD160 (HUnit-1.2.2.3.tar.gz) = 2e1249b19c08daca9a3f695838dfbfcdb485dea3
|
||||
Size (HUnit-1.2.2.3.tar.gz) = 22665 bytes
|
||||
SHA1 (patch-HUnit.cabal) = 80b7949445ac6584330e59cf90b6455e6c5dfc85
|
||||
SHA1 (HUnit-1.2.4.2.tar.gz) = 4db75bfdc4dcb6061500cc3321e10a5a311df6ea
|
||||
RMD160 (HUnit-1.2.4.2.tar.gz) = a8a8dca99fc5f6fd37a35e7e71305d195e2a52e2
|
||||
Size (HUnit-1.2.4.2.tar.gz) = 23558 bytes
|
||||
SHA1 (patch-HUnit.cabal) = a695a572b9b8a370677045ada5a7542464eae0fb
|
||||
|
|
|
@ -1,28 +1,23 @@
|
|||
$NetBSD: patch-HUnit.cabal,v 1.1 2011/07/28 09:54:12 phonohawk Exp $
|
||||
$NetBSD: patch-HUnit.cabal,v 1.2 2011/12/04 13:27:16 phonohawk Exp $
|
||||
|
||||
Don't build/install the test executables.
|
||||
It's no use for any library users.
|
||||
|
||||
--- HUnit.cabal.orig 2010-09-27 07:52:00.000000000 +0000
|
||||
--- HUnit.cabal.orig 2011-08-13 21:31:54.000000000 +0000
|
||||
+++ HUnit.cabal
|
||||
@@ -51,44 +51,3 @@ Library
|
||||
Test.HUnit.Text,
|
||||
@@ -53,8 +53,6 @@ Library
|
||||
Test.HUnit
|
||||
Extensions: CPP
|
||||
-
|
||||
|
||||
-Executable basic-tests
|
||||
- Main-Is: HUnitTest98.lhs
|
||||
- HS-Source-Dirs: . tests
|
||||
- Build-Depends: base<5
|
||||
- if flag(base4)
|
||||
- Build-Depends: base >=4
|
||||
- CPP-Options: -DBASE4
|
||||
- GHC-Options: -Wall
|
||||
- else
|
||||
- Build-Depends: base <4
|
||||
- if impl(ghc >= 6.10)
|
||||
- Build-Depends: base >=4
|
||||
- Extensions: CPP
|
||||
HS-Source-Dirs: . tests
|
||||
Build-Depends: base<5
|
||||
if flag(base4)
|
||||
@@ -66,83 +64,3 @@ Executable basic-tests
|
||||
if impl(ghc >= 6.10)
|
||||
Build-Depends: base >=4
|
||||
Extensions: CPP
|
||||
-
|
||||
-Executable extended-tests
|
||||
- Main-Is: HUnitTestExtended.lhs
|
||||
|
@ -50,3 +45,56 @@ It's no use for any library users.
|
|||
- if impl(ghc >= 6.10)
|
||||
- Build-Depends: base >=4
|
||||
- Extensions: CPP
|
||||
-
|
||||
--- Commenting these tests out because Hackage doesn't
|
||||
--- accept packages that specify optimization level,
|
||||
--- which is a key component of these tests.
|
||||
---Executable optimize-0-tests
|
||||
--- Main-Is: HUnitTestOptimize.hs
|
||||
--- HS-Source-Dirs: . tests
|
||||
--- Build-Depends: base<5
|
||||
--- GHC-Options: -O0
|
||||
--- if flag(base4)
|
||||
--- Build-Depends: base >=4
|
||||
--- CPP-Options: -DBASE4
|
||||
--- GHC-Options: -Wall
|
||||
--- else
|
||||
--- Build-Depends: base <4
|
||||
--- if impl(ghc >= 6.10)
|
||||
--- Build-Depends: base >=4
|
||||
--- Extensions: CPP
|
||||
-
|
||||
-Executable optimize-1-tests
|
||||
- Main-Is: HUnitTestOptimize.hs
|
||||
- HS-Source-Dirs: . tests
|
||||
- Build-Depends: base<5
|
||||
--- Commenting out this line because, at the time of writing, -O1 is implied and
|
||||
--- the issue, that tests are optimized out of existence, is exposed at this
|
||||
--- optimization level.
|
||||
--- GHC-Options: -O1
|
||||
- if flag(base4)
|
||||
- Build-Depends: base >=4
|
||||
- CPP-Options: -DBASE4
|
||||
- GHC-Options: -Wall
|
||||
- else
|
||||
- Build-Depends: base <4
|
||||
- if impl(ghc >= 6.10)
|
||||
- Build-Depends: base >=4
|
||||
- Extensions: CPP
|
||||
-
|
||||
--- Commented out for the same reason as optimize-0-tests.
|
||||
---Executable optimize-2-tests
|
||||
--- Main-Is: HUnitTestOptimize.hs
|
||||
--- HS-Source-Dirs: . tests
|
||||
--- Build-Depends: base<5
|
||||
--- GHC-Options: -O2
|
||||
--- if flag(base4)
|
||||
--- Build-Depends: base >=4
|
||||
--- CPP-Options: -DBASE4
|
||||
--- GHC-Options: -Wall
|
||||
--- else
|
||||
--- Build-Depends: base <4
|
||||
--- if impl(ghc >= 6.10)
|
||||
--- Build-Depends: base >=4
|
||||
--- Extensions: CPP
|
||||
-
|
||||
|
|
Loading…
Reference in a new issue