Update Passenger to 4.0.53.
Remove vulnerability refences from TODO (none of which applied). Changelog from 4.0.42 follows... Release 4.0.53 -------------- * Upgraded the preferred Nginx version to 1.6.2. * Improved RVM gemset autodetection. * Fixed some Ruby 2.2 compatibility issues. Release 4.0.52 -------------- * Fixed a null termination bug when autodetecting application types. * Node.js apps can now also trigger the inverse port binding mechanism by passing `'/passenger'` as argument. This was introduced in order to be able to support the Hapi.js framework. * It is now possible to abort Node.js WebSocket connections upon application restart. * Passenger Standalone no longer automatically resolves symlinks in its paths. * `passenger-config system-metrics` no longer crashes when the system clock is set to a time in the past. * `passenger-status`, `passenger-memory-stats`, `passenger-install-apache2-module` and `passenger-install-nginx-module` no longer output ANSI color codes by default when STDOUT is not a TTY. * `passenger-install-nginx-module --auto` is now all that's necessary to make it fully non-interactive. It is no longer necessary to provide all the answers through command line parameters. * Minor contribution by Alessandro Lenzen. Release 4.0.50 -------------- * Fixed a potential heap corruption bug. * Added Union Station support for Rails 4.1. Release 4.0.49 -------------- * Upgraded the preferred Nginx version to 1.6.1. * Fixed a crash that may be triggered by the `passenger_max_requests` feature. * Introduced the `spawn_failed` hook, which is called when an application process fails to spawn. You could use this hook to setup an error notification system. * Fonts, RSS and XML are now gzip-compressed by default in Phusion Passenger Standalone. Thanks to Jacob Elder. * Fixed some user and group information lookup issues. * Fixed some request handling crashes. * Fixed some compilation problems on Gentoo. * Fixed some compilation problems on Solaris Release 4.0.48 -------------- * Fixed a race condition while determining what user an application should be executed as. This bug could lead to applications being run as the wrong user. * [Standalone] Improved autodetection of Rails asset pipeline files. This prevents Standalone from incorrectly setting caching headers on non-asset pipeline files. * Fixed compilation problems on CentOS 5. * Fixed compilation problems on OpenBSD. * Fixed compatibility with Ruby 1.8.5. Release 4.0.47 -------------- * [Enterprise] Fixed a bug in Flying Passenger's `--max-preloader-idle-time` option. Release 4.0.46 -------------- * Further improved Node.js and Socket.io compatibility. * Sticky session cookies have been made more reliable. * Fixed WebSocket upgrade issues on Firefox. * The Python application loader now inserts the application root into `sys.path`. The fact that this was not done previously caused a lot of confusion amongst Python users, who wondered why their `passenger_wsgi.py` could not import any modules from the same directory. * Fixed a compatibility problem with Django, which could cause Django apps to freeze indefinitely. * Logging of application spawning errors has been much improved. Full details about the error, such as environment variables, are saved to a private log file. In the past, these details were only viewable in the browser. This change also fixes a bug on Phusion Passenger Enterprise, where enabling Deployment Error Resistance causes error messages to get lost. * Fixed a regression in Node.js support. When a Node.js app is deployed on a HTTPS host, the `X-Forwarded-Proto` header wasn't set in 4.0.45. * Passenger Standalone no longer, by default, loads shell startup files before loading the application. This is because Passenger Standalone is often invoked from the shell anyway. Indeed, loading shell startup files again can interfere with any environment variables already set in the invoking shell. You can still tell Passenger Standalone to load shell startup files by passing `--load-shell-envvars`. Passenger for Apache and Passenger for Nginx still load shell startup files by default. * Passenger Standalone now works properly when the HOME environment variable isn't set. * Passenger Standalone's `package-runtime` command has been removed. It has been broken for a while and has nowadays been obsolete by our automatic binary generation system. * The `passenger_startup_file` option now also works on Python apps. * If you are a Union Station customer, then Phusion Passenger will now also log application spawning errors to Union Station. This data isn't shown in the Union Station interface yet, but it will be implemented in the future. * Fixed compilation problems on OmniOS and OpenIndiana. * Fixed compilation problems when Nginx is configured with OpenResty. Thanks to Yichun Zhang. * Fixed Nginx HTTP POST failures on ARM platforms. Thanks to nocelic for the fix. * Documentation contributions by Tim Bishop and Tugdual de Kerviler. * Minor Nginx bug fix by Feng Gu. Release 4.0.45 -------------- * Major improvements in Node.js and Meteor compatibility. Older Phusion Passenger versions implemented Node.js support by emulating Node.js' HTTP library. This approach was found to be unsustainable, so we've abandoned that approach and replaced it with a much simpler approach that does not involve emulating the HTTP library. * Introduced support for sticky sessions. Sticky sessions are useful -- or even required -- for apps that store state inside process memory. Prominent examples include SockJS, Socket.io, faye-websocket and Meteor. Sticky sessions are required to make the aforementioned examples work in multi-process scenarios. By introducing sticky sessions support, we've much improved WebSocket support and support for the aforementioned libraries and frameworks. * Due to user demand, GET requests with request bodies are once again supported. Support for these kinds of requests was removed in 4.0.42 in an attempt to increase the strictness and robustness of our request handling code. It has been determined that GET requests with request bodies can be adequately supported without degrading robustness in Phusion Passenger. However, GET requests with both request bodies and WebSocket upgrade headers are unsupported. * Fixed some issues with RVM mixed mode support, issue #1121. * Fixed Passenger Standalone complaining about not finding PassengerHelperAgent during startup. * Fixed various minor issues such as #1190 and #1197. * The download timeout for passenger-install-nginx-module has been increased. Release 4.0.44 -------------- * The issue tracker has now been moved from Google Code to Github. Before version 4.0.44 (May 29 2014, commit 3dd0964c9f4), all issue numbers referred to Google Code. From now on, all issue numbers will refer to Github Issues. * Fixed compilation problems on OS X Lion and OS X Mountain Lion. * On Ruby, fixed `nil` being frozen on accident in some cases. Release 4.0.43 -------------- * Introduced a new command `passenger-config list-instances`, which prints all running Phusion Passenger instances. * Introduced a new command `passenger-config system-metrics, which displays metrics about the system such as the total CPU and memory usage. * Fixed some compilation problems caused by the compiler capability autodetector. * System metrics such as total CPU usage and memory usage, are now sent to [Union Station](https://www.unionstationapp.com) in preparation for future features.
This commit is contained in:
parent
afc80b5a57
commit
efc32553c8
9 changed files with 46 additions and 47 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.6 2014/05/06 13:40:30 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2014/10/29 12:59:17 fhajny Exp $
|
||||
|
||||
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME}
|
||||
|
||||
|
@ -29,6 +29,5 @@ do-install:
|
|||
${INSTALL_MAN} ${WRKSRC}/man/passenger-config.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/passenger-memory-stats.8 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man8
|
||||
${INSTALL_MAN} ${WRKSRC}/man/passenger-status.8 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man8
|
||||
${INSTALL_MAN} ${WRKSRC}/man/passenger-stress-test.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile.common,v 1.10 2014/05/08 13:11:38 fhajny Exp $
|
||||
# $NetBSD: Makefile.common,v 1.11 2014/10/29 12:59:17 fhajny Exp $
|
||||
# used by wip/ap2-passenger/Makefile
|
||||
# used by wip/ruby-passenger/Makefile
|
||||
#
|
||||
DISTNAME= passenger-4.0.42
|
||||
DISTNAME= passenger-4.0.53
|
||||
CATEGORIES= www
|
||||
|
||||
MASTER_SITES= http://s3.amazonaws.com/phusion-passenger/releases/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.8 2014/05/08 13:11:38 fhajny Exp $
|
||||
@comment $NetBSD: PLIST,v 1.9 2014/10/29 12:59:17 fhajny Exp $
|
||||
bin/passenger
|
||||
bin/passenger-config
|
||||
bin/passenger-install-apache2-module
|
||||
|
@ -32,7 +32,6 @@ ${RUBY_VENDORLIB_BASE}/phusion_passenger/active_support3_extensions/init.rb
|
|||
${RUBY_VENDORLIB_BASE}/phusion_passenger/admin_tools.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/admin_tools/memory_stats.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/admin_tools/server_instance.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/analytics_logger.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/apache2/config_options.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/classic_rails/cgi_fixed.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/classic_rails/thread_handler_extension.rb
|
||||
|
@ -41,8 +40,10 @@ ${RUBY_VENDORLIB_BASE}/phusion_passenger/config/about_command.rb
|
|||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/build_native_support_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/detach_process_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/list_instances_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/main.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/restart_app_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/system_metrics_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/utils.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/config/validate_install_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/console_text_template.rb
|
||||
|
@ -87,7 +88,6 @@ ${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/command.rb
|
|||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/config_file.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/help_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/main.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/package_runtime_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/runtime_installer.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/runtime_locator.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/start_command.rb
|
||||
|
@ -95,25 +95,29 @@ ${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/status_command.rb
|
|||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/stop_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/utils.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/standalone/version_command.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/union_station/connection.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/union_station/core.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/union_station/transaction.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/ansi_colors.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/download.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/file_system_watcher.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/hosts_file_parser.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/json.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/lock.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/native_support_utils.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/shellwords.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/tee_input.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/terminal_choice_menu.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/tmpdir.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/tmpio.rb
|
||||
${RUBY_VENDORLIB_BASE}/phusion_passenger/utils/unseekable_socket.rb
|
||||
man/man1/passenger-config.1
|
||||
man/man1/passenger-stress-test.1
|
||||
man/man8/passenger-memory-stats.8
|
||||
man/man8/passenger-status.8
|
||||
sbin/passenger-memory-stats
|
||||
sbin/passenger-status
|
||||
share/doc/passenger/Architectural overview.html
|
||||
share/doc/passenger/Design and Architecture.html
|
||||
share/doc/passenger/Packaging.html
|
||||
share/doc/passenger/Security of user switching support.html
|
||||
share/doc/passenger/Users guide Apache.html
|
||||
|
@ -121,10 +125,12 @@ share/doc/passenger/Users guide Nginx.html
|
|||
share/doc/passenger/Users guide Standalone.html
|
||||
share/doc/passenger/Users guide.html
|
||||
share/doc/passenger/images/by_sa.png
|
||||
share/doc/passenger/images/code_walkthrough.jpg
|
||||
share/doc/passenger/images/direct_spawning.png
|
||||
share/doc/passenger/images/direct_spawning.svg
|
||||
share/doc/passenger/images/glyphicons-halflings-white.png
|
||||
share/doc/passenger/images/glyphicons-halflings.png
|
||||
share/doc/passenger/images/helper_agent_core_architecture.png
|
||||
share/doc/passenger/images/icons/README
|
||||
share/doc/passenger/images/icons/callouts/1.png
|
||||
share/doc/passenger/images/icons/callouts/10.png
|
||||
|
@ -154,14 +160,17 @@ share/doc/passenger/images/icons/warning.png
|
|||
share/doc/passenger/images/many_web_framework_protocols.png
|
||||
share/doc/passenger/images/passenger_architecture.png
|
||||
share/doc/passenger/images/passenger_architecture.svg
|
||||
share/doc/passenger/images/passenger_architecture_overview.png
|
||||
share/doc/passenger/images/passenger_nodejs_architecture.svg
|
||||
share/doc/passenger/images/phusion_banner.png
|
||||
share/doc/passenger/images/phusion_banner_small.png
|
||||
share/doc/passenger/images/rack.png
|
||||
share/doc/passenger/images/smart.png
|
||||
share/doc/passenger/images/smart.svg
|
||||
share/doc/passenger/images/smart_spawning.png
|
||||
share/doc/passenger/images/smart_spawning.svg
|
||||
share/doc/passenger/images/spawn_server_architecture.png
|
||||
share/doc/passenger/images/spawn_server_architecture.svg
|
||||
share/doc/passenger/images/spawning_preparation_work.png
|
||||
share/doc/passenger/images/startup_sequence.png
|
||||
share/doc/passenger/images/typical_isolated_web_application.png
|
||||
share/doc/passenger/images/typical_isolated_web_application.svg
|
||||
share/passenger/helper-scripts/backtrace-sanitizer.rb
|
||||
|
@ -173,9 +182,7 @@ share/passenger/helper-scripts/node-loader.js
|
|||
share/passenger/helper-scripts/prespawn
|
||||
share/passenger/helper-scripts/rack-loader.rb
|
||||
share/passenger/helper-scripts/rack-preloader.rb
|
||||
share/passenger/helper-scripts/system-memory-stats.py
|
||||
share/passenger/helper-scripts/wsgi-loader.py
|
||||
share/passenger/helper-scripts/wsgi-preloader.py
|
||||
share/passenger/include/common/AgentsStarter.h
|
||||
share/passenger/include/common/ApplicationPool2/AppTypes.h
|
||||
share/passenger/include/common/Constants.h
|
||||
|
@ -202,10 +209,7 @@ share/passenger/ngx_http_passenger_module/StaticContentHandler.h
|
|||
share/passenger/ngx_http_passenger_module/config
|
||||
share/passenger/ngx_http_passenger_module/ngx_http_passenger_module.c
|
||||
share/passenger/ngx_http_passenger_module/ngx_http_passenger_module.h
|
||||
share/passenger/node/phusion_passenger/httplib_emulation.js
|
||||
share/passenger/node/phusion_passenger/line_reader.js
|
||||
share/passenger/node/phusion_passenger/request_handler.js
|
||||
share/passenger/node/phusion_passenger/session_protocol_parser.js
|
||||
share/passenger/oss-binaries.phusionpassenger.com.crt
|
||||
share/passenger/release.txt
|
||||
share/passenger/ruby_extension_source/extconf.rb
|
||||
|
|
|
@ -1,4 +0,0 @@
|
|||
Resolve security issues:
|
||||
http://secunia.com/advisories/56560/
|
||||
http://secunia.com/advisories/56617/
|
||||
http://secunia.com/advisories/53561/
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.7 2014/05/08 13:11:38 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.8 2014/10/29 12:59:17 fhajny Exp $
|
||||
|
||||
SHA1 (passenger-4.0.42.tar.gz) = cdc20111ed0bc01e13c6e56f6a6febf54a55b476
|
||||
RMD160 (passenger-4.0.42.tar.gz) = 04e3178f9b4c90aa0c01f669d6549160cfb23130
|
||||
Size (passenger-4.0.42.tar.gz) = 3910485 bytes
|
||||
SHA1 (patch-build__agents.rb) = a8ab809327eaee4f0163e6e67470502f6e653212
|
||||
SHA1 (patch-build__packaging.rb) = e52ba6133a1edd42b430bcb94eec4f80a981a098
|
||||
SHA1 (patch-build_common__library.rb) = 97ee1c9658ea64c35fbca03f7daa763ae6fc2e9b
|
||||
SHA1 (patch-lib__phusion_passenger.rb) = 25547c50100cc64eb0797a17c7d9fc8abc54dcd9
|
||||
SHA1 (passenger-4.0.53.tar.gz) = dce2a83e66abb1fac1cd3cdc2ef284f098bc9390
|
||||
RMD160 (passenger-4.0.53.tar.gz) = 5c9004866bce65adc17ee3381210dbec1460568a
|
||||
Size (passenger-4.0.53.tar.gz) = 4447609 bytes
|
||||
SHA1 (patch-build__agents.rb) = 82c7263c8aac1915a50fedd2fe7d03257b1bfd47
|
||||
SHA1 (patch-build__packaging.rb) = 83e7246f7a28b384cf697829b32fc5c3a09f0358
|
||||
SHA1 (patch-build_common__library.rb) = b0e04a8656d6cbf1e8b7a4402e0af1f660a8140c
|
||||
SHA1 (patch-lib__phusion_passenger.rb) = 681242e1e785e8b2d34dac2e2dde3f3f8c56704e
|
||||
SHA1 (patch-lib_phusion__passenger_packaging.rb) = 1a263b387f72aa9e4bc623afac9694253350c54a
|
||||
SHA1 (patch-lib_phusion__passenger_platform__info_cxx__portability.rb) = 1921aa9a836793caad650bafe483ae214bbc247a
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-build__agents.rb,v 1.3 2014/05/06 13:40:31 fhajny Exp $
|
||||
$NetBSD: patch-build__agents.rb,v 1.4 2014/10/29 12:59:17 fhajny Exp $
|
||||
|
||||
Add a simple target to skip the Apache/Nginx binaries.
|
||||
--- build/agents.rb.orig 2013-10-26 22:00:00.000000000 +0000
|
||||
+++ build/agents.rb
|
||||
@@ -184,3 +184,13 @@ end
|
||||
@@ -188,3 +188,13 @@ end
|
||||
task 'common:clean' do
|
||||
sh "rm -rf #{AGENT_OUTPUT_DIR}"
|
||||
end
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-build__packaging.rb,v 1.3 2014/05/06 13:40:31 fhajny Exp $
|
||||
$NetBSD: patch-build__packaging.rb,v 1.4 2014/10/29 12:59:17 fhajny Exp $
|
||||
|
||||
Mangle faceroot support for our purposes.
|
||||
--- build/packaging.rb.orig 2013-10-26 22:00:00.000000000 +0000
|
||||
+++ build/packaging.rb
|
||||
@@ -396,7 +396,7 @@ def change_shebang(filename, value)
|
||||
@@ -477,7 +477,7 @@ def change_shebang(filename, value)
|
||||
end
|
||||
|
||||
desc "Create a fakeroot, useful for building native packages"
|
||||
|
@ -12,19 +12,19 @@ Mangle faceroot support for our purposes.
|
|||
require 'rbconfig'
|
||||
require 'fileutils'
|
||||
include RbConfig
|
||||
@@ -426,7 +426,7 @@ task :fakeroot => [:apache2, :nginx, :do
|
||||
@@ -507,7 +507,7 @@ task :fakeroot => [:apache2, :nginx, :do
|
||||
psg_ruby_extension_source_dir = "#{fs_datadir}/#{GLOBAL_NAMESPACE_DIRNAME}/ruby_extension_source"
|
||||
psg_nginx_module_source_dir = "#{fs_datadir}/#{GLOBAL_NAMESPACE_DIRNAME}/ngx_http_passenger_module"
|
||||
|
||||
|
||||
- fakeroot = "pkg/fakeroot"
|
||||
+ fakeroot = ENV['DESTDIR'].nil? ? '' : ENV['DESTDIR']
|
||||
fake_rubylibdir = "#{fakeroot}#{psg_rubylibdir}"
|
||||
fake_nodelibdir = "#{fakeroot}#{psg_nodelibdir}"
|
||||
fake_libdir = "#{fakeroot}#{psg_libdir}"
|
||||
@@ -529,10 +529,6 @@ task :fakeroot => [:apache2, :nginx, :do
|
||||
@@ -610,10 +610,6 @@ task :fakeroot => [:apache2, :nginx, :do
|
||||
end
|
||||
end
|
||||
|
||||
|
||||
- # Apache 2 module
|
||||
- sh "mkdir -p #{File.dirname(fake_apache2_module_path)}"
|
||||
- sh "cp #{APACHE2_MODULE} #{fake_apache2_module_path}"
|
||||
|
@ -32,7 +32,7 @@ Mangle faceroot support for our purposes.
|
|||
# Ruby extension sources
|
||||
sh "mkdir -p #{fake_ruby_extension_source_dir}"
|
||||
sh "cp -R #{PhusionPassenger.ruby_extension_source_dir}/* #{fake_ruby_extension_source_dir}"
|
||||
@@ -564,5 +560,5 @@ task :fakeroot => [:apache2, :nginx, :do
|
||||
@@ -645,5 +641,5 @@ task :fakeroot => [:apache2, :nginx, :do
|
||||
end
|
||||
end
|
||||
|
||||
|
|
|
@ -1,16 +1,16 @@
|
|||
$NetBSD: patch-build_common__library.rb,v 1.2 2014/05/06 13:40:31 fhajny Exp $
|
||||
$NetBSD: patch-build_common__library.rb,v 1.3 2014/10/29 12:59:17 fhajny Exp $
|
||||
|
||||
Fix pkgsrc libeio/libev support.
|
||||
--- build/common_library.rb.orig 2013-10-26 22:00:00.000000000 +0000
|
||||
+++ build/common_library.rb
|
||||
@@ -151,8 +151,8 @@ if USE_VENDORED_LIBEV
|
||||
|
||||
|
||||
task :clean => 'libev:clean'
|
||||
else
|
||||
- LIBEV_CFLAGS = string_option('LIBEV_CFLAGS', '-I/usr/include/libev')
|
||||
- LIBEV_LIBS = string_option('LIBEV_LIBS', '-lev')
|
||||
+ LIBEV_CFLAGS = string_option('LIBEV_CFLAGS', '-I/opt/local/include/ev')
|
||||
+ LIBEV_LIBS = string_option('LIBEV_LIBS', '-L/opt/local/lib/ev -Wl,-R/opt/local/lib/ev -lev')
|
||||
+ LIBEV_CFLAGS = string_option('LIBEV_CFLAGS', '-I@PREFIX@/include/ev')
|
||||
+ LIBEV_LIBS = string_option('LIBEV_LIBS', '-L@PREFIX@/lib/ev @COMPILER_RPATH_FLAG@@PREFIX@/lib/ev -lev')
|
||||
LIBEV_TARGET = nil
|
||||
task :libev # do nothing
|
||||
end
|
||||
|
@ -20,8 +20,8 @@ Fix pkgsrc libeio/libev support.
|
|||
else
|
||||
- LIBEIO_CFLAGS = string_option('LIBEIO_CFLAGS', '-I/usr/include/libeio')
|
||||
- LIBEIO_LIBS = string_option('LIBEIO_LIBS', '-leio')
|
||||
+ LIBEIO_CFLAGS = string_option('LIBEIO_CFLAGS', '-I/opt/local/include/eio')
|
||||
+ LIBEIO_LIBS = string_option('LIBEIO_LIBS', '-L/opt/local/lib/eio -Wl,-R/opt/local/lib/eio -leio')
|
||||
+ LIBEIO_CFLAGS = string_option('LIBEIO_CFLAGS', '-I@PREFIX@/include/eio')
|
||||
+ LIBEIO_LIBS = string_option('LIBEIO_LIBS', '-L@PREFIX@/lib/eio @COMPILER_RPATH_FLAG@@PREFIX@/lib/eio -leio')
|
||||
LIBEIO_TARGET = nil
|
||||
task :libeio # do nothing
|
||||
end
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-lib__phusion_passenger.rb,v 1.3 2014/05/06 13:40:31 fhajny Exp $
|
||||
$NetBSD: patch-lib__phusion_passenger.rb,v 1.4 2014/10/29 12:59:17 fhajny Exp $
|
||||
|
||||
Fix default paths.
|
||||
--- lib/phusion_passenger.rb.orig 2013-10-26 22:00:00.000000000 +0000
|
||||
+++ lib/phusion_passenger.rb
|
||||
@@ -51,8 +51,7 @@ module PhusionPassenger
|
||||
|
||||
|
||||
# Directories in which to look for plugins.
|
||||
PLUGIN_DIRS = [
|
||||
- "/usr/share/#{GLOBAL_NAMESPACE_DIRNAME}/plugins",
|
||||
|
@ -12,8 +12,8 @@ Fix default paths.
|
|||
+ "@PREFIX@/#{GLOBAL_NAMESPACE_DIRNAME}/plugins",
|
||||
"~/#{USER_NAMESPACE_DIRNAME}/plugins"
|
||||
]
|
||||
|
||||
@@ -254,7 +253,7 @@ private
|
||||
|
||||
@@ -258,7 +257,7 @@ private
|
||||
return filename if File.exist?(filename)
|
||||
end
|
||||
|
||||
|
|
Loading…
Reference in a new issue