Added proplib.

This commit is contained in:
Aleksej Lebedev 2015-04-19 17:56:54 +00:00 committed by Thomas Klausner
parent a2840fe707
commit f58f099880
6 changed files with 65 additions and 0 deletions

4
proplib/DESCR Normal file
View file

@ -0,0 +1,4 @@
The proplib library provides an abstract interface for creating and
manipulating property lists in C. Property lists have object types for boolean
values, opaque data, numbers, and strings. Structure is provided by the array
and dictionary collection types.

19
proplib/Makefile Normal file
View file

@ -0,0 +1,19 @@
# $NetBSD: Makefile,v 1.1 2015/04/19 17:56:54 realzhtw Exp $
DISTNAME= proplib-0.6.3
CATEGORIES= devel
MASTER_SITES= http://portableproplib.googlecode.com/files/
EXTRACT_SUFX= .tar.xz
MAINTAINER= root@zta.lk
HOMEPAGE= http://code.google.com/p/portableproplib/
COMMENT= Portable Property container object library
LICENSE= modified-bsd
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= pkg-config
PKGCONFIG_OVERRIDE+= proplib.pc.in
.include "../../mk/bsd.pkg.mk"

23
proplib/PLIST Normal file
View file

@ -0,0 +1,23 @@
@comment $NetBSD: PLIST,v 1.1 2015/04/19 17:56:54 realzhtw Exp $
include/prop/prop_array.h
include/prop/prop_bool.h
include/prop/prop_data.h
include/prop/prop_dictionary.h
include/prop/prop_ingest.h
include/prop/prop_number.h
include/prop/prop_object.h
include/prop/prop_string.h
include/prop/proplib.h
lib/libprop.la
lib/pkgconfig/proplib.pc
man/man3/prop_array.3
man/man3/prop_array_util.3
man/man3/prop_bool.3
man/man3/prop_data.3
man/man3/prop_dictionary.3
man/man3/prop_dictionary_util.3
man/man3/prop_ingest.3
man/man3/prop_number.3
man/man3/prop_object.3
man/man3/prop_string.3
man/man3/proplib.3

6
proplib/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2015/04/19 17:56:54 realzhtw Exp $
SHA1 (proplib-0.6.3.tar.xz) = 8454c4531aa00bb4e5f24dda7999160800cc4cfe
RMD160 (proplib-0.6.3.tar.xz) = a8bb669b9e4b7d84f6bec6ffba46a18323a5eb3d
Size (proplib-0.6.3.tar.xz) = 266012 bytes
SHA1 (patch-src_prop__object.c) = 7e9600d9f214ebfd644bd1b3505f8a9a36634f0e

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_prop__object.c,v 1.1 2015/04/19 17:56:54 realzhtw Exp $
--- src/prop_object.c.orig 2015-04-15 21:41:29.000000000 +0000
+++ src/prop_object.c
@@ -834,7 +834,7 @@ _prop_object_externalize_write_file(cons
return (false);
}
#else
- otname = strncat(tname, "/.plistXXXXXX", sizeof(tname));
+ otname = strncat(tname, "/.plistXXXXXX", sizeof(tname) - 1);
if (sizeof(*otname) >= sizeof(tname)) {
errno = ENAMETOOLONG;