Fixed the LD_LIBRARY_PATH issue.
Thanks to Thomas Klausner for the help.
This commit is contained in:
parent
7ddb921417
commit
f590c45d71
3 changed files with 12 additions and 4 deletions
|
@ -1,2 +1 @@
|
|||
- Fix Python, Ruby and sid options
|
||||
- Have to set LD_LIBRARY_PATH to $PREFIX/lib.
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2005/09/12 21:19:17 leonardschmidt Exp $
|
||||
$NetBSD: distinfo,v 1.2 2005/09/13 15:05:13 leonardschmidt Exp $
|
||||
|
||||
SHA1 (xmms2-0.1DR2.2.tar.gz) = 913a7bf908eb6164ef4b8920f6e239f34fb2d45c
|
||||
RMD160 (xmms2-0.1DR2.2.tar.gz) = 56f68df7f97fcd93e756ddd4c8dd3db02b0246c1
|
||||
Size (xmms2-0.1DR2.2.tar.gz) = 672961 bytes
|
||||
SHA1 (patch-aa) = e523563453f298b6982134ab478e0c536509b945
|
||||
SHA1 (patch-aa) = 964a3bc80f2d1ec52f1b1365925a9e9ab299d255
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/09/12 21:19:17 leonardschmidt Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2005/09/13 15:05:14 leonardschmidt Exp $
|
||||
|
||||
--- SConstruct.orig 2005-09-06 19:06:19.000000000 +0000
|
||||
+++ SConstruct
|
||||
|
@ -15,3 +15,12 @@ $NetBSD: patch-aa,v 1.1.1.1 2005/09/12 21:19:17 leonardschmidt Exp $
|
|||
if sys.platform == 'darwin':
|
||||
default_cpppath = ['/sw/lib']
|
||||
else:
|
||||
@@ -44,7 +44,7 @@ opts = Options("options.cache")
|
||||
opts.Add('CC', 'C compiler to use')
|
||||
opts.Add('CXX', 'C++ compiler to use')
|
||||
opts.Add('LD', 'Linker to use')
|
||||
-opts.Add(SimpleListOption('LINKFLAGS', 'Linker flags', []))
|
||||
+opts.Add(SimpleListOption('LINKFLAGS', 'Linker flags', '-Wl,-R$PREFIX/lib'))
|
||||
opts.Add(SimpleListOption('LIBPATH', 'Path to libs', []))
|
||||
opts.Add(SimpleListOption('CPPPATH', 'path to include files', default_cpppath))
|
||||
opts.Add(SimpleListOption('CXXFLAGS', 'C++ compilerflags', default_cxxflags))
|
||||
|
|
Loading…
Reference in a new issue