Add editors/emacs/patches/patch-az. Commit message was:

revision 1.14
date: 2006/04/05 22:22:16;  author: markd;  state: Exp;  lines: +11 -169
Pass the correct sized argument to sbrk() when trying to reduce the break
so that on 64bit systems it is actually a negative number, not a very
large positive one.  Should fix PR pkg/29351.
Thanks to Martijn van Buul for giving me access to an amd64 box so I
could track this down.  Bump PKGREVISION.


Don't bump PKGREVISION here, because it's a daily CVS snapshot anyway.
This commit is contained in:
Thomas Klausner 2006-10-27 18:04:26 +00:00
parent d6f16249f3
commit f82f888cf8
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.3 2006/10/17 07:23:49 thomasklausner Exp $
$NetBSD: distinfo,v 1.4 2006/10/27 18:04:26 thomasklausner Exp $
SHA1 (patch-aa) = 8a6a32ca7804794bd0216e4fd8757df1344a02fe
SHA1 (patch-ab) = 7f831a9a3c3c6c968b20eaa4fb55f3592545e15e
SHA1 (patch-ac) = 852d18d70601d875fd2f419b8e62941807aebc49

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2006/10/27 18:04:26 thomasklausner Exp $
--- src/ralloc.c.orig 2006-02-06 15:23:21.000000000 +0000
+++ src/ralloc.c
@@ -330,7 +330,7 @@ static void
relinquish ()
{
register heap_ptr h;
- int excess = 0;
+ long excess = 0;
/* Add the amount of space beyond break_value
in all heaps which have extend beyond break_value at all. */