Import of ldap-module for MultiSync.

This commit is contained in:
Ola Eriksson 2005-01-09 09:30:29 +00:00 committed by Thomas Klausner
parent 20dc7b9052
commit f9b4c29160
7 changed files with 95 additions and 0 deletions

6
multisync-ldap/DESCR Normal file
View file

@ -0,0 +1,6 @@
Module for MultiSync that enables synchronization with LDAP servers.
MultiSync is a free modular program to synchronize calendars, addressbooks
and other PIM data between programs on your computer and other computers,
mobile devices, PDAs or cell phones. MultiSync works on any Gnome platform,
such as Linux.

36
multisync-ldap/Makefile Normal file
View file

@ -0,0 +1,36 @@
# $NetBSD: Makefile,v 1.1 2005/01/09 09:30:29 mreriksson Exp $
#
PKGNAME= multisync-ldap-0.82
COMMENT= LDAP module for Multisync
WRKSRC= ${WRKDIR}/multisync-0.82/plugins/ldap_plugin/
DEPENDS+= multisync>=0.82:../../wip/multisync
BUILD_DEPENDS+= libtool-base>=1.5.10:../../devel/libtool-base
pre-configure:
cd work/multisync-${PKGVERSION} && \
${ACLOCAL} && \
${AUTOHEADER} && \
${AUTOCONF} && \
${AUTOMAKE} -acf
cd ${WRKSRC} && \
${ACLOCAL} && \
${PREFIX}/bin/libtoolize --force --copy && \
${AUTOHEADER} && \
${AUTOCONF} && \
${AUTOMAKE} -acf
cd work/multisync-${PKGVERSION} && \
./configure ${CONFIGURE_ENV} ${CONFIGURE_ARGS}
do-install:
cd ${WRKSRC} && \
${MAKE} install
.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../databases/openldap/buildlink3.mk"
.include "../../security/cyrus-sasl/buildlink3.mk"
.include "../../wip/multisync/Makefile.common"

2
multisync-ldap/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1 2005/01/09 09:30:29 mreriksson Exp $
lib/multisync/libldap_plugin.la

7
multisync-ldap/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2005/01/09 09:30:29 mreriksson Exp $
SHA1 (multisync-0.82-1.tar.bz2) = 2960618ff1ebf62513854394f0b397c5e2066c62
Size (multisync-0.82-1.tar.bz2) = 1432107 bytes
SHA1 (patch-aa) = aabc027e8da80ab93a52a2da2a0c42493a59efd9
SHA1 (patch-ab) = eff9d18965363b7bf3fc97cc38e85869e49d0c6c
SHA1 (patch-ac) = 6a77a992795a6f7eb8f1e90ebd5df6b9e8f93145

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2005/01/09 09:30:29 mreriksson Exp $
--- Makefile.am.orig 2004-04-12 23:03:13.000000000 +0200
+++ Makefile.am
@@ -9,7 +9,7 @@ EXTRA_DIST = \
install-data-local:
@$(NORMAL_INSTALL)
if test -d $(srcdir)/pixmaps; then \
- $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps/$(PACKAGE); \
+ $(install-sh) -d $(DESTDIR)$(datadir)/pixmaps/$(PACKAGE); \
for pixmap in $(srcdir)/pixmaps/*; do \
if test -f $$pixmap; then \
$(INSTALL_DATA) $$pixmap $(DESTDIR)$(datadir)/pixmaps/$(PACKAGE); \

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ab,v 1.1 2005/01/09 09:30:29 mreriksson Exp $
--- configure.in.orig 2004-04-12 23:03:13.000000000 +0200
+++ configure.in
@@ -17,7 +17,7 @@ AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_CHECK_LIB(ldap,ldap_init,,AC_MSG_ERROR(You must have openldap libraries installed.))
-AC_CHECK_HEADER(sasl/sasl.h,, AC_MSG_ERROR(You must have the libsasl2-dev package installed))
+AC_CHECK_HEADER(sasl.h,, AC_MSG_ERROR(You must have the libsasl2-dev package installed))
dnl Info for the RPM
MULTISYNC_TOP="../.."
@@ -29,5 +29,5 @@ AC_SUBST(MULTISYNC_VERSION)
AC_OUTPUT([
Makefile
src/Makefile
-${MULTISYNC_TOP}/specs/multisync-ldap.spec
+../../specs/multisync-ldap.spec
])

View file

@ -0,0 +1,11 @@
$NetBSD: patch-ac,v 1.1 2005/01/09 09:30:29 mreriksson Exp $
--- src/ldap.c.orig 2005-01-09 10:16:58.000000000 +0100
+++ src/ldap.c
@@ -1,5 +1,5 @@
#include "ldap_plugin.h"
-#include <sasl/sasl.h>
+#include <sasl.h>
int lutil_sasl_interact(
LDAP *ld,