foremost has been moved to pkgsrc.

This commit is contained in:
Min Sik Kim 2007-01-26 16:38:07 +00:00 committed by Thomas Klausner
parent 94a693f653
commit fa3c991a09
9 changed files with 1 additions and 124 deletions

View file

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.2493 2007/01/25 23:35:42 thomasklausner Exp $
# $Id: Makefile,v 1.2494 2007/01/26 16:38:07 minskim Exp $
#
COMMENT= WIP pkgsrc packages
@ -285,7 +285,6 @@ SUBDIR+= fnord
SUBDIR+= font-alias
SUBDIR+= foomatic-db
SUBDIR+= foomatic-db-engine
SUBDIR+= foremost
SUBDIR+= fprobe
SUBDIR+= fragrouter
SUBDIR+= freedict-tools-xsl

View file

@ -1,5 +0,0 @@
Foremost is a program to recover files based on their headers and footers.
Foremost can work on image files, such as those generated by dd, Safeback,
Encase, etc, or directly on a drive. The headers and footers are specified
by a configuration file, so you can pick and choose which headers you want
to look for.

View file

@ -1,17 +0,0 @@
# $NetBSD: Makefile,v 1.4 2007/01/26 16:32:38 minskim Exp $
DISTNAME= foremost-1.3
CATEGORIES= sysutils
MASTER_SITES= http://foremost.sourceforge.net/pkg/
MAINTAINER= lkundrak@skosi.org
HOMEPAGE= http://foremost.sourceforge.net/
COMMENT= Recover various formats of files using typical data structures
EGDIR= ${PREFIX}/share/examples/foremost
CONF_FILES= ${EGDIR}/foremost.conf ${PKG_SYSCONFDIR}/foremost.conf
pre-install:
${INSTALL_DATA_DIR} ${EGDIR}
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2007/01/26 08:11:41 lkundrak Exp $
bin/foremost
man/man1/foremost.1
share/examples/foremost/foremost.conf
@dirrm share/examples/foremost

View file

View file

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.3 2007/01/26 14:28:42 lkundrak Exp $
SHA1 (foremost-1.3.tar.gz) = 675886fc4806ad156cb40d614aa80fead0b391d8
RMD160 (foremost-1.3.tar.gz) = 7b92d249ae105db3ad8c92a697ee5f314b280f8f
Size (foremost-1.3.tar.gz) = 50488 bytes
SHA1 (patch-aa) = 727975dedae9261a4088083931eb709771873062
SHA1 (patch-ab) = c56e70d64e30c0867beb3fd3ad40336cb6364c31
SHA1 (patch-ac) = 7832701bafa1336fda2b4e08ef38bca8ddf29f8d

View file

@ -1,17 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2006/02/09 15:33:04 lkundrak Exp $
--- Makefile.orig 2005-11-05 18:12:37.000000000 +0100
+++ Makefile
@@ -24,9 +24,9 @@ MAN_PAGES = $(NAME).1
RAW_FLAGS += -DVERSION=\"$(VERSION)\"
# Where we get installed
-BIN = /usr/local/bin
-MAN = /usr/local/man/man1
-CONF= /usr/local/etc
+BIN = $(PREFIX)/bin
+MAN = $(PREFIX)/$(PKGMANDIR)/man1
+CONF= $(PKG_SYSCONFDIR)
# Setup for compiling and cross-compiling for Windows
# The CR_ prefix refers to cross compiling from OSX to Windows
CR_CC = $(CR_BASE)/gcc

View file

@ -1,52 +0,0 @@
$NetBSD: patch-ab,v 1.2 2007/01/26 14:28:42 lkundrak Exp $
--- Makefile.orig 2007-01-26 15:10:20.000000000 +0100
+++ Makefile
@@ -10,7 +10,7 @@ SYS := $(shell uname -s | tr -d "[0-9]"
# You can cross compile this program for Win32 using Linux and the
# MinGW compiler. See the README for details. If you have already
# installed MinGW, put the location ($PREFIX) here:
-CR_BASE = /usr/local/cross-tools/i386-mingw32msvc/bin
+CR_BASE = $(PREFIX)/cross-tools/i386-mingw32msvc/bin
# You shouldn't need to change anything below this line
#---------------------------------------------------------------------
@@ -27,6 +27,11 @@ RAW_FLAGS += -DVERSION=\"$(VERSION)\"
BIN = $(PREFIX)/bin
MAN = $(PREFIX)/$(PKGMANDIR)/man1
CONF= $(PKG_SYSCONFDIR)
+SAMPLES = $(PREFIX)/share/examples/foremost
+
+# Tell it to config.c
+RAW_FLAGS += -DCONFDIR=\"$(CONF)\"
+
# Setup for compiling and cross-compiling for Windows
# The CR_ prefix refers to cross compiling from OSX to Windows
CR_CC = $(CR_BASE)/gcc
@@ -120,10 +125,11 @@ foremost: $(OBJ)
install: goals
install -m 755 $(NAME) $(BIN)
install -m 444 $(MAN_PAGES) $(MAN)
- install -m 444 foremost.conf $(CONF)
-macinstall: BIN = /usr/local/bin/
-macinstall: MAN = /usr/share/man/man1/
-macinstall: CONF = /usr/local/etc/
+ install -m 444 foremost.conf $(SAMPLES)
+macinstall: BIN = $(PREFIX)/bin/
+macinstall: MAN = $(PREFIX)/$(PKGMANDIR)/man1/
+macinstall: CONF = $(PREFIX)/etc/
+macinstall: SAMPLES = $(PREFIX)/share/examples/foremost
macinstall: mac install
@@ -131,8 +137,8 @@ uninstall:
rm -f -- $(BIN)/{$(RM_GOALS)}
rm -f -- $(MAN)/{$(RM_DOCS)}
-macuninstall: BIN = /usr/bin
-macuninstall: MAN = /usr/share/man/man1
+macuninstall: BIN = $(PREFIX)/bin
+macuninstall: MAN = $(PREFIX)/$(PKGMANDIR)/man1
macuninstall: uninstall
#---------------------------------------------------------------------

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ac,v 1.2 2007/01/26 14:28:42 lkundrak Exp $
--- config.c.orig 2006-08-26 09:02:14.000000000 +0200
+++ config.c
@@ -285,11 +285,8 @@ int load_config_file(f_state *s)
/*Can't find a conf in the current directory
* So lets try the /usr/local/etc*/
-#ifdef __WIN32
- set_config_file(s, "/Program Files/foremost/foremost.conf");
-#else
- set_config_file(s, "/usr/local/etc/foremost.conf");
-#endif
+
+ set_config_file(s,CONFDIR "/" DEFAULT_CONFIG_FILE);
if ((f = fopen(get_config_file(s), "r")) == NULL)
{
print_error(s, get_config_file(s), strerror(errno));