Builds now.

This commit is contained in:
Mark Davies 2007-12-16 19:49:56 +00:00 committed by Thomas Klausner
parent fd88477445
commit fd2b741b34
8 changed files with 3221 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1.1.1 2007/12/12 03:50:54 mwdavies Exp $
# $NetBSD: Makefile,v 1.2 2007/12/16 19:49:56 mwdavies Exp $
DISTNAME= kdeedu-${_KDE_VERSION}
CATEGORIES= misc
@ -6,10 +6,17 @@ COMMENT= Edu{tainment,cation} tools for the KDE integrated X11 desktop
.include "../../wip/kde4/Makefile.kde4"
BUILD_MAKE_FLAGS+= VERBOSE=1
# BUILD_MAKE_FLAGS+= VERBOSE=1
CMAKE_ARGS+= -DBUILD_kmplot:BOOL=OFF
USE_GNU_READLINE= yes
BROKEN_READLINE_DETECTION= yes
.include "../../wip/kde4/kde4.mk"
.include "../../devel/libusb/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../wip/kdelibs4/buildlink3.mk"
.include "../../wip/kdebase-runtime4/buildlink3.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,6 +1,11 @@
$NetBSD: distinfo,v 1.1.1.1 2007/12/12 03:50:54 mwdavies Exp $
$NetBSD: distinfo,v 1.2 2007/12/16 19:49:57 mwdavies Exp $
SHA1 (kdeedu-3.97.0.tar.bz2) = 611fcdb1bd65c2b7cc36394241874d407db2b091
RMD160 (kdeedu-3.97.0.tar.bz2) = f225718aa74edf94585e675201ac13dae9b6b121
Size (kdeedu-3.97.0.tar.bz2) = 42027415 bytes
SHA1 (patch-aa) = 5e2f12e2c70e438524ace2d238c9119dd36695ed
SHA1 (patch-ab) = ec20cce005849560bd4655b53b75a359d15dfe50
SHA1 (patch-ac) = 139d60ef68bc4a9af6d2c0ec2076ddd432cd6576
SHA1 (patch-ad) = 9d45fe9950c25c481b3c8562986ae7d9e9bb58b2
SHA1 (patch-ae) = 412adfe31664db087e66ce73428ee775dff858d3
SHA1 (patch-af) = 0a8691662dee0950102bdd5c688a545a98834226

30
kdeedu4/patches/patch-ab Normal file
View file

@ -0,0 +1,30 @@
$NetBSD: patch-ab,v 1.1 2007/12/16 19:49:57 mwdavies Exp $
--- kmplot/kmplot/parser.cpp.orig 2007-12-14 23:10:57.000000000 +1300
+++ kmplot/kmplot/parser.cpp
@@ -100,9 +100,13 @@ ScalarFunction Parser::scalarFunctions[
{"floor", 0, floor}, // round down to nearest integer
{"ceil", 0, ceil}, // round up to nearest integer
{"round", 0, round}, // round to nearest integer
+#ifndef __NetBSD__
{"gamma", 0, tgamma}, // gamma function
+#endif
{"lgamma", 0, lgamma}, // log-gamma function
+#ifndef __NetBSD__
{"factorial", 0, factorial}, // factorial
+#endif
// legendre
{"P_0", 0, legendre0}, // lengedre polynomial (n=0)
@@ -1333,9 +1337,11 @@ double larcsin(double x) {
double larctan(double x) {
return atan(x) / Parser::radiansPerAngleUnit();
}
+#ifndef __NetBSD__
double factorial( double x ) {
return tgamma(x+1);
}
+#endif
double legendre0( double ) {
return 1.0;
}

13
kdeedu4/patches/patch-ac Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2007/12/16 19:49:57 mwdavies Exp $
--- kstars/kstars/htmesh/SpatialGeneral.h.orig 2007-12-15 01:12:26.000000000 +1300
+++ kstars/kstars/htmesh/SpatialGeneral.h
@@ -80,7 +80,7 @@ typedef unsigned long long uint64;
// emulate the standard bool type where not supported by compiler
-# if !defined(SXGENERAL_H) && !defined(__sgi) && !defined(__linux__) && !defined(_WIN32) && !defined(__FreeBSD__)
+# if !defined(SXGENERAL_H) && !defined(__sgi) && !defined(__linux__) && !defined(_WIN32) && !defined(__FreeBSD__) && !defined(__NetBSD__)
# ifdef __unix__
/*
* The following ifndef must ALWAYS be present since C++ may use

13
kdeedu4/patches/patch-ad Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2007/12/16 19:49:57 mwdavies Exp $
--- kstars/kstars/htmesh/SkipListElement.h.orig 2007-12-15 01:17:43.000000000 +1300
+++ kstars/kstars/htmesh/SkipListElement.h
@@ -24,7 +24,7 @@
#ifdef _WIN32
#define KEY_MAX _I64_MAX
#else
-# ifdef __FreeBSD__
+# if defined(__FreeBSD__) || defined(__NetBSD__)
# define KEY_MAX LLONG_MAX
# else
# define KEY_MAX LONG_LONG_MAX

16
kdeedu4/patches/patch-ae Normal file
View file

@ -0,0 +1,16 @@
$NetBSD: patch-ae,v 1.1 2007/12/16 19:49:57 mwdavies Exp $
--- kalgebra/src/graph2d.cpp.orig 2007-12-15 07:19:44.000000000 +1300
+++ kalgebra/src/graph2d.cpp
@@ -86,6 +86,11 @@ void Graph2D::drawAxes(QPainter *f, Axe
//EO write coords
}
+#ifdef __NetBSD__
+#define fmin(a,b) ((a)<(b)?(a):(b))
+#define fmax(a,b) ((a)>(b)?(a):(b))
+#endif
+
void Graph2D::drawPolarAxes(QPainter *w)
{
QPen ceixos;

15
kdeedu4/patches/patch-af Normal file
View file

@ -0,0 +1,15 @@
$NetBSD: patch-af,v 1.1 2007/12/16 19:49:57 mwdavies Exp $
Need to fix this (back) for linux.
--- cmake/modules/FindReadline.cmake.orig 2007-12-16 08:48:08.000000000 +1300
+++ cmake/modules/FindReadline.cmake
@@ -7,7 +7,7 @@ else(READLINE_INCLUDE_DIR AND READLINE_L
)
FIND_LIBRARY(READLINE_LIBRARY NAMES readline)
- FIND_LIBRARY(NCURSES_LIBRARY NAMES ncurses )
+ FIND_LIBRARY(NCURSES_LIBRARY NAMES termcap )
include(FindPackageHandleStandardArgs)
FIND_PACKAGE_HANDLE_STANDARD_ARGS(Readline DEFAULT_MSG NCURSES_LIBRARY READLINE_INCLUDE_DIR READLINE_LIBRARY )