Fix installation of sample configuration files under example directory.

This commit is contained in:
Aleksej Saushev 2008-04-15 20:42:42 +00:00 committed by Thomas Klausner
parent 6c0d914f55
commit fd37b60abd
3 changed files with 42 additions and 13 deletions

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2008/04/15 20:21:14 asau Exp $
@comment $NetBSD: PLIST,v 1.4 2008/04/15 20:42:42 asau Exp $
bin/check_callstack
bin/clog2_join
bin/clog2_print
@ -45,17 +45,6 @@ bin/mpif77
bin/mpirun
bin/mpirun.py
bin/parkill
etc/mpe_callstack_ldflags.conf
etc/mpe_f77env.conf
etc/mpe_f77env.conf.in
etc/mpe_help.conf
etc/mpe_help.conf.in
etc/mpe_log.conf
etc/mpe_log_postlib.conf
etc/mpe_mpicheck.conf
etc/mpe_mpilog.conf
etc/mpe_mpitrace.conf
etc/mpe_nolog.conf
include/clog_commset.h
include/clog_const.h
include/clog_inttypes.h
@ -787,6 +776,17 @@ share/doc/${PKGNAME}/install.pdf
share/doc/${PKGNAME}/logging.pdf
share/doc/${PKGNAME}/smpd_pmi.pdf
share/doc/${PKGNAME}/user.pdf
share/${PKGNAME}/examples/mpe_callstack_ldflags.conf
share/${PKGNAME}/examples/mpe_f77env.conf
share/${PKGNAME}/examples/mpe_f77env.conf.in
share/${PKGNAME}/examples/mpe_help.conf
share/${PKGNAME}/examples/mpe_help.conf.in
share/${PKGNAME}/examples/mpe_log.conf
share/${PKGNAME}/examples/mpe_log_postlib.conf
share/${PKGNAME}/examples/mpe_mpicheck.conf
share/${PKGNAME}/examples/mpe_mpilog.conf
share/${PKGNAME}/examples/mpe_mpitrace.conf
share/${PKGNAME}/examples/mpe_nolog.conf
share/${PKGNAME}/examples/mpicc.conf
share/${PKGNAME}/examples/mpicxx.conf
share/${PKGNAME}/examples/mpif77.conf

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.3 2008/04/15 20:21:14 asau Exp $
$NetBSD: distinfo,v 1.4 2008/04/15 20:42:42 asau Exp $
SHA1 (mpich2-1.0.7.tar.gz) = 39d2734f2504b7c3a5e5ea79fa447913c5fcd177
RMD160 (mpich2-1.0.7.tar.gz) = d818cd2b3daf173a3e754d9805fdf20d74335122
Size (mpich2-1.0.7.tar.gz) = 16565875 bytes
SHA1 (patch-aa) = dc0756c27c01715669c066007ff964733213f14c
SHA1 (patch-ab) = 904c244fb3273dd1c38e0083c443f9a9c9d7e27e
SHA1 (patch-ac) = 813ab9b66055ce009d7ff254a6a81a8422ccffcf

28
mpi-ch/patches/patch-ac Normal file
View file

@ -0,0 +1,28 @@
$NetBSD: patch-ac,v 1.1 2008/04/15 20:42:42 asau Exp $
Install sample configuration files in example directory.
--- src/mpe2/sbin/mpeinstall.in.orig 2007-11-29 00:51:40.000000000 +0300
+++ src/mpe2/sbin/mpeinstall.in 2008-04-16 00:32:18.000000000 +0400
@@ -38,6 +38,8 @@
htmldir=@htmldir@
docdir=@docdir@
+exampledir=${datadir}/examples
+
# Assume PROF_LIBNAME=MPE_LIBNAME.
PROF_LIBNAME=@MPE_LIBNAME@
MPI_IMPL=@MPI_IMPL@
@@ -466,10 +468,10 @@
if [ -n "$etcbuild_dir" ] ; then
if [ -d $etcbuild_dir ] ; then
echo "Installing $pkgname configuration files to $DESTDIR$sysconfdir"
- InstallDirRecur $etcbuild_dir $sysconfdir $MODE
+ InstallDirRecur $etcbuild_dir $exampledir $MODE
cd $etcbuild_dir && \
for file in *.conf ; do \
- FixInstallFile $file $sysconfdir/$file ; \
+ FixInstallFile $file $exampledir/$file ; \
done
fi
fi