Import nios2-binutils-2.24 as wip/nios2-binutils.
Cross binutils 2.24 for ALTERA FPGA Nios2 processor.
This commit is contained in:
parent
62f1cbc81e
commit
fde5bf8e75
15 changed files with 532 additions and 0 deletions
25
nios2-binutils/COMMIT_MSG
Normal file
25
nios2-binutils/COMMIT_MSG
Normal file
|
@ -0,0 +1,25 @@
|
|||
(pkgsrc)
|
||||
Switch from Codesourcery to GNU FSF
|
||||
(Upstream 2.23.2 to 2.24.0)
|
||||
- binutils
|
||||
* Objcopy now supports wildcard characters in command line options that take
|
||||
section names.
|
||||
* Add support for Altera Nios II.
|
||||
- gas
|
||||
* Add support for the Texas Instruments MSP430X processor.
|
||||
* Add -gdwarf-sections command line option to enable per-code-section
|
||||
generation of DWARF .debug_line sections.
|
||||
* Add support for Altera Nios II.
|
||||
* Add support for the Imagination Technologies Meta processor.
|
||||
* Add support for the v850e3v5.
|
||||
* Remove assembler support for MIPS ECOFF targets.
|
||||
- ld
|
||||
* Add LOG2CEIL() builtin function to the linker script language
|
||||
* Add support for the Texas Instruments MSP430X processor.
|
||||
* Add support for Altera Nios II.
|
||||
* Add support for the V850E3V5 architecture.
|
||||
* Add support for the Imagination Technologies Meta processor.
|
||||
* --enable-new-dtags no longer generates old dtags in addition to new dtags.
|
||||
* Remove linker support for MIPS ECOFF targets.
|
||||
* Add ALIGN_WITH_INPUT to the linker script language to force the alignment of
|
||||
an output section to use the maximum alignment of all its input sections.
|
1
nios2-binutils/DESCR
Normal file
1
nios2-binutils/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
Cross binutils 2.24 for ALTERA FPGA Nios2 processor.
|
54
nios2-binutils/Makefile
Normal file
54
nios2-binutils/Makefile
Normal file
|
@ -0,0 +1,54 @@
|
|||
# $NetBSD: Makefile,v 1.12 2013/12/06 01:06:15 makoto Exp $
|
||||
|
||||
DISTNAME= binutils-2.24
|
||||
PKGNAME= ${DISTNAME:S/^/nios2-/}
|
||||
CATEGORIES= cross
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=binutils/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.gnu.org/software/binutils/
|
||||
COMMENT= GNU binutils for Altera FPGA Nios2 processor
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
BUILD_DEPENDS+= gtexinfo-[0-9]*:../../devel/gtexinfo
|
||||
|
||||
# No need to use makeinfo - this package doesn't install the documentation.
|
||||
USE_TOOLS+= gmake
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_GNU_CONFIGURE_HOST= no
|
||||
INFO_FILES= # empty
|
||||
|
||||
NIOS2_TARGET= nios2-elf
|
||||
CONFIGURE_ARGS+= --disable-werror --target=${NIOS2_TARGET} --disable-nls
|
||||
PLIST_SUBST+= NIOS2_TARGET=${NIOS2_TARGET:Q}
|
||||
|
||||
BUILD_DEFS+= CROSSBASE
|
||||
PATH:= ${CROSSBASE}/bin:${PATH}
|
||||
AUTO_MKDIRS= yes
|
||||
|
||||
# Prevent the need to run texi2pod.pl and pod2man hence
|
||||
# the need for perl as build dependency.
|
||||
post-configure:
|
||||
set -e; \
|
||||
cd ${WRKSRC}; \
|
||||
for f in ld/ldver.texi ld/ld.1 gas/doc/gasver.texi \
|
||||
gas/doc/as.1; do \
|
||||
${TOUCH} $${f}; \
|
||||
done
|
||||
|
||||
# following file installed is reference only, not used at all for the moment
|
||||
post-install:
|
||||
${INSTALL_DATA} files/nios2elf-netbsd.x ${DESTDIR}${PREFIX}/${NIOS2_TARGET}/lib/ldscripts
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
||||
# ./configure.lineno: 3239: Syntax error: Missing '}'
|
||||
# Makefile:2991: recipe for target 'configure-opcodes' failed
|
||||
# gmake[1]: *** [configure-opcodes] Error 1
|
||||
# gmake[1]: Leaving directory '/export/WRKOBJDIR/wip/avr-binutils/work/binutils-2.24'
|
||||
# see avr-binutils
|
||||
PKGSRC_MAKE_ENV+= SH=/bin/ksh
|
59
nios2-binutils/PLIST
Normal file
59
nios2-binutils/PLIST
Normal file
|
@ -0,0 +1,59 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2013/12/06 01:06:15 makoto Exp $
|
||||
${NIOS2_TARGET}/bin/ar
|
||||
${NIOS2_TARGET}/bin/as
|
||||
${NIOS2_TARGET}/bin/ld
|
||||
${NIOS2_TARGET}/bin/ld.bfd
|
||||
${NIOS2_TARGET}/bin/nm
|
||||
${NIOS2_TARGET}/bin/objcopy
|
||||
${NIOS2_TARGET}/bin/objdump
|
||||
${NIOS2_TARGET}/bin/ranlib
|
||||
${NIOS2_TARGET}/bin/strip
|
||||
bin/${NIOS2_TARGET}-addr2line
|
||||
bin/${NIOS2_TARGET}-ar
|
||||
bin/${NIOS2_TARGET}-as
|
||||
bin/${NIOS2_TARGET}-c++filt
|
||||
bin/${NIOS2_TARGET}-elfedit
|
||||
bin/${NIOS2_TARGET}-gprof
|
||||
bin/${NIOS2_TARGET}-ld
|
||||
bin/${NIOS2_TARGET}-ld.bfd
|
||||
bin/${NIOS2_TARGET}-nm
|
||||
bin/${NIOS2_TARGET}-objcopy
|
||||
bin/${NIOS2_TARGET}-objdump
|
||||
bin/${NIOS2_TARGET}-ranlib
|
||||
bin/${NIOS2_TARGET}-readelf
|
||||
bin/${NIOS2_TARGET}-size
|
||||
bin/${NIOS2_TARGET}-strings
|
||||
bin/${NIOS2_TARGET}-strip
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf-netbsd.x
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.x
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xbn
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xc
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xd
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xdc
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xdw
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xn
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xr
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xs
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xsc
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xsw
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xu
|
||||
${NIOS2_TARGET}/lib/ldscripts/nios2elf.xw
|
||||
man/man1/${NIOS2_TARGET}-addr2line.1
|
||||
man/man1/${NIOS2_TARGET}-ar.1
|
||||
man/man1/${NIOS2_TARGET}-as.1
|
||||
man/man1/${NIOS2_TARGET}-c++filt.1
|
||||
man/man1/${NIOS2_TARGET}-dlltool.1
|
||||
man/man1/${NIOS2_TARGET}-elfedit.1
|
||||
man/man1/${NIOS2_TARGET}-gprof.1
|
||||
man/man1/${NIOS2_TARGET}-ld.1
|
||||
man/man1/${NIOS2_TARGET}-nlmconv.1
|
||||
man/man1/${NIOS2_TARGET}-nm.1
|
||||
man/man1/${NIOS2_TARGET}-objcopy.1
|
||||
man/man1/${NIOS2_TARGET}-objdump.1
|
||||
man/man1/${NIOS2_TARGET}-ranlib.1
|
||||
man/man1/${NIOS2_TARGET}-readelf.1
|
||||
man/man1/${NIOS2_TARGET}-size.1
|
||||
man/man1/${NIOS2_TARGET}-strings.1
|
||||
man/man1/${NIOS2_TARGET}-strip.1
|
||||
man/man1/${NIOS2_TARGET}-windmc.1
|
||||
man/man1/${NIOS2_TARGET}-windres.1
|
16
nios2-binutils/buildlink3.mk
Normal file
16
nios2-binutils/buildlink3.mk
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2013/12/06 01:06:15 makoto Exp $
|
||||
|
||||
BUILDLINK_TREE+= nios2-binutils
|
||||
|
||||
.if !defined(NIOS2_BINUTILS_BUILDLINK3_MK)
|
||||
NIOS2_BINUTILS_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.nios2-binutils+= nios2-binutils>=2.20
|
||||
BUILDLINK_PKGSRCDIR.nios2-binutils?= ../../wip/nios2-binutils
|
||||
BUILDLINK_FNAME_TRANSFORM.nios2-binutils+= -e "s,${NIOS2_TARGET}/lib,lib/,g"
|
||||
#BUILDLINK_CONTENTS_FILTER.nios2-binutils= ${EGREP} '.*'
|
||||
BUILDLINK_CONTENTS_FILTER.nios2-binutils= ${GREP} '${CROSSBASE}'
|
||||
|
||||
.endif # NIOS2_BINUTILS_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -nios2-binutils
|
13
nios2-binutils/distinfo
Normal file
13
nios2-binutils/distinfo
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.6 2013/12/06 01:06:15 makoto Exp $
|
||||
|
||||
SHA1 (binutils-2.24.tar.bz2) = 7ac75404ddb3c4910c7594b51ddfc76d4693debb
|
||||
RMD160 (binutils-2.24.tar.bz2) = b4aa3ea5ba9d0d9f817b2cf136e7f911f692af8d
|
||||
Size (binutils-2.24.tar.bz2) = 22716802 bytes
|
||||
SHA1 (patch-ab) = e2bc22866d8e04b0d670509f3295da5f0e535ac8
|
||||
SHA1 (patch-ad) = 6d1acfd834c692abcc4f454db5f5107b7f77e34e
|
||||
SHA1 (patch-ae) = fff6693a610b26aa60e1d96ad634d15d11afbe05
|
||||
SHA1 (patch-af) = 5fa08da0b31da042eb30cce683f7b7b1feb3196b
|
||||
SHA1 (patch-ag) = e778ddd88f34e264e6b2d6d31a56a02be565e916
|
||||
SHA1 (patch-ah) = b6e91279475c41bc78b3df227938a91948fc377c
|
||||
SHA1 (patch-ai) = 3cd298ac0364f913c1261fc87f7f474281bae9cf
|
||||
SHA1 (patch-aj) = fd2a66979f68350a53960defdaf5e9e5018ec59a
|
227
nios2-binutils/files/nios2elf-netbsd.x
Normal file
227
nios2-binutils/files/nios2elf-netbsd.x
Normal file
|
@ -0,0 +1,227 @@
|
|||
/* Default linker script, for normal executables */
|
||||
OUTPUT_FORMAT("elf32-littlenios2", "elf32-bignios2",
|
||||
"elf32-littlenios2")
|
||||
OUTPUT_ARCH(nios2)
|
||||
ENTRY(__start)
|
||||
SEARCH_DIR("/usr/pkg/cross/lib");
|
||||
/* Do we need any of these for elf?
|
||||
__DYNAMIC = 0; */
|
||||
SECTIONS
|
||||
{
|
||||
/* Read-only sections, merged into text segment: */
|
||||
/* PROVIDE (__executable_start = 0x0400000); . = 0x0400000 + SIZEOF_HEADERS; */
|
||||
PROVIDE (__executable_start = 0x0400000); . = 0x0400000 + 1048576;
|
||||
.interp : { *(.interp) }
|
||||
/* XXX */
|
||||
/*
|
||||
.note.netbsd.ident : { *(.note.netbsd.ident) } :.text
|
||||
.note.netbsd.pax : { *(.note.netbsd.pax) } :.text
|
||||
*/
|
||||
/* XXX */
|
||||
.reginfo : { *(.reginfo) }
|
||||
.dynamic : { *(.dynamic) }
|
||||
.hash : { *(.hash) }
|
||||
.dynsym : { *(.dynsym) }
|
||||
.dynstr : { *(.dynstr) }
|
||||
.gnu.version : { *(.gnu.version) }
|
||||
.gnu.version_d : { *(.gnu.version_d) }
|
||||
.gnu.version_r : { *(.gnu.version_r) }
|
||||
.rel.init : { *(.rel.init) }
|
||||
.rela.init : { *(.rela.init) }
|
||||
.rel.text : { *(.rel.text .rel.text.* .rel.gnu.linkonce.t.*) }
|
||||
.rela.text : { *(.rela.text .rela.text.* .rela.gnu.linkonce.t.*) }
|
||||
.rel.fini : { *(.rel.fini) }
|
||||
.rela.fini : { *(.rela.fini) }
|
||||
.rel.rodata : { *(.rel.rodata .rel.rodata.* .rel.gnu.linkonce.r.*) }
|
||||
.rela.rodata : { *(.rela.rodata .rela.rodata.* .rela.gnu.linkonce.r.*) }
|
||||
.rel.data.rel.ro : { *(.rel.data.rel.ro*) }
|
||||
.rela.data.rel.ro : { *(.rel.data.rel.ro*) }
|
||||
.rel.data : { *(.rel.data .rel.data.* .rel.gnu.linkonce.d.*) }
|
||||
.rela.data : { *(.rela.data .rela.data.* .rela.gnu.linkonce.d.*) }
|
||||
.rel.tdata : { *(.rel.tdata .rel.tdata.* .rel.gnu.linkonce.td.*) }
|
||||
.rela.tdata : { *(.rela.tdata .rela.tdata.* .rela.gnu.linkonce.td.*) }
|
||||
.rel.tbss : { *(.rel.tbss .rel.tbss.* .rel.gnu.linkonce.tb.*) }
|
||||
.rela.tbss : { *(.rela.tbss .rela.tbss.* .rela.gnu.linkonce.tb.*) }
|
||||
.rel.ctors : { *(.rel.ctors) }
|
||||
.rela.ctors : { *(.rela.ctors) }
|
||||
.rel.dtors : { *(.rel.dtors) }
|
||||
.rela.dtors : { *(.rela.dtors) }
|
||||
.rel.got : { *(.rel.got) }
|
||||
.rela.got : { *(.rela.got) }
|
||||
.rel.sdata : { *(.rel.sdata .rel.sdata.* .rel.gnu.linkonce.s.*) }
|
||||
.rela.sdata : { *(.rela.sdata .rela.sdata.* .rela.gnu.linkonce.s.*) }
|
||||
.rel.sbss : { *(.rel.sbss .rel.sbss.* .rel.gnu.linkonce.sb.*) }
|
||||
.rela.sbss : { *(.rela.sbss .rela.sbss.* .rela.gnu.linkonce.sb.*) }
|
||||
.rel.sdata2 : { *(.rel.sdata2 .rel.sdata2.* .rel.gnu.linkonce.s2.*) }
|
||||
.rela.sdata2 : { *(.rela.sdata2 .rela.sdata2.* .rela.gnu.linkonce.s2.*) }
|
||||
.rel.sbss2 : { *(.rel.sbss2 .rel.sbss2.* .rel.gnu.linkonce.sb2.*) }
|
||||
.rela.sbss2 : { *(.rela.sbss2 .rela.sbss2.* .rela.gnu.linkonce.sb2.*) }
|
||||
.rel.bss : { *(.rel.bss .rel.bss.* .rel.gnu.linkonce.b.*) }
|
||||
.rela.bss : { *(.rela.bss .rela.bss.* .rela.gnu.linkonce.b.*) }
|
||||
.rel.plt : { *(.rel.plt) }
|
||||
.rela.plt : { *(.rela.plt) }
|
||||
.init :
|
||||
{
|
||||
KEEP (*(.init))
|
||||
} =0x0001883a
|
||||
.plt : { *(.plt) }
|
||||
.text :
|
||||
{
|
||||
_ftext = . ;
|
||||
*(.text .stub .text.* .gnu.linkonce.t.*)
|
||||
KEEP (*(.text.*personality*))
|
||||
/* .gnu.warning sections are handled specially by elf32.em. */
|
||||
*(.gnu.warning)
|
||||
} =0x0001883a
|
||||
.fini :
|
||||
{
|
||||
KEEP (*(.fini))
|
||||
} =0x0001883a
|
||||
PROVIDE (__etext = .);
|
||||
PROVIDE (_etext = .);
|
||||
PROVIDE (etext = .);
|
||||
.rodata : { *(.rodata .rodata.* .gnu.linkonce.r.*) }
|
||||
.rodata1 : { *(.rodata1) }
|
||||
.sdata2 : { *(.sdata2 .sdata2.* .gnu.linkonce.s2.*) }
|
||||
.sbss2 : { *(.sbss2 .sbss2.* .gnu.linkonce.sb2.*) }
|
||||
.eh_frame_hdr : { *(.eh_frame_hdr) }
|
||||
/* .eh_frame : ONLY_IF_RO { KEEP (*(.eh_frame)) } */
|
||||
/* .gcc_except_table : ONLY_IF_RO { KEEP (*(.gcc_except_table)) *(.gcc_except_table.*) } */
|
||||
/* Adjust the address for the data segment. We want to adjust up to
|
||||
the same address within the page on the next page up. */
|
||||
. = ALIGN (0x1000) - ((0x1000 - .) & (0x1000 - 1)); . = DATA_SEGMENT_ALIGN (0x1000, 0x1000);
|
||||
/* Exception handling */
|
||||
.eh_frame : /*ONLY_IF_RW*/ { KEEP (*(.eh_frame)) }
|
||||
.gcc_except_table : /*ONLY_IF_RW*/ { KEEP (*(.gcc_except_table)) *(.gcc_except_table.*) }
|
||||
/* Thread Local Storage sections */
|
||||
.tdata : { *(.tdata .tdata.* .gnu.linkonce.td.*) }
|
||||
.tbss : { *(.tbss .tbss.* .gnu.linkonce.tb.*) *(.tcommon) }
|
||||
/* Ensure the __preinit_array_start label is properly aligned. We
|
||||
could instead move the label definition inside the section, but
|
||||
the linker would then create the section even if it turns out to
|
||||
be empty, which isn't pretty. */
|
||||
. = ALIGN(32 / 8);
|
||||
PROVIDE (__preinit_array_start = .);
|
||||
.preinit_array : { KEEP (*(.preinit_array)) }
|
||||
PROVIDE (__preinit_array_end = .);
|
||||
PROVIDE (__init_array_start = .);
|
||||
.init_array : { KEEP (*(.init_array)) }
|
||||
PROVIDE (__init_array_end = .);
|
||||
PROVIDE (__fini_array_start = .);
|
||||
.fini_array : { KEEP (*(.fini_array)) }
|
||||
PROVIDE (__fini_array_end = .);
|
||||
.ctors :
|
||||
{
|
||||
/* gcc uses crtbegin.o to find the start of
|
||||
the constructors, so we make sure it is
|
||||
first. Because this is a wildcard, it
|
||||
doesn't matter if the user does not
|
||||
actually link against crtbegin.o; the
|
||||
linker won't look for a file to match a
|
||||
wildcard. The wildcard also means that it
|
||||
doesn't matter which directory crtbegin.o
|
||||
is in. */
|
||||
KEEP (*crtbegin*.o(.ctors))
|
||||
/* We don't want to include the .ctor section from
|
||||
from the crtend.o file until after the sorted ctors.
|
||||
The .ctor section from the crtend file contains the
|
||||
end of ctors marker and it must be last */
|
||||
KEEP (*(EXCLUDE_FILE (*crtend*.o ) .ctors))
|
||||
KEEP (*(SORT(.ctors.*)))
|
||||
KEEP (*(.ctors))
|
||||
}
|
||||
.dtors :
|
||||
{
|
||||
KEEP (*crtbegin*.o(.dtors))
|
||||
KEEP (*(EXCLUDE_FILE (*crtend*.o ) .dtors))
|
||||
KEEP (*(SORT(.dtors.*)))
|
||||
KEEP (*(.dtors))
|
||||
}
|
||||
.jcr : { KEEP (*(.jcr)) }
|
||||
.data.rel.ro : { *(.data.rel.ro.local) *(.data.rel.ro*) }
|
||||
/* . = DATA_SEGMENT_RELRO_END (0, .); */
|
||||
. = .;
|
||||
.data :
|
||||
{
|
||||
_fdata = . ;
|
||||
*(.data .data.* .gnu.linkonce.d.*)
|
||||
KEEP (*(.gnu.linkonce.d.*personality*))
|
||||
SORT(CONSTRUCTORS)
|
||||
}
|
||||
.data1 : { *(.data1) }
|
||||
. = .;
|
||||
_gp = ALIGN(16) + 0x7ff0;
|
||||
PROVIDE(gp = _gp);
|
||||
.got : { *(.got.plt) *(.got) }
|
||||
/* We want the small data sections together, so single-instruction offsets
|
||||
can access them all, and initialized data all before uninitialized, so
|
||||
we can shorten the on-disk segment size. */
|
||||
.sdata :
|
||||
{
|
||||
*(.sdata .sdata.* .gnu.linkonce.s.*)
|
||||
}
|
||||
.lit8 : { *(.lit8) }
|
||||
.lit4 : { *(.lit4) }
|
||||
_edata = .;
|
||||
PROVIDE (edata = .);
|
||||
__bss_start = .;
|
||||
_fbss = .;
|
||||
.sbss :
|
||||
{
|
||||
PROVIDE (__sbss_start = .);
|
||||
PROVIDE (___sbss_start = .);
|
||||
*(.dynsbss)
|
||||
*(.sbss .sbss.* .gnu.linkonce.sb.*)
|
||||
*(.scommon)
|
||||
PROVIDE (__sbss_end = .);
|
||||
PROVIDE (___sbss_end = .);
|
||||
}
|
||||
.bss :
|
||||
{
|
||||
*(.dynbss)
|
||||
*(.bss .bss.* .gnu.linkonce.b.*)
|
||||
*(COMMON)
|
||||
/* Align here to ensure that the .bss section occupies space up to
|
||||
_end. Align after .bss to ensure correct alignment even if the
|
||||
.bss section disappears because there are no input sections. */
|
||||
. = ALIGN(32 / 8);
|
||||
}
|
||||
. = ALIGN(32 / 8);
|
||||
_end = .;
|
||||
PROVIDE (end = .);
|
||||
. = DATA_SEGMENT_END (.);
|
||||
/* Stabs debugging sections. */
|
||||
.stab 0 : { *(.stab) }
|
||||
.stabstr 0 : { *(.stabstr) }
|
||||
.stab.excl 0 : { *(.stab.excl) }
|
||||
.stab.exclstr 0 : { *(.stab.exclstr) }
|
||||
.stab.index 0 : { *(.stab.index) }
|
||||
.stab.indexstr 0 : { *(.stab.indexstr) }
|
||||
.comment 0 : { *(.comment) }
|
||||
/* DWARF debug sections.
|
||||
Symbols in the DWARF debugging sections are relative to the beginning
|
||||
of the section so we begin them at 0. */
|
||||
/* DWARF 1 */
|
||||
.debug 0 : { *(.debug) }
|
||||
.line 0 : { *(.line) }
|
||||
/* GNU DWARF 1 extensions */
|
||||
.debug_srcinfo 0 : { *(.debug_srcinfo) }
|
||||
.debug_sfnames 0 : { *(.debug_sfnames) }
|
||||
/* DWARF 1.1 and DWARF 2 */
|
||||
.debug_aranges 0 : { *(.debug_aranges) }
|
||||
.debug_pubnames 0 : { *(.debug_pubnames) }
|
||||
/* DWARF 2 */
|
||||
.debug_info 0 : { *(.debug_info .gnu.linkonce.wi.*) }
|
||||
.debug_abbrev 0 : { *(.debug_abbrev) }
|
||||
.debug_line 0 : { *(.debug_line) }
|
||||
.debug_frame 0 : { *(.debug_frame) }
|
||||
.debug_str 0 : { *(.debug_str) }
|
||||
.debug_loc 0 : { *(.debug_loc) }
|
||||
.debug_macinfo 0 : { *(.debug_macinfo) }
|
||||
/* SGI/MIPS DWARF 2 extensions */
|
||||
.debug_weaknames 0 : { *(.debug_weaknames) }
|
||||
.debug_funcnames 0 : { *(.debug_funcnames) }
|
||||
.debug_typenames 0 : { *(.debug_typenames) }
|
||||
.debug_varnames 0 : { *(.debug_varnames) }
|
||||
/DISCARD/ : { *(.note.GNU-stack) }
|
||||
}
|
14
nios2-binutils/patches/patch-ab
Normal file
14
nios2-binutils/patches/patch-ab
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ab,v 1.1 2013/12/06 01:06:16 makoto Exp $
|
||||
|
||||
Avoid installing info file.
|
||||
|
||||
--- bfd/Makefile.in.orig 2011-11-21 20:55:49.000000000 +0900
|
||||
+++ bfd/Makefile.in 2012-02-06 22:14:51.000000000 +0900
|
||||
@@ -1713,7 +1713,6 @@
|
||||
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
||||
done
|
||||
install: $(BUILT_SOURCES)
|
||||
- $(MAKE) $(AM_MAKEFLAGS) install-recursive
|
||||
install-exec: install-exec-recursive
|
||||
install-data: install-data-recursive
|
||||
uninstall: uninstall-recursive
|
15
nios2-binutils/patches/patch-ad
Normal file
15
nios2-binutils/patches/patch-ad
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ad,v 1.1 2013/12/06 01:06:16 makoto Exp $
|
||||
|
||||
Avoid installing info (which duplicates with other CPU)
|
||||
|
||||
--- etc/Makefile.in.orig 2010-11-21 04:37:57.000000000 +0900
|
||||
+++ etc/Makefile.in 2012-02-06 21:50:04.000000000 +0900
|
||||
@@ -64,7 +64,7 @@
|
||||
HTMLFILES = standards.html configure.html
|
||||
|
||||
all: info
|
||||
-install install-strip: install-info
|
||||
+install install-strip:
|
||||
|
||||
uninstall:
|
||||
|
15
nios2-binutils/patches/patch-ae
Normal file
15
nios2-binutils/patches/patch-ae
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ae,v 1.1 2013/12/06 01:06:16 makoto Exp $
|
||||
|
||||
Avoid installing info (which duplicates with other CPU)
|
||||
|
||||
--- binutils/doc/Makefile.in.orig 2008-08-15 10:31:47 +0200
|
||||
+++ binutils/doc/Makefile.in
|
||||
@@ -65,7 +65,7 @@ CONFIG_CLEAN_FILES =
|
||||
depcomp =
|
||||
am__depfiles_maybe =
|
||||
SOURCES =
|
||||
-INFO_DEPS = binutils.info
|
||||
+INFO_DEPS =
|
||||
TEXINFO_TEX = $(top_srcdir)/../texinfo/texinfo.tex
|
||||
am__TEXINFO_TEX_DIR = $(top_srcdir)/../texinfo
|
||||
DVIS = binutils.dvi
|
15
nios2-binutils/patches/patch-af
Normal file
15
nios2-binutils/patches/patch-af
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-af,v 1.1 2013/12/06 01:06:16 makoto Exp $
|
||||
|
||||
Avoid installing info (which duplicates with other CPU)
|
||||
|
||||
--- gas/doc/Makefile.in.orig 2008-08-15 10:31:50 +0200
|
||||
+++ gas/doc/Makefile.in
|
||||
@@ -62,7 +62,7 @@ CONFIG_CLEAN_FILES =
|
||||
depcomp =
|
||||
am__depfiles_maybe =
|
||||
SOURCES =
|
||||
-INFO_DEPS = as.info
|
||||
+INFO_DEPS =
|
||||
TEXINFO_TEX = $(top_srcdir)/../texinfo/texinfo.tex
|
||||
am__TEXINFO_TEX_DIR = $(top_srcdir)/../texinfo
|
||||
DVIS = as.dvi
|
24
nios2-binutils/patches/patch-ag
Normal file
24
nios2-binutils/patches/patch-ag
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ag,v 1.1 2013/12/06 01:06:16 makoto Exp $
|
||||
|
||||
Avoid installing info (which duplicates with other CPU)
|
||||
|
||||
--- ld/Makefile.in.orig 2012-09-04 21:53:47.000000000 +0900
|
||||
+++ ld/Makefile.in 2013-01-27 07:19:44.000000000 +0900
|
||||
@@ -118,7 +118,7 @@ LTYACCCOMPILE = $(LIBTOOL) $(AM_LIBTOOLF
|
||||
--mode=compile $(YACC) $(YFLAGS) $(AM_YFLAGS)
|
||||
SOURCES = $(libldtestplug_la_SOURCES) $(ld_new_SOURCES) \
|
||||
$(EXTRA_ld_new_SOURCES)
|
||||
-INFO_DEPS = ld.info
|
||||
+INFO_DEPS =
|
||||
am__TEXINFO_TEX_DIR = $(srcdir)/../texinfo
|
||||
DVIS = ld.dvi
|
||||
PDFS = ld.pdf
|
||||
@@ -345,7 +345,7 @@ use_sysroot = @use_sysroot@
|
||||
AUTOMAKE_OPTIONS = dejagnu no-texinfo.tex no-dist foreign
|
||||
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
|
||||
TEXINFO_TEX = ../texinfo/texinfo.tex
|
||||
-SUBDIRS = po
|
||||
+SUBDIRS =
|
||||
tooldir = $(exec_prefix)/$(target_alias)
|
||||
|
||||
# Automake 1.10+ disables lex and yacc output file regeneration if
|
15
nios2-binutils/patches/patch-ah
Normal file
15
nios2-binutils/patches/patch-ah
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ah,v 1.1 2013/12/06 01:06:16 makoto Exp $
|
||||
|
||||
Avoid installing po (nls) files
|
||||
|
||||
--- binutils/Makefile.in.orig 2011-08-08 09:27:15.000000000 +0900
|
||||
+++ binutils/Makefile.in 2012-02-06 21:51:20.000000000 +0900
|
||||
@@ -405,7 +405,7 @@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = dejagnu no-dist foreign
|
||||
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
|
||||
-SUBDIRS = doc po
|
||||
+SUBDIRS = doc
|
||||
tooldir = $(exec_prefix)/$(target_alias)
|
||||
|
||||
# Automake 1.10+ disables lex and yacc output file regeneration if
|
15
nios2-binutils/patches/patch-ai
Normal file
15
nios2-binutils/patches/patch-ai
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ai,v 1.1 2013/12/06 01:06:16 makoto Exp $
|
||||
|
||||
Avoid installing po (nls) files
|
||||
|
||||
--- gas/Makefile.in.orig 2011-06-14 00:18:47.000000000 +0900
|
||||
+++ gas/Makefile.in 2012-02-06 21:51:43.000000000 +0900
|
||||
@@ -281,7 +281,7 @@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = 1.11 dejagnu foreign no-dist
|
||||
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
|
||||
-SUBDIRS = doc po
|
||||
+SUBDIRS = doc
|
||||
tooldir = $(exec_prefix)/$(target_alias)
|
||||
|
||||
# Automake 1.10+ disables lex and yacc output file regeneration if
|
24
nios2-binutils/patches/patch-aj
Normal file
24
nios2-binutils/patches/patch-aj
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-aj,v 1.1 2013/12/06 01:06:16 makoto Exp $
|
||||
|
||||
Avoid installing info and po (nls) files
|
||||
|
||||
--- gprof/Makefile.in.orig 2012-06-02 19:19:23.000000000 +0900
|
||||
+++ gprof/Makefile.in 2013-01-27 07:21:40.000000000 +0900
|
||||
@@ -93,7 +93,7 @@ LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLF
|
||||
--mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
|
||||
$(LDFLAGS) -o $@
|
||||
SOURCES = $(gprof_SOURCES)
|
||||
-INFO_DEPS = gprof.info
|
||||
+INFO_DEPS =
|
||||
am__TEXINFO_TEX_DIR = $(srcdir)/../texinfo
|
||||
DVIS = gprof.dvi
|
||||
PDFS = gprof.pdf
|
||||
@@ -279,7 +279,7 @@ AUTOMAKE_OPTIONS = 1.11 foreign no-dist
|
||||
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
|
||||
TEXINFO_TEX = ../texinfo/texinfo.tex
|
||||
SUFFIXES = .m
|
||||
-SUBDIRS = po
|
||||
+SUBDIRS =
|
||||
BASEDIR = $(srcdir)/..
|
||||
BFDDIR = $(BASEDIR)/bfd
|
||||
INCDIR = $(BASEDIR)/include
|
Loading…
Reference in a new issue