MUSCLE SmartCard framework PKCS #11 library
PKCS #11 modules can be loaded in software like Mozilla for smartcard support
This commit is contained in:
parent
85ada5d14a
commit
fe187bffe8
7 changed files with 86 additions and 0 deletions
2
muscle-pkcs11/DESCR
Normal file
2
muscle-pkcs11/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
MUSCLE SmartCard framework PKCS #11 library
|
||||
PKCS #11 modules can be loaded in software like Mozilla for smartcard support
|
25
muscle-pkcs11/Makefile
Normal file
25
muscle-pkcs11/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2005/07/25 21:28:57 udontknow Exp $
|
||||
|
||||
DISTNAME= muscleframework-1.1.5
|
||||
PKGNAME= muscle-pkcs11-1.1.5
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://alioth.debian.org/download.php/463/
|
||||
|
||||
MAINTAINER= evaldo@gardenali.biz
|
||||
HOMEPAGE= http://www.linuxnet.com/
|
||||
COMMENT= MUSCLE SmartCard framework PKCS #11 library
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/libmusclepkcs11
|
||||
GNU_CONFIGURE= YES
|
||||
USE_PKGINSTALL= YES
|
||||
USE_LIBTOOL= YES
|
||||
USE_TOOLS+= automake gmake
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/muscle-pkcs11
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/pkcs11rc.example ${EGDIR}
|
||||
|
||||
.include "../../wip/libmusclecard/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
13
muscle-pkcs11/PLIST
Normal file
13
muscle-pkcs11/PLIST
Normal file
|
@ -0,0 +1,13 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2005/07/25 21:28:57 udontknow Exp $
|
||||
include/crackcert.h
|
||||
include/cryptoki.h
|
||||
include/cryptoki_unix.h
|
||||
include/cryptoki_win32.h
|
||||
include/p11x_msc.h
|
||||
include/pkcs11.h
|
||||
include/pkcs11f.h
|
||||
include/pkcs11t.h
|
||||
include/thread_generic.h
|
||||
lib/libmusclepkcs11.la
|
||||
share/examples/muscle-pkcs11/pkcs11rc.example
|
||||
@dirrm share/examples/muscle-pkcs11
|
3
muscle-pkcs11/TODO
Normal file
3
muscle-pkcs11/TODO
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: TODO,v 1.1.1.1 2005/07/25 21:28:57 udontknow Exp $
|
||||
To-do list for muscle-pkcs11
|
||||
looks fine, needs some testing
|
20
muscle-pkcs11/buildlink3.mk
Normal file
20
muscle-pkcs11/buildlink3.mk
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2005/07/25 21:28:57 udontknow Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
MUSCLE_PKCS11_BUILDLINK3_MK:= ${MUSCLE_PKCS11_BUILDLINK3_MK}+
|
||||
|
||||
.if !empty(BUILDLINK_DEPTH:M+)
|
||||
BUILDLINK_DEPENDS+= muscle-pkcs11
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nmuscle-pkcs11}
|
||||
BUILDLINK_PACKAGES+= muscle-pkcs11
|
||||
|
||||
.if !empty(MUSCLE_PKCS11_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.muscle-pkcs11+= muscle-pkcs11>=1.1.5
|
||||
BUILDLINK_PKGSRCDIR.muscle-pkcs11?= ../../wip/muscle-pkcs11
|
||||
.endif # MUSCLE_PKCS11_BUILDLINK3_MK
|
||||
|
||||
.include "../../wip/libmusclecard/buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
6
muscle-pkcs11/distinfo
Normal file
6
muscle-pkcs11/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2005/07/25 21:28:57 udontknow Exp $
|
||||
|
||||
SHA1 (muscleframework-1.1.5.tar.gz) = d93266734e9081cd7779ae547995c1f171663c20
|
||||
RMD160 (muscleframework-1.1.5.tar.gz) = feb7661492b789862ad4112e4b76920daa0ad7da
|
||||
Size (muscleframework-1.1.5.tar.gz) = 1022040 bytes
|
||||
SHA1 (patch-aa) = bfcd78d4b3e3fcfde568048de40844023a375633
|
17
muscle-pkcs11/patches/patch-aa
Normal file
17
muscle-pkcs11/patches/patch-aa
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/07/25 21:28:57 udontknow Exp $
|
||||
|
||||
--- include/cryptoki.h.orig 2003-08-29 11:18:04.000000000 -0300
|
||||
+++ include/cryptoki.h
|
||||
@@ -35,12 +35,8 @@
|
||||
#include <pthread.h>
|
||||
#endif
|
||||
|
||||
-#ifndef __APPLE__
|
||||
-#include <musclecard.h>
|
||||
-#else
|
||||
#include <PCSC/wintypes.h>
|
||||
#include <PCSC/musclecard.h>
|
||||
-#endif
|
||||
|
||||
#include <sys/types.h>
|
||||
|
Loading…
Reference in a new issue