moved to pkgsrc/www
This commit is contained in:
parent
75bff2010d
commit
fea3a12256
6 changed files with 0 additions and 87 deletions
|
@ -1,7 +0,0 @@
|
|||
What is whisker?
|
||||
|
||||
The primary purpose of whisker is to be a URL scanner, which is
|
||||
used to search for known vulnerable CGIs on websites. Whisker does
|
||||
this by both scanning the the CGIs directly as well as crawling the
|
||||
website in order to determine what CGIs are already currently in
|
||||
use.
|
|
@ -1,31 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.2 2003/04/05 15:12:58 adrian_p Exp $
|
||||
|
||||
DISTNAME= whisker-2.1
|
||||
CATEGORIES= security www
|
||||
MASTER_SITES= http://www.wiretrip.net/rfp/bins/whisker/
|
||||
|
||||
MAINTAINER= adrianp@stindustries.net
|
||||
HOMEPAGE= http://www.wiretrip.net/rfp/
|
||||
COMMENT= URL scanner used to search for known vulnerable CGIs on websites
|
||||
|
||||
DEPENDS+= p5-Net-SSLeay>=1.20:../../security/p5-Net-SSLeay
|
||||
|
||||
USE_PERL5= YES
|
||||
REPLACE_PERL= whisker.pl
|
||||
|
||||
do-build:
|
||||
${SED} -e 's|@PREFIX@|${PREFIX}|g' < ${WRKSRC}/whisker.pl > ${WRKSRC}/whisker
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/whisker
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/whisker
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${PREFIX}/share/doc/whisker
|
||||
${INSTALL_DATA} ${WRKSRC}/CHANGES ${PREFIX}/share/doc/whisker
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/whisker
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/whisker ${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/LW.pm ${PREFIX}/share/whisker
|
||||
${INSTALL_DATA} ${WRKSRC}/html.plugin ${PREFIX}/share/whisker
|
||||
${INSTALL_DATA} ${WRKSRC}/main.test ${PREFIX}/share/whisker
|
||||
${INSTALL_DATA} ${WRKSRC}/newbie.help ${PREFIX}/share/whisker
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,12 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/04/05 14:08:19 adrian_p Exp $
|
||||
bin/whisker
|
||||
share/doc/whisker/plugins.txt
|
||||
share/doc/whisker/tests.txt
|
||||
share/doc/whisker/CHANGES
|
||||
share/doc/whisker/README
|
||||
share/whisker/LW.pm
|
||||
share/whisker/html.plugin
|
||||
share/whisker/main.test
|
||||
share/whisker/newbie.help
|
||||
@dirrm share/doc/whisker
|
||||
@dirrm share/whisker
|
10
whisker/TODO
10
whisker/TODO
|
@ -1,10 +0,0 @@
|
|||
I think there could be a licensing issue with this pkg. This probably
|
||||
needs to be confirmed before it gets committed.
|
||||
|
||||
Please test and let me know if there are any issues.
|
||||
|
||||
Tested on NetBSD 1.6 i386.
|
||||
|
||||
Ta,
|
||||
|
||||
Adrian.
|
|
@ -1,5 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.2 2003/04/05 15:12:58 adrian_p Exp $
|
||||
|
||||
SHA1 (whisker-2.1.tar.gz) = 74e4bcd0392e42ca26c4a353ce3aa0506cff10c2
|
||||
Size (whisker-2.1.tar.gz) = 62861 bytes
|
||||
SHA1 (patch-aa) = 4505f522e0d815dc2d72c9daca3ab1c55505bb2c
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2003/04/05 15:13:00 adrian_p Exp $
|
||||
|
||||
--- whisker.pl.orig Wed Nov 27 22:13:13 2002
|
||||
+++ whisker.pl Fri Jan 3 22:42:57 2003
|
||||
@@ -25,7 +25,7 @@
|
||||
if($^O =~ /Win32/){
|
||||
$WHISKER_DIR='C:\\program files\\whisker\\';
|
||||
} else {
|
||||
- $WHISKER_DIR='/usr/local/share/whisker/';
|
||||
+ $WHISKER_DIR='@PREFIX@/share/whisker/';
|
||||
}
|
||||
}
|
||||
|
||||
@@ -58,7 +58,7 @@
|
||||
eval 'use LW';
|
||||
if($@){ $LW=0;
|
||||
if(-e $WHISKER_DIR.'LW.pm'){
|
||||
- eval "require $WHISKER_DIR".'LW.pm';
|
||||
+ eval "require '$WHISKER_DIR'.'LW.pm'";
|
||||
if(!$@){$LW++;}}
|
||||
} else { $LW++; }
|
||||
if(!$LW){
|
Loading…
Reference in a new issue