ChangeLog: * Changed FBAS and SVHS to COMPOSITE and SVIDEO. * Moved nvtvsimple files to own directory, with own configure. * Adapted man directory for automake. * Changed x_includes to X_CFLAGS in configure.in, to fix Debian bug 192455. * Added nvtvsimple files from Mattias Eriksson. * Added automake files. Renamed LICENSE -> COPYING, main.[ch] -> nvtv.[ch], server.c -> nvtvd.c. * Updated xine info in FAQ. * Card argument for setup, proper mux setup for Voodoo3. * Added another Voodoo3 BT connector status detection. * Added PAL-M and NTSC-J converter for Brooktree/Conexant. * Added extra bus for I830. * Dump for i830 in probeCard. * Added CH7009 (Model2) detection and preleminary support. * Fixed devMem in nvdump. * Check if NV Timer is active before using it. * WxWin configure stuff (no WxWin files yet). * Fixed missing 'methods' in TvNull. * Support NVidia driver 1.0-4349. * Special init also for NV17, NV18, NV25, NV30. * Refactored identify mapping into card_direct. On my side: o Instead of hacking configure script and some Makefiles, I hacked configure.in and autoconf'ed it. I'll send the patch to the author. o Use normal install target now that there are automake files. Now binaries are in bin instead of sbin, and man page for nvtv goes in section 1. Oh, well. I still want some docs to be installed.
56 lines
1.4 KiB
Text
56 lines
1.4 KiB
Text
$NetBSD: patch-af,v 1.2 2003/06/07 17:50:22 cubidou Exp $
|
|
|
|
--- src/nvtvd.c.orig 2003-02-10 15:50:44.000000000 +0100
|
|
+++ src/nvtvd.c
|
|
@@ -27,6 +27,7 @@
|
|
#include "local.h" /* before everything else */
|
|
|
|
#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
#include <getopt.h>
|
|
|
|
#ifdef HAVE_UNISTD_H
|
|
@@ -51,6 +52,7 @@ BackCardPtr back_card = NULL;
|
|
|
|
Bool opt_null = FALSE;
|
|
Bool opt_nvdev = FALSE;
|
|
+Bool opt_debug = FALSE;
|
|
|
|
static const char *short_options = "?hnN";
|
|
|
|
@@ -58,6 +60,7 @@ static struct option long_options[] =
|
|
{{"help", no_argument, NULL, 'h'},
|
|
{"null", no_argument, NULL, 'n'},
|
|
{"nvdev", no_argument, NULL, 'N'},
|
|
+ {"debug", no_argument, NULL, 'd'},
|
|
{NULL, 0, NULL, 0}
|
|
};
|
|
|
|
@@ -77,6 +80,8 @@ void usage (void)
|
|
" -N --nvdev enable usage of /dev/nv* devices\n");
|
|
fprintf (stderr,
|
|
" -n --null use null backend (for debugging)\n");
|
|
+ fprintf (stderr,
|
|
+ " -d --debug don't detach from controlling terminal\n");
|
|
}
|
|
|
|
/* -------- Server state -------- */
|
|
@@ -581,6 +586,9 @@ int main (int argc, char *argv[])
|
|
case 'N':
|
|
opt_nvdev = TRUE;
|
|
break;
|
|
+ case 'd':
|
|
+ opt_debug = TRUE;
|
|
+ break;
|
|
}
|
|
}
|
|
|
|
@@ -618,6 +626,8 @@ int main (int argc, char *argv[])
|
|
}
|
|
|
|
DPRINTF ("server loop.\n");
|
|
+ if (!opt_debug)
|
|
+ daemon(0,0);
|
|
srv_loop ();
|
|
|
|
fclose (pipe_in);
|