pkgsrc-wip/mpi-ch/patches/patch-aa
2010-12-16 23:41:33 +00:00

57 lines
2.8 KiB
Text

$NetBSD: patch-aa,v 1.7 2010/12/16 23:41:33 asau Exp $
Install configuration files into example directory.
--- src/env/Makefile.in.orig 2010-11-17 19:51:55.000000000 +0300
+++ src/env/Makefile.in 2010-12-17 02:06:35.000000000 +0300
@@ -19,6 +19,8 @@
srcdir = @srcdir@
abs_srcdir = @abs_srcdir@
sysconfdir = @sysconfdir@
+datadir = @datadir@
+exampledir = ${datadir}/examples
DEFS = @DEFS@ -I. -I${srcdir}
CPPFLAGS = @CPPFLAGS@
LIBS = @LIBS@
@@ -95,15 +97,15 @@
$(INSTALL_PROGRAM) $(INSTALL_STRIP_FLAG) mpich2version ${DESTDIR}${bindir}/mpich2version
$(INSTALL_SCRIPT) mpicc ${DESTDIR}${bindir}/mpicc
$(INSTALL_SCRIPT) parkill ${DESTDIR}${bindir}/parkill
- if [ ! -d ${DESTDIR}${sysconfdir} ] ; then $(MKDIR_P) ${DESTDIR}${sysconfdir} ; fi
- $(INSTALL_DATA) mpixxx_opts.conf ${DESTDIR}${sysconfdir}/mpixxx_opts.conf
- $(INSTALL_DATA) mpicc.conf ${DESTDIR}${sysconfdir}/mpicc.conf
+ if [ ! -d ${DESTDIR}${exampledir} ] ; then $(MKDIR_P) ${DESTDIR}${exampledir} ; fi
+ $(INSTALL_DATA) mpixxx_opts.conf ${DESTDIR}${exampledir}/mpixxx_opts.conf
+ $(INSTALL_DATA) mpicc.conf ${DESTDIR}${exampledir}/mpicc.conf
if [ -s mpicxx ] ; then $(INSTALL_SCRIPT) mpicxx ${DESTDIR}${bindir}/mpicxx ; fi
if [ -s mpif77 ] ; then $(INSTALL_SCRIPT) mpif77 ${DESTDIR}${bindir}/mpif77 ; fi
if [ -s mpif90 ] ; then $(INSTALL_SCRIPT) mpif90 ${DESTDIR}${bindir}/mpif90 ; fi
- if [ -s mpicxx.conf ] ; then $(INSTALL_DATA) mpicxx.conf ${DESTDIR}${sysconfdir}/mpicxx.conf ; fi
- if [ -s mpif77.conf ] ; then $(INSTALL_DATA) mpif77.conf ${DESTDIR}${sysconfdir}/mpif77.conf ; fi
- if [ -s mpif90.conf ] ; then $(INSTALL_DATA) mpif90.conf ${DESTDIR}${sysconfdir}/mpif90.conf ; fi
+ if [ -s mpicxx.conf ] ; then $(INSTALL_DATA) mpicxx.conf ${DESTDIR}${exampledir}/mpicxx.conf ; fi
+ if [ -s mpif77.conf ] ; then $(INSTALL_DATA) mpif77.conf ${DESTDIR}${exampledir}/mpif77.conf ; fi
+ if [ -s mpif90.conf ] ; then $(INSTALL_DATA) mpif90.conf ${DESTDIR}${exampledir}/mpif90.conf ; fi
${MAKE} install-postamble
install-strip:
@@ -112,14 +114,14 @@
-rm -f ${DESTDIR}${bindir}/mpich2version
-rm -f ${DESTDIR}${bindir}/mpicc
-rm -f ${DESTDIR}${bindir}/parkill
- -rm -f ${DESTDIR}${sysconfdir}/mpixxx_opts.conf
- -rm -f ${DESTDIR}${sysconfdir}/mpicc.conf
+ -rm -f ${DESTDIR}${exampledir}/mpixxx_opts.conf
+ -rm -f ${DESTDIR}${exampledir}/mpicc.conf
-rm -f ${DESTDIR}${bindir}/mpicxx
-rm -f ${DESTDIR}${bindir}/mpif77
-rm -f ${DESTDIR}${bindir}/mpif90
- -rm -f ${DESTDIR}${sysconfdir}/mpicxx.conf
- -rm -f ${DESTDIR}${sysconfdir}/mpif77.conf
- -rm -f ${DESTDIR}${sysconfdir}/mpif90.conf
+ -rm -f ${DESTDIR}${exampledir}/mpicxx.conf
+ -rm -f ${DESTDIR}${exampledir}/mpif77.conf
+ -rm -f ${DESTDIR}${exampledir}/mpif90.conf
${MAKE} uninstall-postamble
installcheck:
# --------------------------------------------------------------------------