pkgsrc-wip/tc-svn/patches/patch-configure.ac
Makoto Fujiwara 688f6f0628 Upstream bumped the version 2.3.1 to 3.0,
but it is really 3.0pre. So we set PKGVERSION as 2.99.1.
(1) Makefile
      Bump version 2.3.1 to 2.99.1
(2) PLIST
      Have ${PKGVERSION} in PLIST
(3) patch-configure.{in,.ac}
      Rename patch-configure.in to patch-configure.ac
      to follow upstream change (actually delete and add).
(4) patches/patch-lisp_Makefile.{am,in}
     In tc-pre.el, following line set the version name.
      (defconst tcode-version "3.0")
     But at byte-compile, if older version like 2.3.1
     is installed already, the old constant is honored
     and tc-pre.elc has 2.3.1 for tcode-version.
    As a work around, tc-pre is excluded for byte compile list.
2012-08-05 15:01:04 +00:00

33 lines
909 B
Text

$NetBSD: patch-configure.ac,v 1.1 2012/08/05 15:01:05 makoto Exp $
Add --enable-symbol-rev for configure (by mef@)
--- configure.ac.orig 2011-04-16 11:35:11.000000000 +0900
+++ configure.ac 2011-04-16 16:51:55.000000000 +0900
@@ -35,6 +35,18 @@
--with-lispdir=DIR Emacs Lisp files in DIR,
lispdir=${withval})
+SYMBOLREV=no
+AC_ARG_ENABLE(symbol-rev,
+[AS_HELP_STRING([--enable-symbol-rev],
+ [Includes symbol.rev in bushu.rev Default: none])],
+if test "${enableval}" = "yes"; then
+ SYMBOLREV=yes
+else
+ SYMBOLREV=no
+fi
+)
+ AC_MSG_RESULT(checking symbol-rev .. ${SYMBOLREV})
+
dnl AC_ARG_WITH(makeinfo,dnl
dnl --with-makeinfo Specify how to build info files,
dnl [ MAKEINFO="$withval" ])
@@ -63,6 +75,7 @@
AC_SUBST(EMACS_PACKAGE_DIR)
AC_SUBST(MAKEINFO)
AC_SUBST(EMACS)
+AC_SUBST(SYMBOLREV)
AC_SUBST(INSTALL)
AC_SUBST(INSTALLINFO)
INSTALL_SCRIPT=$INSTALL