This is the version of man written by John Eaton and maintained by Andries Brouwer. This man package provides a man pager that supports compressed pages, locales and message catalogs. It also includes makewhatis for creating the whatis database, apropos and whatis for searching the whatis database, man2dvi for formating manpages to DVI, and man2html for converting manpages to HTML. This package does not include the CGI scripts nor hman utility for web-based manpage viewing.
27 lines
928 B
Text
27 lines
928 B
Text
$NetBSD: patch-ab,v 1.1.1.1 2005/02/02 07:09:26 jeremy-c-reed Exp $
|
|
|
|
--- man2html/Makefile.in.orig 2005-01-07 16:49:37.000000000 -0800
|
|
+++ man2html/Makefile.in
|
|
@@ -1,8 +1,8 @@
|
|
CC = @CC@
|
|
CFLAGS += -Wall -Wstrict-prototypes -Wmissing-prototypes
|
|
OBJECTS = man2html.o cgibase.o abbrev.o strdefs.o
|
|
-bindir = $(DESTDIR)$(PREFIX)/usr/bin
|
|
-mandir = $(DESTDIR)$(PREFIX)@mandir@
|
|
+bindir = $(DESTDIR)@bindir@
|
|
+mandir = $(DESTDIR)@mandir@
|
|
vardir = $(DESTDIR)$(PREFIX)/var
|
|
httpdir = $(DESTDIR)$(PREFIX)/home/httpd
|
|
cgiowner = nobody
|
|
@@ -17,9 +17,9 @@ man2html: $(OBJECTS)
|
|
|
|
# This installs the man2html utility
|
|
install: man2html
|
|
- install -m 755 man2html $(bindir)
|
|
+ install -c -m 755 man2html $(bindir)
|
|
mkdir -p $(mandir)/man1
|
|
- install -m 644 man2html.1 $(mandir)/man1/man2html.@man1ext@
|
|
+ install -c -m 644 man2html.1 $(mandir)/man1/man2html.@man1ext@
|
|
|
|
install-scripts: install-man-scripts install-glimpse-stuff install-hman
|
|
|