pkgsrc-wip/streamripper/patches/patch-ac
grant beattie 3283d84235 update streamripper to 1.60. still needs work to build on NetBSD,
untested on anything else.

changes since 1.32:

New for 1.60
------------
2004/04/04 (GCS - gregsharp@users.sourceforge.net)
* No changes.

New for 1.60-pre3
-----------------
2004/03/27 (GCS - gregsharp@users.sourceforge.net)
* Fix the bug: error -22 [SR_ERROR_BUFFER_EMPTY]

New for 1.60-pre2
-----------------
2004/03/24 (GCS - gregsharp@users.sourceforge.net)
* Add Johannes Buettner's drop patch
* Fixes for compiling winamp 2 plugin

New for 1.60-pre1
-----------------
2004/03/10 (GCS - gregsharp@users.sourceforge.net)
* Track splitting enhancements - see readme_xfade.txt
* Partial multibyte character support
* Fix crashes on very long file names
* Fix crashes on control characters in meta data

new in cvs
----------
2003/09/25:
* Added support for HTTP "Basic" authorization. Works with
  DigitallyImported.com.
  (lib/types.h, lib/http.c) -Colin D. Bennett <cbennett@radsoft.com>
* Fixed a couple of tiny memory leaks in the usage of b64enc(), the
  returned buffer allocated as 'string' in b64enc wasn't being freed,
  and the 'authbuf' malloc'd in httplib_construct_sc_request for the
  proxy authorization wasn't freed.
  (lib/http.c) -Colin D. Bennett <cbennett@radsoft.com>
2004-07-29 15:48:40 +00:00

149 lines
3.6 KiB
Text

$NetBSD: patch-ac,v 1.2 2004/07/29 15:48:40 grantbeattie Exp $
--- lib/Makefile.in.orig 2004-04-05 06:25:17.000000000 +1000
+++ lib/Makefile.in
@@ -1,72 +1,72 @@
-# Generated automatically from Makefile.in by configure.
-#Makefile for streamripper
-
-bindir = /usr/local/bin
-SHELL = /bin/sh
-CC = @CC@
-
-LDFLAGS = @THREADLIBS@ -lm
-INCPATHS = -I ../libmad
-CFLAGS = @CFLAGS@
-DEFS = -D__UNIX__ -D_REENTRANT -DUSE_LAYER3 -DHAVE_MPGLIB -DNOANALYSIS -DNDEBUG
-COMPILE_CFLAGS = $(CFLAGS) $(DEFS) $(INCPATHS)
-
-LIBOBJS = cbuffer.o \
- util.o \
- filelib.o \
- socklib.o \
- http.o \
- inet.o \
- threadlib.o \
- mpeg.o \
- findsep.o \
- ripstream.o \
- rip_manager.o \
- relaylib.o \
- debug.o \
- ripshout.o
-
-all: $(LIBOBJS)
-
-relaylib.o: relaylib.c relaylib.h
- $(CC) $(COMPILE_CFLAGS) -c -o relaylib.o relaylib.c
-
-rip_manager.o: rip_manager.c rip_manager.h
- $(CC) $(COMPILE_CFLAGS) -c -o rip_manager.o rip_manager.c
-
-util.o: util.c util.h
- $(CC) $(COMPILE_CFLAGS) -c -o util.o util.c
-
-cbuffer.o: cbuffer.c cbuffer.h
- $(CC) $(COMPILE_CFLAGS) -c -o cbuffer.o cbuffer.c
-
-filelib.o: filelib.c filelib.h
- $(CC) $(COMPILE_CFLAGS) -c -o filelib.o filelib.c
-
-socklib.o: socklib.c socklib.h
- $(CC) $(COMPILE_CFLAGS) -c -o socklib.o socklib.c
-
-http.o: http.c http.h
- $(CC) $(COMPILE_CFLAGS) -c -o http.o http.c
-
-inet.o: inet.c inet.h
- $(CC) $(COMPILE_CFLAGS) -c -o inet.o inet.c
-
-threadlib.o: threadlib.c threadlib.h
- $(CC) $(COMPILE_CFLAGS) -c -o threadlib.o threadlib.c
-
-mpeg.o: mpeg.c mpeg.h
- $(CC) $(COMPILE_CFLAGS) -c -o mpeg.o mpeg.c
-
-findsep.o: findsep.c findsep.h
- $(CC) $(COMPILE_CFLAGS) -c -o findsep.o findsep.c
-
-ripstream.o: ripstream.c ripstream.h
- $(CC) $(COMPILE_CFLAGS) -c -o ripstream.o ripstream.c
-
-ripshout.o: ripshout.c ripshout.h
- $(CC) $(COMPILE_CFLAGS) -c -o ripshout.o ripshout.c
-
-clean:
- rm -f *.o
-
+# Generated automatically from Makefile.in by configure.
+#Makefile for streamripper
+
+bindir = /usr/local/bin
+SHELL = /bin/sh
+CC = @CC@
+
+LDFLAGS = @THREADLIBS@ -lm
+INCPATHS = -I ../libmad
+CFLAGS = @CFLAGS@
+DEFS = -D__UNIX__ -D_REENTRANT -DUSE_LAYER3 -DHAVE_MPGLIB -DNOANALYSIS -DNDEBUG
+COMPILE_CFLAGS = $(CFLAGS) $(DEFS) $(INCPATHS)
+
+LIBOBJS = cbuffer.o \
+ util.o \
+ filelib.o \
+ socklib.o \
+ http.o \
+ inet.o \
+ threadlib.o \
+ mpeg.o \
+ findsep.o \
+ ripstream.o \
+ rip_manager.o \
+ relaylib.o \
+ debug.o \
+ ripshout.o
+
+all: $(LIBOBJS)
+
+relaylib.o: relaylib.c relaylib.h
+ $(CC) $(COMPILE_CFLAGS) -c -o relaylib.o relaylib.c
+
+rip_manager.o: rip_manager.c rip_manager.h
+ $(CC) $(COMPILE_CFLAGS) -c -o rip_manager.o rip_manager.c
+
+util.o: util.c util.h
+ $(CC) $(COMPILE_CFLAGS) -c -o util.o util.c
+
+cbuffer.o: cbuffer.c cbuffer.h
+ $(CC) $(COMPILE_CFLAGS) -c -o cbuffer.o cbuffer.c
+
+filelib.o: filelib.c filelib.h
+ $(CC) $(COMPILE_CFLAGS) -c -o filelib.o filelib.c
+
+socklib.o: socklib.c socklib.h
+ $(CC) $(COMPILE_CFLAGS) -c -o socklib.o socklib.c
+
+http.o: http.c http.h
+ $(CC) $(COMPILE_CFLAGS) -c -o http.o http.c
+
+inet.o: inet.c inet.h
+ $(CC) $(COMPILE_CFLAGS) -c -o inet.o inet.c
+
+threadlib.o: threadlib.c threadlib.h
+ $(CC) $(COMPILE_CFLAGS) -c -o threadlib.o threadlib.c
+
+mpeg.o: mpeg.c mpeg.h
+ $(CC) $(COMPILE_CFLAGS) -c -o mpeg.o mpeg.c
+
+findsep.o: findsep.c findsep.h
+ $(CC) $(COMPILE_CFLAGS) -c -o findsep.o findsep.c
+
+ripstream.o: ripstream.c ripstream.h
+ $(CC) $(COMPILE_CFLAGS) -c -o ripstream.o ripstream.c
+
+ripshout.o: ripshout.c ripshout.h
+ $(CC) $(COMPILE_CFLAGS) -c -o ripshout.o ripshout.c
+
+clean:
+ rm -f *.o
+