pkgsrc-wip/pcsc-lite/patches/patch-ab
Geert Hendrickx 15bd68615d Update to 1.2.9-beta10, as the old distfile wasn't available anymore.
ChangeLog:

pcsc-lite-1.2.9-beta10
3 February 2006
- if the USB reader defines a serial number then include it in the
  reader name (between parenthesis)
- the library libpcsclite.so.1 only exports the symbols defined by the
  API (http://pcsclite.alioth.debian.org/pcsc-lite/). This is needed to
  be able to use the library in an appliation that also uses flex (like
  muscleTool). The problem only occurs with GCC >= 4.0
- some other minor improvements and bug corrections

pcsc-lite-1.2.9-beta9
27 November 2005
- add/improve support of PIN pad readers
  . define HOST_TO_CCID_16() and HOST_TO_CCID_32() macro to convert 16 and
    32-bits data to the CCID format (replace HOST_TO_CCID)
- add support of SUN C compiler and try to avoid GCC specific features
  (Heiko Nardmann)
- SCardGetStatusChange():
  . exists if the list of readers changed (one reader added) so that the
    application can update its list of readers (Najam Siddiqui)
  . correct a bug when two contexts where used (Najam Siddiqui)
- add support of Solaris 10 IFDhandler (Douglas E. Engert)
- allow pcsc-lite to be compiled without (f)lex installed
- add a TODO file. Help/money needed here.
- improve Doxygen documentation
- some other minor improvements and bug corrections
2006-02-16 20:30:18 +00:00

11 lines
333 B
Text

$NetBSD: patch-ab,v 1.2 2006/02/16 20:30:20 ghen Exp $
--- src/Makefile.am.orig 2006-02-15 16:45:57.000000000 +0100
+++ src/Makefile.am
@@ -92,3 +92,6 @@ tokenparser.c: tokenparser.l
EXTRA_DIST = README_INTERNALS.txt dyn_win32.c thread_win32.c winscard_scf.c
+install-data-local:
+ ${INSTALL} -d ${DESTDIR}${includedir}/PCSC
+