pkgsrc-wip/db1/patches/patch-af
Roland Illig 11b1db746a Made the package build on Linux. Added buildlink3.mk for other packages.
Integrated the patches from the TODO list.
2004-07-03 18:33:03 +00:00

22 lines
406 B
Text

$NetBSD: patch-af,v 1.1 2004/07/03 18:33:04 rillig Exp $
--- ./hash/ndbm.c.orig 1997-01-04 20:25:41.000000000 +0100
+++ ./hash/ndbm.c 2004-07-03 16:08:28.000000000 +0200
@@ -277,7 +277,7 @@
HTAB *hp;
hp = (HTAB *)db->internal;
- return (hp->errno);
+ return (hp->err_no);
}
int
@@ -287,7 +287,7 @@
HTAB *hp;
hp = (HTAB *)db->internal;
- hp->errno = 0;
+ hp->err_no = 0;
return (0);
}