Task manager is never blocked by Workrave, workaround for focus loss on Vista, Vanja Cvelbar translated Workrave into Slovenian, fixed breaks that have 'suspend timer when inactive' disabled, improved Windows responsiveness under high load, mode menu fixed, Gnome applet no longer 'hangs', Gnome applet no longer crashes Workrave, fixed crashes during startup on Windows, fixed 'end-of-microbreak' sound, fixed bug in multi-head support where Workrave showed multiple windows on a single screen, fixed locking on Gnome with xscreensaver installed. Created different sets of options for building the frontend (GTK2, GNOME, and KDE) and backend (configurations: GNOME, KDE, GConf, GDome), and other support items (DBus, distributed workraves).
40 lines
1.2 KiB
Text
40 lines
1.2 KiB
Text
$NetBSD: patch-ad,v 1.1 2007/10/01 22:51:23 briandealwis Exp $
|
|
|
|
--- configure.ac.orig 2007-09-14 12:50:42.000000000 -0600
|
|
+++ configure.ac
|
|
@@ -119,7 +119,7 @@ AC_ARG_ENABLE( experimental,
|
|
[ --disable-experimental compile without experimental features],
|
|
config_experimental=$enableval
|
|
,
|
|
- config_experimental==yes
|
|
+ config_experimental=yes
|
|
)
|
|
|
|
dnl AC_MSG_CHECKING(whether to link statically)
|
|
@@ -460,7 +460,7 @@ AC_SUBST(GNET_LIBS)
|
|
AC_SUBST(GNET_CFLAGS)
|
|
|
|
|
|
-if test "x$GNET_LIBS" == "x"; then
|
|
+if test "x$GNET_LIBS" = "x"; then
|
|
config_distribution=no
|
|
fi
|
|
|
|
@@ -588,7 +588,7 @@ AM_GNU_GETTEXT()
|
|
#AM_GLIB_GNU_GETTEXT
|
|
|
|
dnl Hack because windows gettext package is SEVERELY broken...
|
|
-if test "x$platform_win32" == "xyes"; then
|
|
+if test "x$platform_win32" = "xyes"; then
|
|
USE_NLS=yes
|
|
AC_DEFINE(ENABLE_NLS,1,[Define to 1 if translation of program messages to the user's native
|
|
language is requested.])
|
|
@@ -719,7 +719,7 @@ if test "x$config_with_registry" = "xyes
|
|
fi
|
|
|
|
HAVE_GLIB=
|
|
-if test "x$GTKMM_LIBS" != "x"; then
|
|
+if test "x$GLIB_LIBS" != "x"; then
|
|
AC_DEFINE(HAVE_GLIB,,[Define if glib is available])
|
|
fi
|
|
|