pkgsrc-wip/clisp-current/patches/patch-aa
Johann Franz bcaa582368 - Overhaul options.mk, modules still need fixing though.
- zlib is a module, ffcall is not a module but required by some, thus
  make zlib optional for now and ffcall mandatory.
- Add some configure switches (copycat lang/clisp).
- Regenerate PLIST.
2008-01-06 13:22:17 +00:00

23 lines
1.1 KiB
Text

$NetBSD: patch-aa,v 1.2 2008/01/06 13:22:17 netcap Exp $
Don't use cache file to avoid trailing space problem.
--- src/makemake.in.orig 2008-01-03 20:28:49.000000000 +0100
+++ src/makemake.in
@@ -1881,6 +1881,7 @@ echol "psdir = ${PSDIR}"
echol "pdfdir = ${PDFDIR}"
echol "libdir = ${LIBDIR}"
echol "lisplibdir = \$(libdir)${NEXT_}\$(TOPDIR)"
+echol "lisplibdir = \$(libdir)${NEXT_}clisp"
if [ -n "$USE_GETTEXT" ] ; then
echol "localedir = ${LOCALEDIR}"
fi
@@ -3342,7 +3343,7 @@ echotab " if test \"\$\${ac_cv_env_
echotab " if test \"\$\${ac_cv_env_CFLAGS_set}\" = set; then CFLAGS=\"\$\${ac_cv_env_CFLAGS_value}\"; export CFLAGS; fi; \\"
# we must use $(SHELL) for sub-configures because when the top CONFIG_SHELL
# is bash, config.cache may be unparsable with sh on Solaris
-echotab " \$(SHELL) ./configure --cache-file=\$\${cache} --srcdir=\$\$m \$(MODULE_CONFIGURE_FLAGS);\\"
+echotab " \$(SHELL) ./configure --srcdir=\$\$m \$(MODULE_CONFIGURE_FLAGS);\\"
echotab " else \$(SHELL) ./configure --srcdir=\$\$m \$(MODULE_CONFIGURE_FLAGS); \\"
echotab " fi ) ;\\"
echotab "fi"