o [NSE] Added 37 scripts, bringing the total to 117! o Added an ALPHA TEST VERSION of Nping, a packet generator. o [NSE] Added RPC library. o [NSE] Added a new library for ASN.1 parsing and adapted the SNMP library to make use of it. Added 5 SNMP scripts that use the new library o [NSE] Added a new library for LDAP. o [NSE] Added a new library for PostgreSQL. o [NSE] Added 5 new MySQL NSE scripts and a MySQL library. o Added version detection match line for the Arucer backdoor. o [Zenmap] several localization improvements. o NetBSD pkgsrc patch for reading the interface table integrated. o Added a service probe for Logitech SqueezeCenter command line interface. o Added service probes and UDP payloads for games based on the Quake 2 and Quake 3 engine. o [Ncat] Added support for HTTP digest authentication of proxies. o [NSE] Added a new library afp.lua which handles the Apple Filing Protocol (AFP) filesharing system. o Added an Apple Filing Protocol service probe. And as usual, a lot of bugfixes and improvements!
34 lines
1 KiB
Text
34 lines
1 KiB
Text
$NetBSD: patch-aa,v 1.1 2010/03/30 21:12:04 pettai Exp $
|
|
|
|
--- Makefile.in.orig 2009-06-24 22:35:54.000000000 +0100
|
|
+++ Makefile.in
|
|
@@ -24,8 +24,8 @@ CXX = @CXX@
|
|
CCOPT =
|
|
DBGFLAGS =
|
|
STRIP = @STRIP@
|
|
-LIBPCAPDIR = @libpcapdir@
|
|
-LIBPCREDIR = @LIBPCREDIR@
|
|
+#LIBPCAPDIR = @libpcapdir@
|
|
+#LIBPCREDIR = @LIBPCREDIR@
|
|
export LIBDNETDIR = @LIBDNETDIR@
|
|
ZENMAPDIR = zenmap
|
|
NDIFFDIR = ndiff
|
|
@@ -95,14 +95,14 @@ $(TARGET): @LUA_DEPENDS@ @PCAP_DEPENDS@
|
|
rm -f $@
|
|
$(CXX) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
|
|
|
|
-pcre_build: $(LIBPCREDIR)/Makefile
|
|
- @echo Compiling libpcre; cd $(LIBPCREDIR) && $(MAKE)
|
|
+#pcre_build: $(LIBPCREDIR)/Makefile
|
|
+# @echo Compiling libpcre; cd $(LIBPCREDIR) && $(MAKE)
|
|
|
|
dnet_build: $(LIBDNETDIR)/Makefile
|
|
@echo Compiling libdnet; cd $(LIBDNETDIR) && $(MAKE)
|
|
|
|
-pcap_build: $(LIBPCAPDIR)/Makefile
|
|
- @echo Compiling libpcap; cd $(LIBPCAPDIR) && $(MAKE)
|
|
+#pcap_build: $(LIBPCAPDIR)/Makefile
|
|
+# @echo Compiling libpcap; cd $(LIBPCAPDIR) && $(MAKE)
|
|
|
|
nbase_build: $(NBASEDIR)/Makefile
|
|
@echo Compiling libnbase;
|