pkgsrc-wip/gl/patches/patch-ac
Pierre Allegraud 2bf9bcd7b1 Import gl-7.7 as wip/gl.
This is the libGL part of Mesa.

MesaLib is a 3-D graphics library with an API which is very similar to
that of OpenGL*.  To the extent that Mesa utilizes the OpenGL command syntax
or state machine, it is being used with authorization from Silicon Graphics,
Inc.  However, the author makes no claim that Mesa is in any way a
compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
2010-01-03 14:32:17 +00:00

21 lines
811 B
Text

$NetBSD: patch-ac,v 1.1.1.1 2010/01/03 14:32:17 pallegra Exp $
--- src/glu/Makefile.orig 2009-09-28 18:55:24.000000000 +0000
+++ src/glu/Makefile
@@ -28,10 +28,12 @@ glu.pc: glu.pc.in
$(pcedit) $< > $@
install: glu.pc
- $(INSTALL) -d $(DESTDIR)$(INSTALL_LIB_DIR)
- $(INSTALL) -d $(DESTDIR)$(INSTALL_LIB_DIR)/pkgconfig
- $(MINSTALL) $(TOP)/$(LIB_DIR)/$(GLU_LIB_GLOB) $(DESTDIR)$(INSTALL_LIB_DIR)
- $(INSTALL) -m 644 glu.pc $(DESTDIR)$(INSTALL_LIB_DIR)/pkgconfig
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(INSTALL_DIR)/lib
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(INSTALL_DIR)/lib/pkgconfig
+ $(LIBTOOL) --mode=install \
+ $(BSD_INSTALL_LIB) $(TOP)/$(LIB_DIR)/libGLU.la \
+ $(DESTDIR)$(INSTALL_DIR)/lib
+ $(BSD_INSTALL_DATA) glu.pc $(DESTDIR)$(INSTALL_DIR)/lib/pkgconfig
clean:
-@for dir in $(SUBDIRS) ; do \