Collection. This is the same source as the Debian package. mod_auth_mysql will allow you to use a MySQL database to authenticate users with the Apache HTTP server.
30 lines
623 B
Text
30 lines
623 B
Text
$NetBSD: patch-ab,v 1.1.1.1 2003/11/24 09:46:32 cubidou Exp $
|
|
|
|
--- configure.ac.orig 2003-09-24 01:39:03.000000000 +0200
|
|
+++ configure.ac
|
|
@@ -84,11 +84,14 @@ AC_SUBST(build_opts, "$mysql_includes $m
|
|
|
|
# Checks for header files.
|
|
AC_CHECK_HEADERS([crypt.h])
|
|
+AC_CHECK_LIB([crypt], [crypt])
|
|
|
|
-if test -n $HAVE_CRYPT_H; then
|
|
+if test -n $HAVE_CRYPT_H -a $HAVE_LIBCRYPT; then
|
|
AC_TRY_RUN(
|
|
[
|
|
+#ifdef HAVE_CRYPT_H
|
|
#include <crypt.h>
|
|
+#endif
|
|
#include <string.h>
|
|
|
|
int main()
|
|
@@ -101,7 +104,9 @@ AC_DEFINE(CRYPT_MD5),
|
|
,,)
|
|
AC_TRY_RUN(
|
|
[
|
|
+#ifdef HAVE_CRYPT_H
|
|
#include <crypt.h>
|
|
+#endif
|
|
#include <string.h>
|
|
|
|
int main()
|