43 lines
1.4 KiB
Text
43 lines
1.4 KiB
Text
$NetBSD: patch-ab,v 1.2 2003/07/31 15:12:39 bencollver Exp $
|
|
|
|
--- src/Makefile.orig Tue May 29 07:36:53 2001
|
|
+++ src/Makefile
|
|
@@ -14,7 +14,7 @@ VPATH = $(srcdir)/src
|
|
# Compiler Section (overrides Makefile.cfg)
|
|
#----------------------------------------------------------------------
|
|
|
|
-INCLUDES += -I$(srcdir)/src
|
|
+INCLUDES += -I$(srcdir)/src -I$(srcdir)/src/config
|
|
|
|
#----------------------------------------------------------------------
|
|
# Rules Section
|
|
@@ -387,8 +387,9 @@ all: libvga.so.$(VERSION)
|
|
|
|
# These rules are for ELF only.
|
|
libvga.so.$(VERSION): $(ALLOBJS)
|
|
- $(CC) -s -shared -Wl,-soname,libvga.so.$(MAJOR_VER) \
|
|
- -o libvga.so.$(VERSION) $(ALLOBJS) -lm
|
|
+ $(CC) -shared -Wl,-soname,libvga.so.$(MAJOR_VER) \
|
|
+ -o libvga.so.$(VERSION) $(ALLOBJS) -lm -li386
|
|
+ /bin/ln -sf libvga.so.$(VERSION) libvga.so
|
|
|
|
$(sharedlibdir)/libvga.so.$(VERSION): libvga.so.$(VERSION)
|
|
$(INSTALL_PROGRAM) $< $(sharedlibdir)/$<
|
|
@@ -403,7 +404,7 @@ libvga.a: $(ALLOBJS)
|
|
$(AR) rcs libvga.a $(ALLOBJS)
|
|
|
|
libvgagl.a: FORCE
|
|
- make -f $(srcdir)/gl/Makefile $@ srcdir="$(srcdir)" DLLFLAGS="$(DLLFLAGS)"
|
|
+ $(MAKE) -f $(srcdir)/gl/Makefile $@ srcdir="$(srcdir)" DLLFLAGS="$(DLLFLAGS)"
|
|
|
|
vga.o: vga.c
|
|
$(CC) $(CFLAGS) $(VGA_DEFINES) -c -o $@ $<
|
|
@@ -425,7 +426,7 @@ $(MODULES): .depend.src
|
|
|
|
dep:
|
|
rm -f .depend.src
|
|
- make .depend.src
|
|
+ $(MAKE) .depend.src
|
|
|
|
.depend.src:
|
|
echo '# Module dependencies' >>.depend.src
|