Tommy Frandsen. VGAlib supported a number of standard VGA graphics modes, as well high resolution/high color modes on many popular graphics adapters. As of now, support for many more chipsets has been added. It supports transparent virtual console switching, that is, you can switch consoles to and from text and graphics mode consoles using alt-[function key]. Also, svgalib corrects most of VGAlib's textmode corruption behaviour by catching SIGSEGV, SIGFPE, SIGILL, and other fatal signals and ensuring that a program is running in the currently visible virtual console before setting a graphics mode.
13 lines
402 B
Text
13 lines
402 B
Text
$NetBSD: patch-ar,v 1.1.1.1 2003/07/27 06:03:36 bencollver Exp $
|
|
|
|
--- demos/Makefile.orig Fri Aug 25 06:09:33 2000
|
|
+++ demos/Makefile
|
|
@@ -29,7 +29,7 @@
|
|
|
|
# Determine what library (static or shared) we will be linking programs with
|
|
ifdef INSTALLSHAREDLIB
|
|
- LIBS = -lvgagl -lvga
|
|
+ LIBS = -L../sharedlib -lvgagl -lvga
|
|
endif
|
|
ifndef LIBS
|
|
LIBS = ../staticlib/libvgagl.a ../staticlib/libvga.a -lm
|