18 lines
569 B
Text
18 lines
569 B
Text
$NetBSD: patch-js_src_Makefile.in,v 1.1 2013/05/24 03:28:04 makoto Exp $
|
|
|
|
--- js/src/Makefile.in.orig 2013-05-11 19:19:32.000000000 +0000
|
|
+++ js/src/Makefile.in
|
|
@@ -791,6 +791,13 @@ EXTRA_LIBS += -lposix4 -ldl -lnsl -lsock
|
|
endif
|
|
endif
|
|
|
|
+# clang 3.3 + -O2 makes jaeger crash in FixupArity
|
|
+ifdef CLANG_CXX
|
|
+ifndef MOZ_DEBUG
|
|
+Compiler.$(OBJ_SUFFIX): CXXFLAGS += -fno-inline-functions
|
|
+endif
|
|
+endif
|
|
+
|
|
# An AIX Optimization bug causes PR_dtoa() & JS_dtoa to produce wrong result.
|
|
# This suppresses optimization for this single compilation unit.
|
|
ifeq ($(OS_ARCH),AIX)
|