55 lines
2.3 KiB
Text
55 lines
2.3 KiB
Text
$NetBSD: patch-ak,v 1.7 2013/01/25 03:22:09 asau Exp $
|
|
|
|
Install configuration files into example directory.
|
|
|
|
--- ompi/etc/Makefile.in.orig 2013-01-15 14:41:30.000000000 +0100
|
|
+++ ompi/etc/Makefile.in 2013-01-24 12:36:01.150707935 +0100
|
|
@@ -51,6 +51,7 @@
|
|
test $$am__dry = yes; \
|
|
}
|
|
pkgdatadir = $(datadir)/@PACKAGE@
|
|
+sysconfexampledir = $(pkgdatadir)/examples
|
|
pkgincludedir = $(includedir)/@PACKAGE@
|
|
pkglibdir = $(libdir)/@PACKAGE@
|
|
pkglibexecdir = $(libexecdir)/@PACKAGE@
|
|
@@ -1536,19 +1537,19 @@
|
|
# details why the mkdir is in install-data-local.
|
|
|
|
install-data-local:
|
|
- $(MKDIR_P) $(DESTDIR)$(sysconfdir)
|
|
+ $(MKDIR_P) $(DESTDIR)$(sysconfexampledir)
|
|
@ p="$(ompi_config_files)"; \
|
|
for file in $$p; do \
|
|
- if test -f $(DESTDIR)$(sysconfdir)/$$file; then \
|
|
+ if test -f $(DESTDIR)$(sysconfexampledir)/$$file; then \
|
|
echo "******************************* WARNING ************************************"; \
|
|
echo "*** Not installing new $$file over existing file in:"; \
|
|
- echo "*** $(DESTDIR)$(sysconfdir)/$$file"; \
|
|
+ echo "*** $(DESTDIR)$(sysconfexampledir)/$$file"; \
|
|
echo "******************************* WARNING ************************************"; \
|
|
else \
|
|
if test -f "$$file"; then d=; else d="$(srcdir)/"; fi; \
|
|
f="`echo $$file | sed -e 's|^.*/||'`"; \
|
|
- echo " $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfdir)/$$f"; \
|
|
- $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfdir)/$$f; \
|
|
+ echo " $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfexampledir)/$$f"; \
|
|
+ $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfexampledir)/$$f; \
|
|
fi; \
|
|
done
|
|
|
|
@@ -1559,11 +1560,11 @@
|
|
uninstall-local:
|
|
@ p="$(ompi_config_files)"; \
|
|
for file in $$p; do \
|
|
- if test -f "$(DESTDIR)$(sysconfdir)/$$file"; then \
|
|
+ if test -f "$(DESTDIR)$(sysconfexampledir)/$$file"; then \
|
|
if test -f "$$file"; then d=; else d="$(srcdir)/"; fi; \
|
|
- if diff "$(DESTDIR)$(sysconfdir)/$$file" "$$d$$file" > /dev/null 2>&1 ; then \
|
|
- echo "rm -f $(DESTDIR)$(sysconfdir)/$$file" ; \
|
|
- rm -f "$(DESTDIR)$(sysconfdir)/$$file" ; \
|
|
+ if diff "$(DESTDIR)$(sysconfexampledir)/$$file" "$$d$$file" > /dev/null 2>&1 ; then \
|
|
+ echo "rm -f $(DESTDIR)$(sysconfexampledir)/$$file" ; \
|
|
+ rm -f "$(DESTDIR)$(sysconfexampledir)/$$file" ; \
|
|
fi ; \
|
|
fi ; \
|
|
done
|